aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-11 15:37:44 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-11 15:37:59 +0100
commit1899ece8f99460518e2ea401f288e60e062658eb (patch)
tree674dc6c58c87eaf89a6e92b746e91cf9518255ab
parentUse dev-python/pillow directly instead of virtual/python-imaging (diff)
downloadsci-1899ece8f99460518e2ea401f288e60e062658eb.tar.gz
sci-1899ece8f99460518e2ea401f288e60e062658eb.tar.bz2
sci-1899ece8f99460518e2ea401f288e60e062658eb.zip
sci-chemistry/openbabel-python: Import tree changes
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-chemistry/openbabel-python/metadata.xml2
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-9999.ebuild23
2 files changed, 14 insertions, 11 deletions
diff --git a/sci-chemistry/openbabel-python/metadata.xml b/sci-chemistry/openbabel-python/metadata.xml
index 66b2cb75c..56c946c67 100644
--- a/sci-chemistry/openbabel-python/metadata.xml
+++ b/sci-chemistry/openbabel-python/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-chemistry</herd>
diff --git a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild b/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
index 69c0acd90..03c35f66e 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
inherit cmake-utils eutils git-r3 multilib python-r1
@@ -21,11 +21,9 @@ IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- !sci-chemistry/babel
~sci-chemistry/openbabel-${PV}
sys-libs/zlib"
DEPEND="${RDEPEND}
- >=dev-util/cmake-2.4.8
>=dev-lang/swig-2"
src_prepare() {
@@ -40,6 +38,9 @@ src_prepare() {
-outdir scripts/python \
scripts/openbabel-python.i \
|| die "Regeneration of openbabel-python.cpp failed"
+ sed \
+ -e '/__GNUC__/s:== 4:>= 4:g' \
+ -i include/openbabel/shared_ptr.h || die
}
src_configure() {
@@ -47,12 +48,14 @@ src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_RPATH=
-DBINDINGS_ONLY=ON
- -DBABEL_SYSTEM_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libopenbabel.so
- -DOB_MODULE_PATH="${EPREFIX}"/usr/$(get_libdir)/openbabel/${PV}
+ -DBABEL_SYSTEM_LIBRARY="${EPREFIX}/usr/$(get_libdir)/libopenbabel.so"
+ -DOB_MODULE_PATH="${EPREFIX}/usr/$(get_libdir)/openbabel/${PV}"
+ -DLIB_INSTALL_DIR="${D}$(python_get_sitedir)"
-DPYTHON_BINDINGS=ON
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DPYTHON_INCLUDE_DIR="${EPREFIX}"/usr/include/"${EPYTHON}"
- -DPYTHON_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/lib"${EPYTHON}".so
+ -DPYTHON_EXECUTABLE=${PYTHON}
+ -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON_INCLUDE_PATH="$(python_get_includedir)"
+ -DPYTHON_LIBRARY="$(python_get_library_path)"
-DENABLE_TESTS=ON
)
@@ -74,7 +77,7 @@ src_install() {
my_impl_src_install() {
cd "${BUILD_DIR}" || die
- DESTDIR=${ED} cmake -DCOMPONENT=bindings_python -P cmake_install.cmake
+ cmake -DCOMPONENT=bindings_python -P cmake_install.cmake
python_optimize
}