aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2013-06-16 16:53:55 -0700
committerSébastien Fabbro <bicatali@gentoo.org>2013-06-16 16:53:55 -0700
commit195a1f3287a4bdfbb25b405706ecdf3d7cbafa26 (patch)
tree0f192d36b81ce5eb51261031d08bae288e05f3a7
parentsci-astronomy/chealpix: Initial import (diff)
downloadsci-195a1f3287a4bdfbb25b405706ecdf3d7cbafa26.tar.gz
sci-195a1f3287a4bdfbb25b405706ecdf3d7cbafa26.tar.bz2
sci-195a1f3287a4bdfbb25b405706ecdf3d7cbafa26.zip
sci-astronomy/healpix_cxx: Initial import
Package-Manager: portage-2.2.01.22013-prefix RepoMan-Options: --force
-rw-r--r--sci-astronomy/healpix_cxx/ChangeLog9
-rw-r--r--sci-astronomy/healpix_cxx/Manifest1
-rw-r--r--sci-astronomy/healpix_cxx/healpix_cxx-3.11.ebuild54
-rw-r--r--sci-astronomy/healpix_cxx/metadata.xml12
4 files changed, 76 insertions, 0 deletions
diff --git a/sci-astronomy/healpix_cxx/ChangeLog b/sci-astronomy/healpix_cxx/ChangeLog
new file mode 100644
index 000000000..fa357f4bd
--- /dev/null
+++ b/sci-astronomy/healpix_cxx/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-astronomy/healpix_cxx
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*healpix_cxx-3.11 (16 Jun 2013)
+
+ 16 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> +healpix_cxx-3.11.ebuild,
+ +metadata.xml:
+ sci-astronomy/healpix_cxx: Initial import
diff --git a/sci-astronomy/healpix_cxx/Manifest b/sci-astronomy/healpix_cxx/Manifest
new file mode 100644
index 000000000..983581ad4
--- /dev/null
+++ b/sci-astronomy/healpix_cxx/Manifest
@@ -0,0 +1 @@
+DIST Healpix_3.11_2013Apr24.tar.gz 24256278 SHA256 f80aa3633601664afe99c8b7dc7253828f22e6d832187ab46ac90b2ad83e6831 SHA512 aae5592dda40103918a6c6520863e2aeddf40a34531e4ce2f38a1ce7411731218d7e20bd02107f92384a7b371c2415ed640ad27aa398f64857f5ed7d9dba32bb WHIRLPOOL 1e3f0588502b6b9e68c19de9763ae775d01031cd7a3120bb663a71bae1fa7e2baf6ac4997ff07598ca45e610ae919839ecf04c66a201256665f5e5f1727f7299
diff --git a/sci-astronomy/healpix_cxx/healpix_cxx-3.11.ebuild b/sci-astronomy/healpix_cxx/healpix_cxx-3.11.ebuild
new file mode 100644
index 000000000..f25aa9d8e
--- /dev/null
+++ b/sci-astronomy/healpix_cxx/healpix_cxx-3.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils toolchain-funcs
+
+MYP="Healpix_${PV}"
+MYPP="2013Apr24"
+
+DESCRIPTION="Hierarchical Equal Area isoLatitude Pixelization of a sphere - C++"
+HOMEPAGE="http://healpix.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}/${MYP}_${MYPP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="openmp static-libs"
+
+RDEPEND="
+ >=sci-libs/cfitsio-3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MYP}/src/cxx/autotools"
+
+DOCS=( ../CHANGES ../../../READ_Copyrights_Licenses.txt )
+
+pkg_setup() {
+ if use openmp; then
+ if [[ $(tc-getCXX)$ == *g++* ]] && ! tc-has-openmp; then
+ ewarn "You are using a g++ without OpenMP capabilities"
+ die "Need an OpenMP capable compiler"
+ fi
+ fi
+}
+
+src_prepare() {
+ # respect user flags
+ sed -i -e '/^AX_CHECK_COMPILE_FLAG/d' configure.ac || die
+ # why was static-libtool-libs forced?
+ use static-libs || sed -i -e '/-static-libtool-libs/d' Makefile.am
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable openmp)
+ )
+ autotools-utils_src_configure
+}
diff --git a/sci-astronomy/healpix_cxx/metadata.xml b/sci-astronomy/healpix_cxx/metadata.xml
new file mode 100644
index 000000000..391b83cad
--- /dev/null
+++ b/sci-astronomy/healpix_cxx/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ HEALPix is an acronym for Hierarchical Equal Area isoLatitude
+ Pixelization of a sphere. As suggested in the name, this pixelization produces a
+ subdivision of a spherical surface in which each pixel covers the same
+ surface area as every other pixel. This package contains the C++
+ library and programs.
+</longdescription>
+</pkgmetadata>