aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin <jlec@j-schmitz.net>2013-02-22 07:29:11 -0800
committerJustin <jlec@j-schmitz.net>2013-02-22 07:29:11 -0800
commit19bab92b6915b5369759364cf47edf4ab05df4f8 (patch)
tree0cb4f78eae53eb65eb2a39690c60c026d89e84af
parentdev-ml/lacaml: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of pl... (diff)
parentuse T for temp file (diff)
downloadsci-19bab92b6915b5369759364cf47edf4ab05df4f8.tar.gz
sci-19bab92b6915b5369759364cf47edf4ab05df4f8.tar.bz2
sci-19bab92b6915b5369759364cf47edf4ab05df4f8.zip
Merge pull request #28 from jamasi/master
adding geo-sciences/fullprof-bin to the sci-overlay
-rw-r--r--sci-geosciences/fullprof-bin/Manifest1
-rw-r--r--sci-geosciences/fullprof-bin/fullprof-bin-2012.11.ebuild63
-rw-r--r--sci-geosciences/fullprof-bin/metadata.xml16
3 files changed, 80 insertions, 0 deletions
diff --git a/sci-geosciences/fullprof-bin/Manifest b/sci-geosciences/fullprof-bin/Manifest
new file mode 100644
index 000000000..f73f25280
--- /dev/null
+++ b/sci-geosciences/fullprof-bin/Manifest
@@ -0,0 +1 @@
+DIST FullProf_Suite_Nov2012_Lin.tgz 66985149 SHA256 22fa6165f299e67c28439eba2c7d9469fff637bbf873cee4006581d4b8e89398 SHA512 c02933d8cbbfc1ec0d9818ec63f3a0102f0a659b0c38371ed7103a082a87e21b33d2075bb2c7d8357f216b347e0f11bfbc39d6dfd5cba22854438cc2b8586243 WHIRLPOOL 8df64c3b87b381ea28542bdcb513cb83eeaa91d656d1717ef18e2d96803590da415703d2ff6e0d2f9ac9e2ec059552252f41707811e078c28c010c2b58d4bdd7
diff --git a/sci-geosciences/fullprof-bin/fullprof-bin-2012.11.ebuild b/sci-geosciences/fullprof-bin/fullprof-bin-2012.11.ebuild
new file mode 100644
index 000000000..7c41344fe
--- /dev/null
+++ b/sci-geosciences/fullprof-bin/fullprof-bin-2012.11.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+DESCRIPTION="a set of crystallographic tools mainly for Rietveld analysis"
+HOMEPAGE="http://www.ill.eu/sites/fullprof/index.html"
+SRC_URI="http://www.ill.eu/sites/fullprof/downloads/FullProf_Suite_Nov2012_Lin.tgz"
+LICENSE="freedist HPND"
+# There is no clear license specified. But according to Docs/Readme_Fp_Suite.txt
+# those two seem to be appropriate.
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="+X +doc +examples"
+
+RDEPEND="X? ( >=x11-libs/motif-2.3 )"
+
+S="${WORKDIR}/"
+
+src_install() {
+ BASEDIR="/opt/fullprof"
+ echo "FULLPROF=\"${BASEDIR}\"" > ${T}/99fullprof
+ doenvd ${T}/99fullprof
+
+ if use !examples; then
+ rm -r Examples || die
+ fi
+
+ if use !doc; then
+ rm -r Docs || die
+ rm -r Html || die
+ else
+ # fix (html) documentation to actually work
+ # as upstream is using inconsistent upper and lower case
+ mv Docs docs || die
+ cd docs || die
+ for i in *.HTM; do
+ mv "$i" "${i,,}" || die
+ done
+ mv "FullProf_Manual.pdf" "Fullprof_Manual.pdf" || die
+ mv "Manual_FullProf_Studio.pdf" "Manual_Fullprof_Studio.pdf" || die
+ mv "FullProf_News.htm" "Fullprof_News.htm" || die
+ for i in FullProf_News_200?.htm; do
+ mv "$i" "${i/FullProf/Fullprof}" || die
+ done
+ cd .. || die
+ fi
+
+ if use !X; then
+ rm tfp tfp.set winplotr-2006 check_group cryscal edpcr fp_studio || die
+ rm gbasireps gbond_str gdatared gfourier gfourier.hlp gxlens || die
+ rm powderpat resvis symmcal wfp2k winplotr.* || die
+ rm -r Fps_Icons || die
+ fi
+
+ mkdir -p "${D}/${BASEDIR}" || die
+ # make symlinks
+ for i in * ; do
+ [[ -x $i && ! -d $i ]] && dosym "../fullprof/${i}" /opt/bin/"${i##*/}"
+ done
+ mv "${S}"/* "${D}/${BASEDIR}" || die
+}
diff --git a/sci-geosciences/fullprof-bin/metadata.xml b/sci-geosciences/fullprof-bin/metadata.xml
new file mode 100644
index 000000000..46b265804
--- /dev/null
+++ b/sci-geosciences/fullprof-bin/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-geosciences</herd>
+<maintainer>
+<email>marten@xtal.rwth-aachen.de</email>
+<name>Jan M. Simons</name>
+</maintainer>
+<longdescription lang="en">
+Fullprof is a programm suite of crystallographic programs (FullProf, WinPLOTR,
+EdPCR, GFourier, etc...) mainly developed for Rietveld analysis (structure
+profile refinement) of neutron (constant wavelength, time of flight,
+nuclear and magnetic scattering) or X-ray powder diffraction data collected at
+constant or variable step in scattering angle 2theta.
+</longdescription>
+</pkgmetadata>