aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <seb@cayenne.ist.utl.pt>2010-01-22 18:33:29 +0000
committerSebastien Fabbro <seb@cayenne.ist.utl.pt>2010-01-22 18:33:29 +0000
commit1c109000c4d979a7bcb36c23dec5a4ae01a8d560 (patch)
treea2a1a24edcfc3cd2205cdff0d9307a02df79b0b8
parentmove EGIT stuff up before inherit (diff)
downloadsci-1c109000c4d979a7bcb36c23dec5a4ae01a8d560.tar.gz
sci-1c109000c4d979a7bcb36c23dec5a4ae01a8d560.tar.bz2
sci-1c109000c4d979a7bcb36c23dec5a4ae01a8d560.zip
Initial import of hdf-java
-rw-r--r--dev-java/hdf-java/ChangeLog10
-rw-r--r--dev-java/hdf-java/Manifest5
-rw-r--r--dev-java/hdf-java/files/hdf-java-2.6-shared.patch113
-rw-r--r--dev-java/hdf-java/hdf-java-2.6.ebuild60
-rw-r--r--dev-java/hdf-java/metadata.xml17
-rw-r--r--dev-java/jeuclid-core/Manifest3
-rw-r--r--dev-java/jeuclid-core/files/jeuclid-core-no-freehep.patch10
-rw-r--r--dev-java/jeuclid-core/jeuclid-core-3.1.8.ebuild56
-rw-r--r--dev-java/jgraphx/Manifest2
-rw-r--r--dev-java/jgraphx/jgraphx-1.0.2.8.ebuild41
-rw-r--r--dev-java/jlatexmath/Manifest2
-rw-r--r--dev-java/jlatexmath/jlatexmath-0.8.7.ebuild32
12 files changed, 351 insertions, 0 deletions
diff --git a/dev-java/hdf-java/ChangeLog b/dev-java/hdf-java/ChangeLog
new file mode 100644
index 000000000..85c88a06a
--- /dev/null
+++ b/dev-java/hdf-java/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-java/hdf-java
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*hdf-java-2.6 (22 Jan 2010)
+
+ 22 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org> +hdf-java-2.6.ebuild,
+ +files/hdf-java-2.6-shared.patch, +metadata.xml:
+ Initial import. Ebuild initially submitted by Guillaume Horel, bug #301049
+
diff --git a/dev-java/hdf-java/Manifest b/dev-java/hdf-java/Manifest
new file mode 100644
index 000000000..f1a1e237f
--- /dev/null
+++ b/dev-java/hdf-java/Manifest
@@ -0,0 +1,5 @@
+AUX hdf-java-2.6-shared.patch 3588 RMD160 cf8525d63a5e6336ed105fbfaf11d32eb5700e40 SHA1 c646d28f33f150d8799d1d5edb95683a36e4c2b0 SHA256 0a9b58894066159fa3296f3a4a9895242ced1d1bdf3b585033116f07d1c60675
+DIST hdf-java-2.6-src.tar 10321920 RMD160 2251033e66f8a24e9e2eccd3261cc46960f72b92 SHA1 5b7a6adc00348469f225c6a157ad03764642f1e9 SHA256 52a838d2e14417e573cc531317adc72f360ecb34dd6cce01b5386b2ffd6164f6
+EBUILD hdf-java-2.6.ebuild 1362 RMD160 650ddbbea8f9385c02dd0dd0416ffc7c98cc8ffe SHA1 2bad645eb1bd7bacecd5951d6db213e93d2f745f SHA256 1b5590c77f6009dd0ba363e7dc1740602f4297b158a9db5a6ae53c970bbc5c53
+MISC ChangeLog 353 RMD160 cec510bb170ac4591988623cc8f84e8fe3b7cd7a SHA1 d31c9abf92665df40805f3180f88954a6fd8eaaf SHA256 b56a9be8fa8d28f3f1b0c4535c5530cf37813fdbd03e217f491796cf3d3cf11e
+MISC metadata.xml 695 RMD160 ba84297087b26c64b36a4a5c269187ddbfe0563f SHA1 bc11c02484fab4059dd22881d4714d7b77caed37 SHA256 97a459b5696f58666686ad9722dd445459352350eef1d568097ac420de4a4954
diff --git a/dev-java/hdf-java/files/hdf-java-2.6-shared.patch b/dev-java/hdf-java/files/hdf-java-2.6-shared.patch
new file mode 100644
index 000000000..c41b9584d
--- /dev/null
+++ b/dev-java/hdf-java/files/hdf-java-2.6-shared.patch
@@ -0,0 +1,113 @@
+--- configure.in.orig 2010-01-22 08:30:29.000000000 +0000
++++ configure.in 2010-01-22 08:32:18.000000000 +0000
+@@ -177,7 +177,7 @@
+ *)
+ if test -n "$withval" ; then
+ z_lib="`echo $withval |cut -f2 -d, -s`"
+- ZLIB=$z_lib"/libz."$LLEXT
++ ZLIB="-L$z_lib -lz"
+ HAVE_ZLIB="yes"
+ else
+ ZLIB=""
+@@ -211,7 +211,7 @@
+ *)
+ if test -n "$withval" ; then
+ jpeg_lib="`echo $withval |cut -f2 -d, -s`"
+- JPEGLIB=$jpeg_lib"/libjpeg."$LLEXT
++ JPEGLIB="-L$jpeg_lib -ljpeg"
+ #AC_MSG_RESULT([jpeg found: $JPEGLIB]);
+ HAVE_JPEG="yes"
+ else
+@@ -246,7 +246,7 @@
+ *)
+ if test -n "$withval" ; then
+ sz_lib="`echo $withval |cut -f2 -d, -s`"
+- SZLIB=$sz_lib"/libsz."$LLEXT
++ SZLIB="-L$sz_lib -lsz"
+ #AC_MSG_RESULT([szlib found: $SZLIB]);
+ HAVE_SZIP="yes"
+ else
+@@ -302,7 +302,7 @@
+ ;;
+ esac
+ if test -n "$HDF4LIB"; then
+- LIBS="$HDF4LIB/libdf.$LLEXT $HDF4LIB/libmfhdf.$LLEXT $LIBS"
++ LIBS="-L$HDF4LIB -ldf -lmfhdf $LIBS"
+ HAVE_HDF4="yes"
+ fi
+ AC_MSG_RESULT([$HAVE_HDF4])
+@@ -363,7 +363,7 @@
+ *)
+ if test -n "$withval" ; then
+ hdf5_lib="`echo $withval |cut -f2 -d, -s`"
+- HDF5LIB=$hdf5_lib"/libhdf.$LLEXT"
++ HDF5LIB="-L$hdf5_lib -lhdf"
+ hdf5_inc="`echo $withval |cut -f1 -d,`"
+ if test -n "$hdf5_inc"; then
+ HDF5INC="$hdf5_inc"
+@@ -380,7 +380,7 @@
+ ;;
+ esac
+ if test -n "$HDF5LIB"; then
+- LIBS="$HDF5LIB/libhdf5.$LLEXT $LIBS"
++ LIBS="-L$HDF5LIB -lhdf5 $LIBS"
+ HAVE_HDF5="yes"
+ fi
+ AC_MSG_RESULT([$HAVE_HDF5])
+@@ -626,6 +626,7 @@
+ AC_CACHE_CHECK("JH45 install directory",ac_cv_lib_JH45INST,JH45INST_FOUND=0)
+ fi
+ if test $JH45INST_FOUND -eq 1; then
++ mkdir -p $JH45INST
+ if test -z "$JH45INST" ; then
+ JH45INST=$ac_cv_lib_JH45INST;
+ fi
+@@ -633,7 +634,7 @@
+ JH45INST_FOUND=0
+ fi
+ if test \( ! -w "$JH45INST" \); then
+- AC_MSG_ERROR( [ $JAVINST : not writable ])
++ AC_MSG_ERROR( [ $JH45INST : not writable ])
+ JH45INST_FOUND=0
+ fi
+ fi
+--- native/hdflib/Makefile.in.orig 2010-01-22 08:40:36.000000000 +0000
++++ native/hdflib/Makefile.in 2010-01-22 09:01:17.000000000 +0000
+@@ -37,7 +37,7 @@
+ CFLAGS = $(DEFS) -I. -I$(JAVAINC1) -I$(JAVAINC2) -I$(HDFINC)
+
+ # Be sure to add -lbsd if compiling in a SYSV environment
+-LIBS = $(HDFLIB)/libmfhdf.$(LLEXT) $(HDFLIB)/libdf.$(LLEXT) $(SZLIB) $(ZLIB) $(JPEGLIB) -lm
++LIBS = -L$(HDFLIB) -lmfhdf -ldf $(SZLIB) $(ZLIB) $(JPEGLIB) -lm
+
+ # Macro def: object filename used
+ OBJECTS = hdfstructsutil.o \
+@@ -56,7 +56,7 @@
+
+ libjhdf: $(OBJECTS)
+ -mkdir -p $(LIBDIR);
+- $(LD) $(LDOPT) -o $(LIBDIR)/libjhdf.$(JSLEXT) $(LDOPT2) $(OBJECTS) $(LIBS)
++ $(LD) $(LDOPT) $(LDFLAGS) -o $(LIBDIR)/libjhdf.$(JSLEXT) $(LDOPT2) $(OBJECTS) $(LIBS)
+
+ clean:
+ $(RM) -f *.o so_locations $(LIBDIR)/libjhdf.$(JSLEXT)
+--- native/hdf5lib/Makefile.in.orig 2010-01-22 08:40:59.000000000 +0000
++++ native/hdf5lib/Makefile.in 2010-01-22 09:01:40.000000000 +0000
+@@ -33,7 +33,7 @@
+
+ CFLAGS = -DH5_USE_16_API -D_FILE_OFFSET_BITS=64 $(DEFS) -I. -I$(HDF5INC) -I$(JAVAINC1) -I$(JAVAINC2)
+
+-LIBS = $(HDF5LIB)/libhdf5.$(LLEXT) $(ZLIB) $(SZLIB) -lm
++LIBS = -L$(HDF5LIB) -lhdf5 $(ZLIB) $(SZLIB) -lm
+
+ # Macro def: object filename used
+ OBJECTS = exceptionImp.o h5Constants.o h5Imp.o h5aImp.o h5dImp.o h5fImp.o h5gImp.o h5iImp.o h5pImp.o h5rImp.o h5sImp.o h5tImp.o nativeData.o h5util.o h5zImp.o
+@@ -45,7 +45,7 @@
+
+ libjhdf5: $(OBJECTS)
+ -mkdir -p $(LIBDIR);
+- $(LD) $(LDOPT) -o $(LIBDIR)/libjhdf5.$(JSLEXT) $(LDOPT2) $(OBJECTS) $(LIBS)
++ $(LD) $(LDOPT) $(LDFLAGS) -o $(LIBDIR)/libjhdf5.$(JSLEXT) $(LDOPT2) $(OBJECTS) $(LIBS)
+
+ clean:
+ $(RM) -f *.o so_locations $(LIBDIR)/libjhdf5.$(JSLEXT)
diff --git a/dev-java/hdf-java/hdf-java-2.6.ebuild b/dev-java/hdf-java/hdf-java-2.6.ebuild
new file mode 100644
index 000000000..fb08380ce
--- /dev/null
+++ b/dev-java/hdf-java/hdf-java-2.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+JAVA_PKG_IUSE="doc examples source"
+inherit eutils java-pkg-2 autotools
+
+DESCRIPTION="Java interface to the HDF5 library"
+HOMEPAGE="http://www.hdfgroup.org/hdf-java-html/index.html"
+SRC_URI="http://www.hdfgroup.org/ftp/HDF5/hdf-java/src/${P}-src.tar"
+
+LICENSE="NCSA-HDF"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hdf"
+
+CDEPEND=">=sci-libs/hdf5-1.8[szip]
+ hdf? ( sci-libs/hdf )
+ >=media-libs/jpeg-7
+ sys-libs/zlib"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ ${CDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e 's|case JH5F_SCOPE_DOWN|//case JH5F_SCOPE_DOWN|' \
+ native/hdf5lib/h5Constants.c || die
+ epatch "${FILESDIR}"/${P}-shared.patch
+ eautoreconf
+}
+
+src_configure() {
+ local stdpath="/usr/include,/usr/$(get_libdir)"
+ local myconf="--with-hdf4=no --with-libjpeg=no"
+ use hdf && \
+ myconf="--with-libjpeg=${stdpath} --with-hdf4=${stdpath}"
+
+ econf \
+ ${myconf} \
+ --with-libz="${stdpath}" \
+ --with-libsz="${stdpath}" \
+ --with-hdf5="${stdpath}" \
+ --with-jdk="$(java-config -o)/include,$(java-config -o)/jre/lib"
+}
+
+src_compile() {
+ # parallel needs work. anyone?
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ java-pkg_dojar "lib/jhdf5.jar"
+ java-pkg_doso "lib/linux/libjhdf5.so"
+}
diff --git a/dev-java/hdf-java/metadata.xml b/dev-java/hdf-java/metadata.xml
new file mode 100644
index 000000000..379252764
--- /dev/null
+++ b/dev-java/hdf-java/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ HDF is a versatile data model that can represent very complex data
+ objects and a wide variety of metadata. It is a completely portable
+ file format with no limit on the number or size of data objects in
+ the collection.
+ 1;2202;0c This Java package implements HDF4/HDF5 data objects in an object-oriented
+ form. It provides a common Java API for accessing HDF files.
+</longdescription>
+<use>
+ <flag name='hdf'>Add support for the Hierarchical Data Format v.4
+ (<pkg>sci-libs/hdf</pkg>)</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-java/jeuclid-core/Manifest b/dev-java/jeuclid-core/Manifest
new file mode 100644
index 000000000..60ddc6321
--- /dev/null
+++ b/dev-java/jeuclid-core/Manifest
@@ -0,0 +1,3 @@
+AUX jeuclid-core-no-freehep.patch 338 RMD160 d12ce25165fe85517b58a7c77ad27ee36c337479 SHA1 aa19c59bd604795ba15dd77f2a91f3f7532f8d3d SHA256 a9ef36f83728a13563ea4ae1de3a0a6ad25e6cae9d5edcca0ed9c93c2d551292
+DIST jeuclid-parent-3.1.8-src.zip 8844588 RMD160 4f7a6f2fc5acd3bba23c0aa715798140dda17836 SHA1 02647c735f620e194e2177d779c16ca027e7b674 SHA256 4c80740a78bef42c6e5b87e09df931448caa210469382270ac4f70016ac21a0c
+EBUILD jeuclid-core-3.1.8.ebuild 1528 RMD160 a6e160be4c89ef48952dbb2e9208a1d3d26a0e49 SHA1 ce17ad393ac14941e286d3725432548491fefdd3 SHA256 3fc6c09fc1daa79b28c3f3b1d864b9f4e34c3cb8a8278075838305c1641cb581
diff --git a/dev-java/jeuclid-core/files/jeuclid-core-no-freehep.patch b/dev-java/jeuclid-core/files/jeuclid-core-no-freehep.patch
new file mode 100644
index 000000000..798dac293
--- /dev/null
+++ b/dev-java/jeuclid-core/files/jeuclid-core-no-freehep.patch
@@ -0,0 +1,10 @@
+--- build.xml.orig 2010-01-22 17:46:35.000000000 +0000
++++ build.xml 2010-01-22 17:49:07.000000000 +0000
+@@ -113,6 +113,7 @@
+ <src>
+ <pathelement location="src/main/java"/>
+ </src>
++ <exclude name="**/FreeHep*" />
+ <classpath refid="libs-build-classpath"/>
+ </javac>
+ <copy todir="${build.output}">
diff --git a/dev-java/jeuclid-core/jeuclid-core-3.1.8.ebuild b/dev-java/jeuclid-core/jeuclid-core-3.1.8.ebuild
new file mode 100644
index 000000000..dca987736
--- /dev/null
+++ b/dev-java/jeuclid-core/jeuclid-core-3.1.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Core module of MathML rendering solution."
+HOMEPAGE="http://jeuclid.sourceforge.net"
+SRC_URI="mirror://sourceforge/jeuclid/jeuclid-parent-${PV}-src.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="dev-java/ant-core
+ dev-java/batik:1.7
+ dev-java/commons-logging
+ dev-java/jcip-annotations
+ dev-java/xml-commons-external:1.3
+ dev-java/xmlgraphics-commons:1.3"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}/jeuclid-parent-${PV}/${PN}"
+
+src_prepare() {
+ # remove support of FreeHep from JAVA files (not needed for FOP plugin)
+ # really not needed?
+ #rm -f src/main/java/net/sourceforge/jeuclid/converter/FreeHep*
+
+ epatch "${FILESDIR}"/${PN}-no-freehep.patch
+
+ # create directory for dependencies
+ mkdir lib || die
+ cd lib || die
+
+ # add dependencies into the lib dir
+ java-pkg_jar-from ant-core ant.jar
+ java-pkg_jar-from batik-1.7 batik-all.jar
+ java-pkg_jar-from commons-logging commons-logging.jar
+ java-pkg_jar-from jcip-annotations jcip-annotations.jar
+ java-pkg_jar-from xml-commons-external-1.3 xml-apis.jar
+ java-pkg_jar-from xmlgraphics-commons-1.3 xmlgraphics-commons.jar
+ #java-pkg_jar-from freehep-util freehep-util.jar
+ #java-pkg_jar-from freehep-graphics2d freehep-graphics2d.jar
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+}
diff --git a/dev-java/jgraphx/Manifest b/dev-java/jgraphx/Manifest
new file mode 100644
index 000000000..819eabd11
--- /dev/null
+++ b/dev-java/jgraphx/Manifest
@@ -0,0 +1,2 @@
+DIST jgraphx-1_0_2_8.zip 2049501 RMD160 368e54870f215322818f20cc76c8630894368d5b SHA1 a3bc134d145ac34e6f2243042d4f309becb966ef SHA256 a7d773b5e797887e48b5b4b9141ae5f773ae7e6e2b15c4b7f6f9d5511919fe17
+EBUILD jgraphx-1.0.2.8.ebuild 1047 RMD160 fe6799778a3645c4f1422ebbf3de8fb2a2800971 SHA1 fb7b29af05f105dce842218b83eaf69608fcbfd4 SHA256 4ff0fade90ac7f7125f0570b1d4b147f21d2731feefd9f9a4f471b0741c489f7
diff --git a/dev-java/jgraphx/jgraphx-1.0.2.8.ebuild b/dev-java/jgraphx/jgraphx-1.0.2.8.ebuild
new file mode 100644
index 000000000..e7d5bd3a1
--- /dev/null
+++ b/dev-java/jgraphx/jgraphx-1.0.2.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgraph/jgraph-5.12.0.4.ebuild,v 1.5 2008/05/13 21:09:16 ken69267 Exp $
+
+JAVA_PKG_IUSE="doc source"
+EAPI=2
+inherit java-pkg-2 java-ant-2 versionator
+
+MY_PV=$(replace_all_version_separators '_')
+
+DESCRIPTION="Open-source graph component for Java"
+SRC_URI="http://guillaume.horel.free.fr/${PN}-${MY_PV}.zip"
+HOMEPAGE="http://www.jgraph.com"
+IUSE="doc examples source"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # don't do javadoc always
+ sed -i \
+ -e 's/depends="doc"/depends="compile"/' \
+ build.xml || die "sed failed"
+ rm -rf doc/api lib/jgraphx.jar || die
+}
+
+EANT_BUILD_TARGET="build"
+EANT_DOC_TARGET="doc"
+
+src_install() {
+ java-pkg_dojar lib/${PN}.jar
+
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc src/org
+ use examples && java-pkg_doexamples examples
+}
diff --git a/dev-java/jlatexmath/Manifest b/dev-java/jlatexmath/Manifest
new file mode 100644
index 000000000..2c7f28f8e
--- /dev/null
+++ b/dev-java/jlatexmath/Manifest
@@ -0,0 +1,2 @@
+DIST jlatexmath-src-0.8.7.jar 932336 RMD160 f115f308051e22076f56a30cb0aa2ab119b44329 SHA1 696b8ab6a4549777297355d5877259498ea99b7e SHA256 09a3282e71f859917b7dff2fcd87998d25acba2b736728cfbb0c2153719b5538
+EBUILD jlatexmath-0.8.7.ebuild 713 RMD160 a9d19cc18e7927ed08f1b1507522aae28fafc4ff SHA1 4aaa67ac7bc6d9ad34a594c85f35eecaac2de602 SHA256 aa14a18c07012a6950f5e0db68001e800b13024e022bd24c3ab50bbb1a9903e4
diff --git a/dev-java/jlatexmath/jlatexmath-0.8.7.ebuild b/dev-java/jlatexmath/jlatexmath-0.8.7.ebuild
new file mode 100644
index 000000000..a41649286
--- /dev/null
+++ b/dev-java/jlatexmath/jlatexmath-0.8.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Java API to render LaTeX"
+SRC_URI="http://forge.scilab.org/index.php/p/${PN}/downloads/29/get/ -> ${PN}-src-${PV}.jar"
+HOMEPAGE="http://forge.scilab.org/index.php/p/jlatexmath"
+
+IUSE="doc examples source"
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+EANT_BUILD_TARGET="buildJar"
+EANT_DOC_TARGET="doc"
+
+S="${WORKDIR}"
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+ use doc && java-pkg_dojavadoc doc
+ use source && java-pkg_dosrc src/org
+}