aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-18 13:01:32 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-18 13:01:32 +0200
commit1d627c06654e471d2c1511af0722e2f8294f8485 (patch)
tree366318b23bc2a339de9a3578f350ddca73c5a3a0
parentdev-python/gffpandas: proposal for a new package (diff)
downloadsci-1d627c06654e471d2c1511af0722e2f8294f8485.tar.gz
sci-1d627c06654e471d2c1511af0722e2f8294f8485.tar.bz2
sci-1d627c06654e471d2c1511af0722e2f8294f8485.zip
dev-python/gffpandas: fix test/doc/prepare
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/gffpandas/gffpandas-1.2.0.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/dev-python/gffpandas/gffpandas-1.2.0.ebuild b/dev-python/gffpandas/gffpandas-1.2.0.ebuild
index 461712be5..12ec9927c 100644
--- a/dev-python/gffpandas/gffpandas-1.2.0.ebuild
+++ b/dev-python/gffpandas/gffpandas-1.2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -15,8 +15,15 @@ SRC_URI="https://github.com/foerstner-lab/${PN}/archive/v${PV}.tar.gz -> ${P}.ta
LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RESTRICT="test"
-DEPEND="dev-python/pandas[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-BDEPEND=""
+RDEPEND="dev-python/pandas[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+
+python_prepare_all() {
+ # Do not depend on pytest-runner
+ sed -i -e '/pytest-runner/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}