aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin <jlec@users.noreply.github.com>2013-11-14 23:28:40 -0800
committerJustin <jlec@users.noreply.github.com>2013-11-14 23:28:40 -0800
commit205bb450e392f3d77964e430a83e59b1552e0097 (patch)
tree824050a7962eeb0659bb9d8f2cd69064e0622065
parentsci-chemistry/wxmacmolplt: Bump to 7.5 (diff)
parentpysurfer-9999 ebuild (diff)
downloadsci-205bb450e392f3d77964e430a83e59b1552e0097.tar.gz
sci-205bb450e392f3d77964e430a83e59b1552e0097.tar.bz2
sci-205bb450e392f3d77964e430a83e59b1552e0097.zip
Merge pull request #136 from mluessi/pysurfer
WIP: PySurfer ebuild
-rw-r--r--sci-biology/pysurfer/Manifest1
-rw-r--r--sci-biology/pysurfer/files/0.4-headless_build.patch22
-rw-r--r--sci-biology/pysurfer/pysurfer-0.4.ebuild27
-rw-r--r--sci-biology/pysurfer/pysurfer-9999.ebuild25
4 files changed, 75 insertions, 0 deletions
diff --git a/sci-biology/pysurfer/Manifest b/sci-biology/pysurfer/Manifest
new file mode 100644
index 000000000..855d1655d
--- /dev/null
+++ b/sci-biology/pysurfer/Manifest
@@ -0,0 +1 @@
+DIST 0.4.zip 1900346 SHA256 783858b9b2b466f2f606f72e5e2ca1e4ba175b96371bd1cee0879f9d5609295c SHA512 d57817c495c114459a5f0eb66d17d6506fe71fa352d34329b012bf33a98e7121eea10fd1925ab51a93c2056628f246895fd92b468096f7bc1f017bb30a2aa0a4 WHIRLPOOL 86cf9e61a2b74d28e00df5154ef76c3066fed41678d05a0a57bb6c8353dffe5ea506dd58396099f5f46aa5415a9c68c947962f52f7dc056980c28cb59b79e856
diff --git a/sci-biology/pysurfer/files/0.4-headless_build.patch b/sci-biology/pysurfer/files/0.4-headless_build.patch
new file mode 100644
index 000000000..0cebc112a
--- /dev/null
+++ b/sci-biology/pysurfer/files/0.4-headless_build.patch
@@ -0,0 +1,22 @@
+diff --git a/setup.py b/setup.py
+index c8681c2..41c21a5 100644
+--- a/setup.py
++++ b/setup.py
+@@ -10,8 +10,6 @@ import os
+ # deal with MPL sandbox violations during easy_install
+ os.environ['MPLCONFIGDIR'] = '.'
+
+-import surfer
+-
+ DISTNAME = 'pysurfer'
+ DESCRIPTION = descr
+ LONG_DESCRIPTION = descr
+@@ -20,7 +18,7 @@ MAINTAINER_EMAIL = 'mwaskom@stanford.edu'
+ URL = 'http://pysurfer.github.com'
+ LICENSE = 'BSD (3-clause)'
+ DOWNLOAD_URL = 'https://github.com/nipy/PySurfer'
+-VERSION = surfer.__version__
++VERSION = "0.4"
+
+ import setuptools # we are using a setuptools namespace
+ from numpy.distutils.core import setup
diff --git a/sci-biology/pysurfer/pysurfer-0.4.ebuild b/sci-biology/pysurfer/pysurfer-0.4.ebuild
new file mode 100644
index 000000000..2aec2ae64
--- /dev/null
+++ b/sci-biology/pysurfer/pysurfer-0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python based program for visualization of data from Freesurfer"
+HOMEPAGE="http://pysurfer.github.com"
+SRC_URI="https://github.com/nipy/PySurfer/archive/${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sci-visualization/mayavi[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND=""
+
+S="${WORKDIR}/PySurfer-${PV}"
+PATCHES=( "${FILESDIR}/${PV}-headless_build.patch" )
diff --git a/sci-biology/pysurfer/pysurfer-9999.ebuild b/sci-biology/pysurfer/pysurfer-9999.ebuild
new file mode 100644
index 000000000..6b0e30e72
--- /dev/null
+++ b/sci-biology/pysurfer/pysurfer-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 git-2
+
+DESCRIPTION="Python based program for visualization of data from Freesurfer"
+HOMEPAGE="http://pysurfer.github.com"
+EGIT_REPO_URI="https://github.com/nipy/PySurfer.git"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="sci-visualization/mayavi[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND=""
+
+S="${WORKDIR}/PySurfer-${PV}"