aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-11-12 14:56:45 +0100
committerJustin Lecher <jlec@gentoo.org>2014-11-12 14:56:45 +0100
commit209bcb0bbc3792c9df0022fe39c2398538ff4648 (patch)
tree32ae387cc7e359343fdc8ad89569001a0a38ed3b
parentsci-misc/stanford-parser: Bump to EAPI=5 (diff)
downloadsci-209bcb0bbc3792c9df0022fe39c2398538ff4648.tar.gz
sci-209bcb0bbc3792c9df0022fe39c2398538ff4648.tar.bz2
sci-209bcb0bbc3792c9df0022fe39c2398538ff4648.zip
sci-misc/stanford-tagger: Bump to EAPI=5
Package-Manager: portage-2.2.14
-rw-r--r--sci-misc/stanford-tagger/ChangeLog6
-rw-r--r--sci-misc/stanford-tagger/metadata.xml8
-rw-r--r--sci-misc/stanford-tagger/stanford-tagger-20060521.ebuild32
3 files changed, 23 insertions, 23 deletions
diff --git a/sci-misc/stanford-tagger/ChangeLog b/sci-misc/stanford-tagger/ChangeLog
index 00cdb3bd9..d0b0d041d 100644
--- a/sci-misc/stanford-tagger/ChangeLog
+++ b/sci-misc/stanford-tagger/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-misc/stanford-tagger
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 12 Nov 2014; Justin Lecher <jlec@gentoo.org> stanford-tagger-20060521.ebuild,
+ metadata.xml:
+ Bump to EAPI=5
+
25 Oct 2011; Justin Lecher <jlec@gentoo.org> metadata.xml:
Removed no-herd from herd tag in metadata.xml
diff --git a/sci-misc/stanford-tagger/metadata.xml b/sci-misc/stanford-tagger/metadata.xml
index 11655fa74..95ef8b6ca 100644
--- a/sci-misc/stanford-tagger/metadata.xml
+++ b/sci-misc/stanford-tagger/metadata.xml
@@ -1,10 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>flammie@gentoo.org</email>
- </maintainer>
- <longdescription>
+ <maintainer>
+ <email>flammie@gentoo.org</email>
+ </maintainer>
+ <longdescription>
University of Stanford’s Natural language pos tagger. Uses log linear
pos taggers such as Maximum Entropy model tagging.
</longdescription>
diff --git a/sci-misc/stanford-tagger/stanford-tagger-20060521.ebuild b/sci-misc/stanford-tagger/stanford-tagger-20060521.ebuild
index 891b47310..200dcdf99 100644
--- a/sci-misc/stanford-tagger/stanford-tagger-20060521.ebuild
+++ b/sci-misc/stanford-tagger/stanford-tagger-20060521.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=5
+
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2
@@ -9,13 +11,11 @@ MY_PV=2006-05-21
MY_P=postagger-${MY_PV}
DESCRIPTION="Stanfords log linear POS taggers"
HOMEPAGE="http://nlp.stanford.edu/software/tagger.shtml"
-
SRC_URI="http://nlp.stanford.edu/software/${MY_P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-
IUSE="${IUSE}"
COMMON_DEP=""
@@ -26,13 +26,15 @@ RDEPEND=">=virtual/jre-1.5
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
jar xf ${MY_P}-source.jar
- rm -v ${MY_P}.jar
- sed -i 's/import edu.stanford.nlp.ling.IndexedFeatureLabe/\/\/\0/g' edu/stanford/nlp/stats/Counters.java || die "sed failed"
- sed -i 's/import edu.stanford.nlp.sequences.BeamBestSequenceFinder/\/\/\0/g' edu/stanford/nlp/tagger/maxent/TestSentence.java || die "sed failed"
+ rm -v ${MY_P}.jar || die
+ sed \
+ -e 's/import edu.stanford.nlp.ling.IndexedFeatureLabe/\/\/\0/g' \
+ -i edu/stanford/nlp/stats/Counters.java || die "sed failed"
+ sed \
+ -e 's/import edu.stanford.nlp.sequences.BeamBestSequenceFinder/\/\/\0/g' \
+ -i edu/stanford/nlp/tagger/maxent/TestSentence.java || die "sed failed"
}
src_compile() {
@@ -43,17 +45,11 @@ src_compile() {
src_install() {
java-pkg_dojar ${PN}.jar
- dodir /usr/share/${PN}
- dodir /usr/share/${PN}/wsj3t0-18-bidirectional
insinto /usr/share/${PN}/wsj3t0-18-bidirectional
- for f in wsj3t0-18-bidirectional/* ; do
- doins ${f}
- done
- dodir /usr/share/${PN}/wsj3t0-18-left3words
+ doins wsj3t0-18-bidirectional/*
+
insinto /usr/share/${PN}/wsj3t0-18-left3words
- for f in wsj3t0-18-left3words/* ; do
- doins ${f}
- done
+ doins wsj3t0-18-left3words/*
if use doc ; then
java-pkg_dojavadoc javadoc
fi