aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-05-22 21:03:27 +0200
committerJustin Lecher <jlec@gentoo.org>2012-05-22 21:03:27 +0200
commit236c97684a42bf2f5b320d8426fd7e8c322a72c0 (patch)
treec7194befdaec05ea4136cddf7b5a433398b9962e
parentsci-biology/emboss: Add missing eutils.eclass (diff)
downloadsci-236c97684a42bf2f5b320d8426fd7e8c322a72c0.tar.gz
sci-236c97684a42bf2f5b320d8426fd7e8c322a72c0.tar.bz2
sci-236c97684a42bf2f5b320d8426fd7e8c322a72c0.zip
sci-biology/est2uni: Bump to EAPI=4, remove unnecessary bits
(Portage version: 2.2.0_alpha107/git/Linux x86_64, unsigned Manifest commit)
-rw-r--r--sci-biology/est2uni/ChangeLog6
-rw-r--r--sci-biology/est2uni/est2uni-0.27.ebuild34
-rw-r--r--sci-biology/est2uni/est2uni-9999.ebuild48
3 files changed, 47 insertions, 41 deletions
diff --git a/sci-biology/est2uni/ChangeLog b/sci-biology/est2uni/ChangeLog
index b4090e1ca..e58990663 100644
--- a/sci-biology/est2uni/ChangeLog
+++ b/sci-biology/est2uni/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-biology/est2uni
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 22 May 2012; Justin Lecher <jlec@gentoo.org> est2uni-0.27.ebuild,
+ est2uni-9999.ebuild:
+ Bump to EAPI=4, remove unnecessary bits
+
12 Dec 2011; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
est2uni-9999.ebuild:
added configuration.php.patch for VHOSTS setup files/configuration.php.patch
diff --git a/sci-biology/est2uni/est2uni-0.27.ebuild b/sci-biology/est2uni/est2uni-0.27.ebuild
index 7252b2f8a..063e02a95 100644
--- a/sci-biology/est2uni/est2uni-0.27.ebuild
+++ b/sci-biology/est2uni/est2uni-0.27.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=4
inherit eutils perl-module webapp
-DESCRIPTION="EST assembly+annotation: a perl-based analysis pipeline including php-based web interface"
+DESCRIPTION="Perl-based analysis pipeline including php-based web interface"
HOMEPAGE="http://cichlid.umd.edu/est2uni/download.php"
SRC_URI="
http://cichlid.umd.edu/est2uni/est2uni_0.27.tar.gz
@@ -22,27 +22,27 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}
- sci-biology/lucy
+ >=dev-db/mysql-4.1
+ dev-lang/php:5.3
+ dev-perl/go-perl
+ sci-biology/bioperl
sci-biology/cap3-bin
sci-biology/estscan
- <sci-biology/hmmer-3
+ sci-biology/exonerate
+ <sci-biology/hmmer-3.0
+ sci-biology/lucy
+ sci-biology/ncbi-tools
sci-biology/phred
- sci-biology/seqclean
sci-biology/repeatmasker
+ sci-biology/seqclean
sci-biology/tgicl
- sci-biology/ncbi-tools
- sci-biology/bioperl
- sci-biology/exonerate
- www-servers/apache
- >=dev-db/mysql-4.1
- <dev-lang/php-5.3"
-# perl-gcpan/go-perl
+ www-servers/apache"
S="${WORKDIR}"/est2uni
src_prepare(){
for f in "${FILESDIR}"/*.pm.patch "${FILESDIR}"/tgicl_files.patch; do
- cd perl; epatch $f || die "Failed to patch $f"
+ cd perl; epatch $f
done
}
@@ -57,7 +57,7 @@ src_install(){
chmod a+rx perl/*.pl perl/*.pm || die
mv perl/* "${D}"/opt/est2uni || die
- doenvd "${FILESDIR}"/99est2uni || die
+ doenvd "${FILESDIR}"/99est2uni
mkdir -p "${D}"/usr/share/webapps/"${PN}"/"${PV}"/htdocs
cp -r php/* "${D}"/usr/share/webapps/"${PN}"/"${PV}"/htdocs || die
@@ -90,10 +90,10 @@ src_install(){
einfo "https://listas.upv.es/pipermail/est2uni/2008-April/000129.html"
einfo "https://listas.upv.es/pipermail/est2uni/2008-April/000128.html"
einfo "https://listas.upv.es/pipermail/est2uni/2008-May/000139.html"
- einfo ""
+ echo ""
einfo "Current code is at http://bioinf.comav.upv.es/git///?p=est2uni;a=summary"
}
pkg_postinst(){
- webapp_pkg_postinst || die "webapp_pkg_postinst failed"
+ webapp_pkg_postinst
}
diff --git a/sci-biology/est2uni/est2uni-9999.ebuild b/sci-biology/est2uni/est2uni-9999.ebuild
index b3be36338..bb491c482 100644
--- a/sci-biology/est2uni/est2uni-9999.ebuild
+++ b/sci-biology/est2uni/est2uni-9999.ebuild
@@ -1,20 +1,21 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=4
-inherit webapp eutils perl-module
+[ "$PV" == "9999" ] && _GIT=git-2
-[ "$PV" == "9999" ] && inherit git-2
+inherit eutils ${_GIT} perl-module webapp
-DESCRIPTION="EST assembly+annotation: a perl-based analysis pipeline including php-based web interface"
+DESCRIPTION="Perl-based analysis pipeline including php-based web interface"
HOMEPAGE="http://cichlid.umd.edu/est2uni/download.php"
if [ "$PV" == "9999" ]; then
EGIT_REPO_URI="git://gitolite@bioinfo.comav.upv.es:2203/est2uni.git"
KEYWORDS=""
else
- SRC_URI="http://cichlid.umd.edu/est2uni/est2uni.tar.gz
+ SRC_URI="
+ http://cichlid.umd.edu/est2uni/est2uni.tar.gz
ftp://ftp.ncbi.nih.gov/pub/UniVec/UniVec
ftp://ftp.ncbi.nih.gov/pub/UniVec/UniVec_Core
http://www.geneontology.org/ontology/gene_ontology.obo
@@ -22,39 +23,40 @@ else
KEYWORDS="~amd64 ~x86"
fi
+SLOT="0"
LICENSE="GPL-3"
IUSE=""
DEPEND=""
RDEPEND="${DEPEND}
- sci-biology/lucy
+ >=dev-db/mysql-4.1
+ dev-lang/php:5.3
+ dev-perl/go-perl
+ sci-biology/bioperl
sci-biology/cap3-bin
sci-biology/estscan
+ sci-biology/exonerate
<sci-biology/hmmer-3.0
+ sci-biology/lucy
+ sci-biology/ncbi-tools
sci-biology/phred
- sci-biology/seqclean
sci-biology/repeatmasker
+ sci-biology/seqclean
sci-biology/tgicl
- sci-biology/ncbi-tools
- sci-biology/bioperl
- sci-biology/exonerate
- dev-perl/go-perl
- www-servers/apache
- >=dev-db/mysql-4.1
- <dev-lang/php-5.3"
+ www-servers/apache"
S="${WORKDIR}"/est2uni
src_prepare(){
for f in "${FILESDIR}"/9999-*.pm.patch; do
- cd perl; epatch $f || die "Failed to apply patch $f"
+ cd perl; epatch $f
done
cd ../php || die "Failed to chdir to ../php"
- epatch "${FILESDIR}"/configuration.php.patch || die "Failed to apply config patch for VHOSTS setup"
+ epatch "${FILESDIR}"/configuration.php.patch
}
src_compile(){
- "$(tc-getCC)" external_software/sputnik/sputnik.c -o external_software/sputnik/sputnik
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} external_software/sputnik/sputnik.c -o external_software/sputnik/sputnik || die
}
src_install(){
@@ -64,7 +66,7 @@ src_install(){
chmod a+rx perl/*.pl perl/*.pm || die
mv perl/* "${D}"/opt/est2uni || die
- doenvd "${FILESDIR}"/99est2uni || die
+ doenvd "${FILESDIR}"/99est2uni
mkdir -p "${D}"/usr/share/webapps/"${PN}"/"${PV}"/htdocs
cp -r php/* "${D}"/usr/share/webapps/"${PN}"/"${PV}"/htdocs || die
@@ -85,9 +87,9 @@ src_install(){
einfo "Please follow the pipeline installation and web configuration docs at"
einfo "http://cichlid.umd.edu/est2uni/install.php"
- einfo ""
+ echo ""
einfo "Example changes to the config file are in ${FILESDIR}/configuration.php.patch"
- einfo ""
+ echo ""
einfo "BEWARE the software is not maintained anymore by upstream but I do not"
einfo "know any better available (replaced by ngs_backbone which has no web"
einfo "interface yet). Consider using latest svn checkout instead of 0.27"
@@ -102,10 +104,10 @@ src_install(){
einfo "https://listas.upv.es/pipermail/est2uni/2008-April/000129.html"
einfo "https://listas.upv.es/pipermail/est2uni/2008-April/000128.html"
einfo "https://listas.upv.es/pipermail/est2uni/2008-May/000139.html"
- einfo ""
+ echo ""
einfo "Current code is at http://bioinf.comav.upv.es/git///?p=est2uni;a=summary"
}
pkg_postinst(){
- webapp_pkg_postinst || die "webapp_pkg_postinst failed"
+ webapp_pkg_postinst
}