aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheChymera <h.chr@mail.ru>2013-09-15 03:01:47 +0200
committerHorea Christian <h.chr@mail.ru>2015-02-09 13:06:53 +0100
commit2607b0f11d5a97322c0a330658ae70d7924a56d9 (patch)
tree020d934bdcf61c3f970410f7dc8a437f5538fa67
parentAdded -j1 to emake (apparently multithreading may screw some eispack/ things up) (diff)
downloadsci-2607b0f11d5a97322c0a330658ae70d7924a56d9.tar.gz
sci-2607b0f11d5a97322c0a330658ae70d7924a56d9.tar.bz2
sci-2607b0f11d5a97322c0a330658ae70d7924a56d9.zip
replaced URI_BASENAMe with PN, directory now just PN
-rw-r--r--sci-biology/spm8/spm8-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/sci-biology/spm8/spm8-9999.ebuild b/sci-biology/spm8/spm8-9999.ebuild
index dc89f9ce4..13ba1d583 100644
--- a/sci-biology/spm8/spm8-9999.ebuild
+++ b/sci-biology/spm8/spm8-9999.ebuild
@@ -9,25 +9,24 @@ inherit unpacker
DESCRIPTION="Construction and assessment tool for spatially extended statistical processes used to test hypotheses about functional imaging data"
HOMEPAGE="http://www.fil.ion.ucl.ac.uk/spm/"
URI_BASE="http://www.fil.ion.ucl.ac.uk/spm/download/restricted/idyll/"
-URI_BASE_NAME="spm8"
SRC_URI="" # SRC_URI is left blank on live ebuild
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
-DEPEND="net-misc/wget
- ${RDEPEND}"
+DEPEND="${RDEPEND}
+ "
RDEPEND=">=sci-mathematics/octave-3.6.4
"
-S=${WORKDIR}/${URI_BASE_NAME}
+S=${WORKDIR}/${PN}
src_unpack() {
# We have to do this inside of here, since it's a live ebuild. :-(
- wget "${URI_BASE}${URI_BASE_NAME}.zip"
- unpack "./${URI_BASE_NAME}.zip"
+ wget "${URI_BASE}${PN}.zip" || die
+ unpack "./${PN}.zip"
}
src_prepare() {
@@ -46,13 +45,13 @@ src_install() {
cd "${S}"/src
emake -j1 install PLATFORM=octave
emake -j1 toolbox-install PLATFORM=octave
- dodir /opt/${P}
- mv "${S}"/* "${ED}"/opt/${P}
+ dodir /opt/${PN}
+ mv "${S}"/* "${ED}"/opt/${PN}
ewarn "SPM8 has _not_ been added to the octave path. If you wish to be able to
run it directly from the octave shell please run the following from your
octave shell:
- addpath('/opt/spm8-9999/')
+ addpath('/opt/${PN}/')
You may make the path change persistent for your user by subsequently running: