aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-09-16 11:10:10 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-09-16 11:10:10 +0200
commit27e77ad519c3d49a3c04c21896cd678c73e2a150 (patch)
tree14e48c474417b3369dd249db1aa729619a72e588
parentsci-chemistry/coot: Fix PYTHONPATH during test (diff)
downloadsci-27e77ad519c3d49a3c04c21896cd678c73e2a150.tar.gz
sci-27e77ad519c3d49a3c04c21896cd678c73e2a150.tar.bz2
sci-27e77ad519c3d49a3c04c21896cd678c73e2a150.zip
dev-python/arrayfire-python: New package, ebuild wirtten by me
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-python/arrayfire-python/ChangeLog11
-rw-r--r--dev-python/arrayfire-python/Manifest1
l---------dev-python/arrayfire-python/arrayfire-python-3.0.20150914.ebuild1
-rw-r--r--dev-python/arrayfire-python/arrayfire-python-9999.ebuild30
-rw-r--r--dev-python/arrayfire-python/metadata.xml17
5 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/arrayfire-python/ChangeLog b/dev-python/arrayfire-python/ChangeLog
new file mode 100644
index 000000000..94eafd284
--- /dev/null
+++ b/dev-python/arrayfire-python/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/arrayfire-python
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Id$
+
+*arrayfire-python-3.0.20150914 (16 Sep 2015)
+*arrayfire-python-9999 (16 Sep 2015)
+
+ 16 Sep 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +arrayfire-python-3.0.20150914.ebuild, +arrayfire-python-9999.ebuild,
+ +metadata.xml:
+ dev-python/arrayfire-python: New package, ebuild wirtten by me
diff --git a/dev-python/arrayfire-python/Manifest b/dev-python/arrayfire-python/Manifest
new file mode 100644
index 000000000..14fc23b2c
--- /dev/null
+++ b/dev-python/arrayfire-python/Manifest
@@ -0,0 +1 @@
+DIST arrayfire-3.0.20150914.tar.gz 29172 SHA256 30d43c09d67dc9a2e93a2759287a37a288fadd4bec21c00361d84ff2417b04d0 SHA512 fcca14568b0e1491ca59df4fe003e53f3b387f1efd535a93deebb067c942b112077e4d61138d21cd0904d584141c3d023edcc62499f3f89ec68d982d1f4cfab1 WHIRLPOOL e181df3fcafdbbbe2bea74ff63d4e6bfc253d6fa27e49540d9b790ae4c31c289fbd94a3a5cd668240fc414be85cb22683f64b0f4ca842ce9c0d5e0769e8adf4d
diff --git a/dev-python/arrayfire-python/arrayfire-python-3.0.20150914.ebuild b/dev-python/arrayfire-python/arrayfire-python-3.0.20150914.ebuild
new file mode 120000
index 000000000..a61966cf0
--- /dev/null
+++ b/dev-python/arrayfire-python/arrayfire-python-3.0.20150914.ebuild
@@ -0,0 +1 @@
+arrayfire-python-9999.ebuild \ No newline at end of file
diff --git a/dev-python/arrayfire-python/arrayfire-python-9999.ebuild b/dev-python/arrayfire-python/arrayfire-python-9999.ebuild
new file mode 100644
index 000000000..c4d561b8d
--- /dev/null
+++ b/dev-python/arrayfire-python/arrayfire-python-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for ArrayFire"
+HOMEPAGE="http://www.arrayfire.com"
+
+MY_PN="arrayfire"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/arrayfire/${PN}.git git://github.com/arrayfire/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ >=sci-libs/arrayfire-3.0.0
+ "
+DEPEND="${RDEPEND}"
diff --git a/dev-python/arrayfire-python/metadata.xml b/dev-python/arrayfire-python/metadata.xml
new file mode 100644
index 000000000..6209f0d75
--- /dev/null
+++ b/dev-python/arrayfire-python/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <longdescription>
+ ArrayFire is a high performance library for parallel computing
+ wih an easy-to-use API. This package project Python bindings
+ for the ArrayFire library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">arrayfire/arrayfire-python</remote-id>
+ </upstream>
+</pkgmetadata>