aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-08-25 08:54:08 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-08-25 08:54:08 +0200
commit28e83b1e29803482e9c2416746f4366dae297a2d (patch)
treed12659097689223c70c0b39386166291360d3263
parentdev-python/ipython: Version bumped ebuild; Imported from tree (diff)
downloadsci-28e83b1e29803482e9c2416746f4366dae297a2d.tar.gz
sci-28e83b1e29803482e9c2416746f4366dae297a2d.tar.bz2
sci-28e83b1e29803482e9c2416746f4366dae297a2d.zip
dev-python/jupyter_console: Drop MY_PN, add python_test
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-python/jupyter_console/ChangeLog4
-rw-r--r--dev-python/jupyter_console/jupyter_console-9999.ebuild15
2 files changed, 15 insertions, 4 deletions
diff --git a/dev-python/jupyter_console/ChangeLog b/dev-python/jupyter_console/ChangeLog
index aca91f96c..81953c659 100644
--- a/dev-python/jupyter_console/ChangeLog
+++ b/dev-python/jupyter_console/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 25 Aug 2015; Marius Brehler <marbre@linux.sungazer.de>
+ jupyter_console-9999.ebuild:
+ dev-python/jupyter_console: Drop MY_PN, add python_test
+
*jupyter_console-4.0.0 (12 Aug 2015)
*jupyter_console-9999 (12 Aug 2015)
diff --git a/dev-python/jupyter_console/jupyter_console-9999.ebuild b/dev-python/jupyter_console/jupyter_console-9999.ebuild
index dcfd95ebb..7c3d71429 100644
--- a/dev-python/jupyter_console/jupyter_console-9999.ebuild
+++ b/dev-python/jupyter_console/jupyter_console-9999.ebuild
@@ -7,14 +7,12 @@ PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
inherit distutils-r1
-MY_PN="jupyter_console"
-
DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
HOMEPAGE="http://jupyter.org"
if [ ${PV} == "9999" ] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/jupyter/${MY_PN}.git git://github.com/jupyter/${MY_PN}.git"
+ EGIT_REPO_URI="https://github.com/jupyter/${PN}.git git://github.com/jupyter/${PN}.git"
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64"
@@ -22,10 +20,19 @@ fi
LICENSE="BSD"
SLOT="0"
+IUSE="test"
RDEPEND="
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/ipykernel[${PYTHON_USEDEP}]
dev-python/jupyter_client[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --with-coverage --cover-package=jupyter_console jupyter_console || die
+}