aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2014-03-24 12:53:41 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2014-03-24 12:53:41 +0100
commit2c576304e6b594c5423610448a39bb68e75d47ea (patch)
tree718c032554cbc68ef9ebed8104e2012e9caf5e49
parentdev-python/psubprocess: a wrapper utility to split tasks in parallel (diff)
downloadsci-2c576304e6b594c5423610448a39bb68e75d47ea.tar.gz
sci-2c576304e6b594c5423610448a39bb68e75d47ea.tar.bz2
sci-2c576304e6b594c5423610448a39bb68e75d47ea.zip
sci-biology/mgblast: initial ebuild but while it needs an old version of ncbi-tools source tree to build ... it is not tested yet
-rw-r--r--sci-biology/mgblast/ChangeLog11
-rw-r--r--sci-biology/mgblast/Manifest1
-rw-r--r--sci-biology/mgblast/metadata.xml9
-rw-r--r--sci-biology/mgblast/mgblast-0.1.ebuild46
4 files changed, 67 insertions, 0 deletions
diff --git a/sci-biology/mgblast/ChangeLog b/sci-biology/mgblast/ChangeLog
new file mode 100644
index 000000000..5b62270ad
--- /dev/null
+++ b/sci-biology/mgblast/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-biology/mgblast
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*mgblast-0.1 (24 Mar 2014)
+
+ 24 Mar 2014; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
+ +mgblast-0.1.ebuild, +metadata.xml:
+ initial ebuild but while it needs an old version of ncbi-tools source tree to
+ build ... it is not tested yet
+
diff --git a/sci-biology/mgblast/Manifest b/sci-biology/mgblast/Manifest
new file mode 100644
index 000000000..5db9b36c6
--- /dev/null
+++ b/sci-biology/mgblast/Manifest
@@ -0,0 +1 @@
+DIST mgblast.tar.gz 22904 SHA256 eb790a0e3979b511f289e440f8bc381788509e80a214792315356a23af151cf2
diff --git a/sci-biology/mgblast/metadata.xml b/sci-biology/mgblast/metadata.xml
new file mode 100644
index 000000000..07b525505
--- /dev/null
+++ b/sci-biology/mgblast/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <maintainer>
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-biology/mgblast/mgblast-0.1.ebuild b/sci-biology/mgblast/mgblast-0.1.ebuild
new file mode 100644
index 000000000..8b7011a15
--- /dev/null
+++ b/sci-biology/mgblast/mgblast-0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+DESCRIPTION="Customized version of megablast from TIGR Gene Indices project used by tgicl and gicl utilities"
+HOMEPAGE="http://compbio.dfci.harvard.edu/tgi/software/"
+SRC_URI="ftp://occams.dfci.harvard.edu/pub/bio/tgi/software/tgicl/mgblast.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="" # upstream binary is provided by sci-biology/tgicl currently
+#KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sci-biology/ncbi-tools"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+# mgblast needs old version of ncbi-tools unpacked and compiled during its own compilation
+# from newer tools you need to include blfmtutl.h but the next error is no go for me:
+# mgblast.c:2205: error: too few arguments to function ‘BXMLBuildOneQueryIteration’
+
+# Quoting from mgblast/README: the present package was built and tested only with the release 20060507
+
+src_prepare(){
+ # mgblast cannot be compiled against newer ncbi-tools but let's try
+ mv mgblast/makefile mgblast/Makefile 2>/dev/null || true
+ sed -i 's#/usr/local/projects/tgi/ncbitoolkit/ncbi#/usr#' mgblast/Makefile
+ sed -i 's#NCBIDIR = /mylocal/src/ncbi#NCBIDIR = /usr#' mgblast/Makefile
+ sed -i 's#NCBI_INCDIR = .*#NCBI_INCDIR = /usr/include/ncbi#' mgblast/Makefile
+ sed -i 's#NCBI_LIBDIR = .*#NCBI_LIBDIR = /usr/lib#' mgblast/Makefile # a PATH to NCBI-TOOLKIT (/usr/lib) while NOT /usr/lib/ncbi-tools++ !
+ sed -i "s#-I-#-iquote#" mgblast/Makefile
+}
+
+src_compile(){
+ cd ${S}/mgblast || die
+ emake || die "mgblast really needs an older ncbi-toolkit version so we are out of luck, install the binary provided by upstream instead from mgblast-bin package"
+}
+
+src_install(){
+ cd ${S}/mgblast || die
+ dobin mgblast || die
+}