aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-04 13:05:17 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-04 13:05:17 +0100
commit2e461f069f5aaa8e5968b698ace996a3add02888 (patch)
treed4671c9b0a18d0c6ab422a7f6611af79407251bf
parentsci-mathematics/gappa: drop old (diff)
downloadsci-2e461f069f5aaa8e5968b698ace996a3add02888.tar.gz
sci-2e461f069f5aaa8e5968b698ace996a3add02888.tar.bz2
sci-2e461f069f5aaa8e5968b698ace996a3add02888.zip
sci-mathematics/flocq: version bump 3.4.0
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-mathematics/flocq/Manifest1
-rw-r--r--sci-mathematics/flocq/flocq-3.4.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/flocq/Manifest b/sci-mathematics/flocq/Manifest
index 25a417be1..c14088e85 100644
--- a/sci-mathematics/flocq/Manifest
+++ b/sci-mathematics/flocq/Manifest
@@ -1 +1,2 @@
DIST flocq-2.3.0.tar.gz 155465 BLAKE2B 8cf3c10799643b24b17b50c118bf344d95fba1ecb6faa0d12e559f15f449eb1c6b75f2b1707e6e770abbffeb26d73e094941828a785224f426c4cf6e6fc13a2d SHA512 964b87f3df3ab76549dace5d8c16c7e7890dc70b64f54db3555023dcd6b32648b19030ad25ecb5b6e99bca5139f289a2ecfd3a1fe8bc1e1dfe7429f3d4f1ebc3
+DIST flocq-3.4.0.tar.gz 453124 BLAKE2B 0c3e7f7fe18f9722e341a62b8770ebe94a9195fc6e47a2beb6493ed976e8fac6da6eecae23a77d394a6b3dee89897f2fc918307130e7e8d3b1d08f2eb175c87e SHA512 26be9e6d0d30f0035f898c3cfd973ca954195af2068b1fc1ddcffe6ea81d9c3d8b9d72fad1ae75a816f67942bb4bef269bf9739e95ecf6cc17aecdbe1fcaf7a0
diff --git a/sci-mathematics/flocq/flocq-3.4.0.ebuild b/sci-mathematics/flocq/flocq-3.4.0.ebuild
new file mode 100644
index 000000000..e629d5628
--- /dev/null
+++ b/sci-mathematics/flocq/flocq-3.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A floating-point formalization for the Coq system"
+HOMEPAGE="http://flocq.gforge.inria.fr/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/38385/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=sci-mathematics/coq-8.7"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i Remakefile.in \
+ -e "s:mkdir -p @libdir@:mkdir -p \${DESTDIR}@libdir@:g" \
+ -e "s:cp \$f @libdir@:cp \$f \${DESTDIR}@libdir@:g"
+}
+
+src_configure() {
+ econf --libdir="`coqc -where`/user-contrib/Flocq"
+}
+
+src_compile() {
+ ./remake || die "emake failed"
+}
+
+src_install() {
+ DESTDIR="${D}" ./remake install || die
+ einstalldocs
+}