aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin <jlec@users.noreply.github.com>2013-10-16 03:01:04 -0700
committerJustin <jlec@users.noreply.github.com>2013-10-16 03:01:04 -0700
commit31567ef0d4d16c554c699a56f1864e06d3b85f82 (patch)
tree204ae743a737ad081cb3d3ab8192d03d3f88de31
parentsci-chemistry/shiftx2: Add missing python-r1 stuff (diff)
parentBump p4est to version 0.3.4.2 (diff)
downloadsci-31567ef0d4d16c554c699a56f1864e06d3b85f82.tar.gz
sci-31567ef0d4d16c554c699a56f1864e06d3b85f82.tar.bz2
sci-31567ef0d4d16c554c699a56f1864e06d3b85f82.zip
Merge pull request #120 from tamiko/bump_p4est
Bump p4est to version 0.3.4.2
-rw-r--r--sci-libs/p4est/Manifest2
-rw-r--r--sci-libs/p4est/metadata.xml3
-rw-r--r--sci-libs/p4est/p4est-0.3.4.2.ebuild (renamed from sci-libs/p4est/p4est-0.3.4.1.ebuild)8
3 files changed, 9 insertions, 4 deletions
diff --git a/sci-libs/p4est/Manifest b/sci-libs/p4est/Manifest
index 12a3a3354..fe186a6d8 100644
--- a/sci-libs/p4est/Manifest
+++ b/sci-libs/p4est/Manifest
@@ -1 +1 @@
-DIST p4est-0.3.4.1.tar.gz 1789020 SHA256 752df2868362e2d6bb984a10ad71ca3f8079972b48d444865d1ea231bd6336fa SHA512 497ee1d2f963227bc4dd60de5a63b9e9065200a9322b65b491a044b27c2fcc35ef6aa24082c3f304b8ac127dbece506de6a6913852f4bea5824cd2903888f1ee WHIRLPOOL 896e5e8cd894d9cb807367a1c1bb203f6d32de447c5d6905a62711c26dfaebce96bae6578f8f4a58ac24c80a8bf695f9dd15b3404cf879d35e67c9dd6d746ea5
+DIST p4est-0.3.4.2.tar.gz 1846685 SHA256 76597cb924f4c65f0c85301ce65bf8141411877b34e9c1605d1ce90781702f39 SHA512 acbd937d1b4d4abbe4a0f0b1cd02aeed9d959d689be66cd26e581823a568c155a8b898a405934a176c38f22cb1678a5b2185522742ef1e06429b868adc031050 WHIRLPOOL 8fb8d3cb6de82b81c72a86df49d41c0bae2cc7c33b87cf381de3c0215979ba29a7f1457ef44728a79c173efb117cfffe037f344786295110d711bbae59896a3b
diff --git a/sci-libs/p4est/metadata.xml b/sci-libs/p4est/metadata.xml
index 592c6fc09..59e8e1db6 100644
--- a/sci-libs/p4est/metadata.xml
+++ b/sci-libs/p4est/metadata.xml
@@ -12,4 +12,7 @@
designed to work in parallel and scale to hundreds of thousands of
processor cores.
</longdescription>
+<use>
+ <flag name="vtk-binary">Enable binary vtk output. If disabled vtk files will be written in ASCII text format.</flag>
+</use>
</pkgmetadata>
diff --git a/sci-libs/p4est/p4est-0.3.4.1.ebuild b/sci-libs/p4est/p4est-0.3.4.2.ebuild
index 9df1e73fd..9db1430eb 100644
--- a/sci-libs/p4est/p4est-0.3.4.1.ebuild
+++ b/sci-libs/p4est/p4est-0.3.4.2.ebuild
@@ -10,20 +10,19 @@ inherit autotools-utils toolchain-funcs eutils multilib
DESCRIPTION="Scalable Algorithms for Parallel Adaptive Mesh Refinement on Forests of Octrees"
HOMEPAGE="http://www.p4est.org/"
-SRC_URI="http://burstedde.ins.uni-bonn.de/release/p4est-${PV}.tar.gz"
+SRC_URI="http://p4est.org/tarball/p4est-${PV}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="GPL-2+"
SLOT="0"
-IUSE="debug doc examples mpi romio static-libs"
+IUSE="debug doc examples mpi romio static-libs +vtk-binary"
REQUIRED_USE="romio? ( mpi )"
RDEPEND="
dev-lang/lua
sys-apps/util-linux
- sys-libs/zlib
virtual/blas
virtual/lapack
mpi? ( virtual/mpi[romio?] )"
@@ -35,6 +34,8 @@ DEPEND="
DOCS=(AUTHORS ChangeLog NEWS README)
PATCHES=( "${FILESDIR}/${PN}-libtool-fix.patch" )
+
+AT_M4DIR="${WORKDIR}/${P}/sc/config"
AUTOTOOLS_AUTORECONF=true
src_configure() {
@@ -42,6 +43,7 @@ src_configure() {
$(use_enable debug)
$(use_enable mpi)
$(use_enable romio mpiio)
+ $(use_enable vtk-binary)
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
--with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
)