aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Horel <guillaume.horel@gmail.com>2013-11-16 12:02:08 -0500
committerGuillaume Horel <guillaume.horel@gmail.com>2013-11-16 12:02:08 -0500
commit341f60aba205f8ddc0d608b44956c6a998c0ebfd (patch)
tree85c90560cfa2825292dee050eac0cd13b537793d
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci (diff)
parentMerge pull request #142 from shuber2/itk2 (diff)
downloadsci-341f60aba205f8ddc0d608b44956c6a998c0ebfd.tar.gz
sci-341f60aba205f8ddc0d608b44956c6a998c0ebfd.tar.bz2
sci-341f60aba205f8ddc0d608b44956c6a998c0ebfd.zip
Merge branch 'master' of github.com:gentoo-science/sci
-rw-r--r--sci-biology/pysurfer/Manifest1
-rw-r--r--sci-biology/pysurfer/files/0.4-headless_build.patch22
-rw-r--r--sci-biology/pysurfer/pysurfer-0.4.ebuild27
-rw-r--r--sci-biology/pysurfer/pysurfer-9999.ebuild25
-rw-r--r--sci-libs/itk/Manifest1
-rw-r--r--sci-libs/itk/itk-4.4.2-r1.ebuild134
6 files changed, 210 insertions, 0 deletions
diff --git a/sci-biology/pysurfer/Manifest b/sci-biology/pysurfer/Manifest
new file mode 100644
index 000000000..855d1655d
--- /dev/null
+++ b/sci-biology/pysurfer/Manifest
@@ -0,0 +1 @@
+DIST 0.4.zip 1900346 SHA256 783858b9b2b466f2f606f72e5e2ca1e4ba175b96371bd1cee0879f9d5609295c SHA512 d57817c495c114459a5f0eb66d17d6506fe71fa352d34329b012bf33a98e7121eea10fd1925ab51a93c2056628f246895fd92b468096f7bc1f017bb30a2aa0a4 WHIRLPOOL 86cf9e61a2b74d28e00df5154ef76c3066fed41678d05a0a57bb6c8353dffe5ea506dd58396099f5f46aa5415a9c68c947962f52f7dc056980c28cb59b79e856
diff --git a/sci-biology/pysurfer/files/0.4-headless_build.patch b/sci-biology/pysurfer/files/0.4-headless_build.patch
new file mode 100644
index 000000000..0cebc112a
--- /dev/null
+++ b/sci-biology/pysurfer/files/0.4-headless_build.patch
@@ -0,0 +1,22 @@
+diff --git a/setup.py b/setup.py
+index c8681c2..41c21a5 100644
+--- a/setup.py
++++ b/setup.py
+@@ -10,8 +10,6 @@ import os
+ # deal with MPL sandbox violations during easy_install
+ os.environ['MPLCONFIGDIR'] = '.'
+
+-import surfer
+-
+ DISTNAME = 'pysurfer'
+ DESCRIPTION = descr
+ LONG_DESCRIPTION = descr
+@@ -20,7 +18,7 @@ MAINTAINER_EMAIL = 'mwaskom@stanford.edu'
+ URL = 'http://pysurfer.github.com'
+ LICENSE = 'BSD (3-clause)'
+ DOWNLOAD_URL = 'https://github.com/nipy/PySurfer'
+-VERSION = surfer.__version__
++VERSION = "0.4"
+
+ import setuptools # we are using a setuptools namespace
+ from numpy.distutils.core import setup
diff --git a/sci-biology/pysurfer/pysurfer-0.4.ebuild b/sci-biology/pysurfer/pysurfer-0.4.ebuild
new file mode 100644
index 000000000..2aec2ae64
--- /dev/null
+++ b/sci-biology/pysurfer/pysurfer-0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python based program for visualization of data from Freesurfer"
+HOMEPAGE="http://pysurfer.github.com"
+SRC_URI="https://github.com/nipy/PySurfer/archive/${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sci-visualization/mayavi[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND=""
+
+S="${WORKDIR}/PySurfer-${PV}"
+PATCHES=( "${FILESDIR}/${PV}-headless_build.patch" )
diff --git a/sci-biology/pysurfer/pysurfer-9999.ebuild b/sci-biology/pysurfer/pysurfer-9999.ebuild
new file mode 100644
index 000000000..6b0e30e72
--- /dev/null
+++ b/sci-biology/pysurfer/pysurfer-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 git-2
+
+DESCRIPTION="Python based program for visualization of data from Freesurfer"
+HOMEPAGE="http://pysurfer.github.com"
+EGIT_REPO_URI="https://github.com/nipy/PySurfer.git"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="sci-visualization/mayavi[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND=""
+
+S="${WORKDIR}/PySurfer-${PV}"
diff --git a/sci-libs/itk/Manifest b/sci-libs/itk/Manifest
index 2a83eb01b..e68e94b9f 100644
--- a/sci-libs/itk/Manifest
+++ b/sci-libs/itk/Manifest
@@ -1 +1,2 @@
+DIST DoxygenInsightToolkit-4.4.0.tar.gz 779393284 SHA256 a2e9a74dad840f6af7e3f3a518f43d75cad511d6b6b4b09d61f5b1b1b72d25c3 SHA512 9bdd6cedcdf5c30afb7f73130074983a56c397db776b927aae78b15a80d1158cca4563f92795d804ade34f4860b350cbbd157ed6924d53cb2ddfccf478e403c6 WHIRLPOOL 114f6ebb4052a8845559a9fa7f2883aa7bba90ff07dd7cd64d4e305e5ffdb35969b8b18b31b631e99d293fe06d95389359b23697544797a7703d9a973bd23246
DIST InsightToolkit-4.4.2.tar.gz 231905134 SHA256 071a7929c295b80bc8a6ab80d50c06cdfb0e6aafd936103c6d0a4a086cf8bec3 SHA512 c65beca4dd60aa769871bb3089cbb421729a2dcbd8bd3ec42c378ed60828e4327f1faf062f77bcca34306315a1daee6bc29d858dab9aea1c08f4843405fd21e3 WHIRLPOOL 4036bce61d0900ef2f1484ca06e9b513f6154c2233122e41fe694c648dd6eef53510749bf75368f9851a4dbd45777ca7033ad43f28c86259d5efae9e0d4200bd
diff --git a/sci-libs/itk/itk-4.4.2-r1.ebuild b/sci-libs/itk/itk-4.4.2-r1.ebuild
new file mode 100644
index 000000000..871888015
--- /dev/null
+++ b/sci-libs/itk/itk-4.4.2-r1.ebuild
@@ -0,0 +1,134 @@
+# Copyright 2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit eutils toolchain-funcs cmake-utils python-single-r1
+
+MYPN=InsightToolkit
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="NLM Insight Segmentation and Registration Toolkit"
+HOMEPAGE="http://www.itk.org"
+SRC_URI="
+ mirror://sourceforge/${PN}/${MYP}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/Doxygen${MYPN}-4.4.0.tar.gz )"
+RESTRICT="primaryuri"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug doc examples fftw itkv3compat python review sse2 test vtkglue"
+
+RDEPEND="
+ sci-libs/hdf5[cxx]
+ virtual/jpeg
+ media-libs/libpng
+ media-libs/tiff:0
+ sys-libs/zlib
+ fftw? ( sci-libs/fftw:3.0 )
+ vtkglue? ( sci-libs/vtk )
+"
+DEPEND="${RDEPEND}
+ python? ( ${PYTHON_DEPS}
+ >=dev-lang/swig-2.0
+ >=dev-cpp/gccxml-0.9.0_pre20120309 )
+ doc? ( app-doc/doxygen )
+"
+
+S="${WORKDIR}/${MYP}"
+
+pkg_pretend() {
+ if [[ -z ${ITK_COMPUTER_MEMORY_SIZE} ]]; then
+ elog "To tune ITK to make the best use ouf working memory you can set"
+ elog " ITK_COMPUTER_MEMORY_SIZE=XX"
+ elog "in make.conf, default is 1 (unit is GB)"
+ fi
+ if use python && [[ -z ${ITK_WRAP_DIMS} ]]; then
+ elog "For Python language bindings, you can define the dimensions"
+ elog "you want to create bindings for by setting"
+ elog " ITK_WRAP_DIMS=X;Y;Z..."
+ elog "in make.conf, default is 2;3 for 2D and 3D data"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWRAP_ITK_JAVA=OFF
+ -DWRAP_ITK_TCL=OFF
+ -DITK_USE_SYSTEM_HDF5=ON
+ -DITK_USE_SYSTEM_JPEG=ON
+ -DITK_USE_SYSTEM_PNG=ON
+ -DITK_USE_SYSTEM_TIFF=ON
+ -DITK_USE_SYSTEM_ZLIB=ON
+ -DITK_USE_SYSTEM_GCCXML=ON
+ -DITK_USE_SYSTEM_SWIG=ON
+ -DITK_BUILD_ALL_MODULES=ON
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_EXAMPLES=OFF
+ -DITK_COMPUTER_MEMORY_SIZE="${ITK_COMPUTER_MEMORY_SIZE:-1}"
+ $(cmake-utils_use_build test TESTING)
+ $(cmake-utils_use review ITK_USE_REVIEW)
+ $(cmake-utils_use itkv3compat ITKV3_COMPATIBILITY)
+ $(cmake-utils_use sse2 VNL_CONFIG_ENABLE_SSE2)
+ )
+ if use fftw; then
+ mycmakeargs+=(
+ -DUSE_FFTWD=ON
+ -DUSE_FFTWF=ON
+ -DUSE_SYSTEM_FFTW=ON
+ -DITK_WRAP_double=ON
+ -DITK_WRAP_vector_double=ON
+ -DITK_WRAP_covariant_vector_double=ON
+ -DITK_WRAP_complex_double=ON
+ )
+ fi
+ if use vtkglue; then
+ mycmakeargs+=(
+ -DModule_ITKVtkGlue=ON
+ )
+ fi
+ if use python; then
+ mycmakeargs+=(
+ -DITK_WRAP_PYTHON=ON
+ -DITK_WRAP_DIMS="${ITK_WRAP_DIMS:-2;3}"
+ )
+ else
+ mycmakeargs+=(
+ -DITK_WRAP_PYTHON=OFF
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ doins -r "${S}"/Examples/*
+ fi
+
+ echo "ITK_DATA_ROOT=${EROOT}/usr/share/${PN}/data" > ${T}/40${PN}
+ local ldpath="${EROOT}/usr/$(get_libdir)/InsightToolkit"
+ if use python; then
+ echo "PYTHONPATH=${EROOT}/usr/$(get_libdir)/InsightToolkit/WrapITK/Python" >> ${T}/40${PN}
+ ldpath="${ldpath}:${EROOT}/usr/$(get_libdir)/InsightToolkit/WrapITK/lib"
+ fi
+ echo "LDPATH=${ldpath}" >> ${T}/40${PN}
+
+ if use doc; then
+ insinto "/usr/share/doc/${PF}/api-docs"
+ cd "${WORKDIR}"/html
+ rm -f *.md5 || die "Failed to remove superfluous hashes"
+ einfo "Installing API docs. This may take some time."
+ insinto "/usr/share/doc/${PF}/api-docs"
+ doins -r ./* || die "Failed to install docs"
+ fi
+
+ doenvd "${T}"/40${PN}
+}