aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-09-27 22:34:55 -0400
committerHorea Christian <chr@chymera.eu>2022-09-27 22:34:55 -0400
commit355ac09d51851dcaca6913ec93ecfcb4c795be74 (patch)
treeea4b8ac7eee12c617c967b83bad0237d8a758954
parentnet-misc/cernbox-client: drop 2.10.0.6519 (diff)
downloadsci-355ac09d51851dcaca6913ec93ecfcb4c795be74.tar.gz
sci-355ac09d51851dcaca6913ec93ecfcb4c795be74.tar.bz2
sci-355ac09d51851dcaca6913ec93ecfcb4c795be74.zip
dev-python/nwbinspector: add 0.4.14
Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--dev-python/nwbinspector/Manifest1
-rw-r--r--dev-python/nwbinspector/nwbinspector-0.4.14.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/nwbinspector/Manifest b/dev-python/nwbinspector/Manifest
index fa770778b..ba201f8da 100644
--- a/dev-python/nwbinspector/Manifest
+++ b/dev-python/nwbinspector/Manifest
@@ -1,2 +1,3 @@
DIST nwbinspector-0.3.9.tar.gz 443247 BLAKE2B 4d1adbca50ff0f5d8278d71063d1248a4b22da952de6dc3e4984d58285d1acecf5adfe85b2a624df20e8064a69fa2ffe2c4a23ec1d2a579446fc451e7cd04bd5 SHA512 e8752fadbfcdb9a46f5c16771d789995fdab378720861dbe15b100f8e07cfad58f99a75fbda8e7631f06ec5671e16b3ac48a002606b658b018d50dd62151cc5e
DIST nwbinspector-0.4.12.tar.gz 455926 BLAKE2B 4bb8b493367593fdd575535e574b8494980a60a6ed1983a08f895c106e03e25ad6cd76b6c72cfcc42a34778d5059c90940bc9907dc9d87569df79aeae1698135 SHA512 60bb799beaff61612e7993069a34f62e0b6053dc3e820474f33c020c02f8c7b11bed0bca7e2bb335edfd60b06159be90b1a50dfcd497f6a3fb0916dc49cf17b7
+DIST nwbinspector-0.4.14.tar.gz 469679 BLAKE2B 96fc92be4b52626b6533ca3d6f9584991543b2de392733af70d7d71d2a98bc8c1455a78ea0a8a6682cd4c52d0e8ed7ebcb0ac439aea9e4a5503f1dbd8b8ef148 SHA512 a1199460420b092a1e9a8803d0f881c7998e4a75e3878cb80b1b44624b1984a63aca39d4b2631339f25a00fb46982289463a062324388edfdebff27e0b8c9faa
diff --git a/dev-python/nwbinspector/nwbinspector-0.4.14.ebuild b/dev-python/nwbinspector/nwbinspector-0.4.14.ebuild
new file mode 100644
index 000000000..a2b20f5af
--- /dev/null
+++ b/dev-python/nwbinspector/nwbinspector-0.4.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Inspect NWB files for compliance with NWB Best Practices"
+HOMEPAGE="https://github.com/NeurodataWithoutBorders/nwbinspector"
+SRC_URI="https://github.com/NeurodataWithoutBorders/nwbinspector/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=""
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_inspector.py
+ tests/unit_tests/test_time_series.py
+ )
+ epytest
+}