aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot <root@lfa-55.(none)>2009-02-23 09:52:51 +0100
committerroot <root@lfa-55.(none)>2009-02-23 09:52:51 +0100
commit379158b0f22fddb3ae6c558de078863df5152c6d (patch)
tree4cffc96aeca9aa73a907e381e3a81625310c2cd5
parentPush Vampir Trace includes to a subdir. #257086 (diff)
downloadsci-379158b0f22fddb3ae6c558de078863df5152c6d.tar.gz
sci-379158b0f22fddb3ae6c558de078863df5152c6d.tar.bz2
sci-379158b0f22fddb3ae6c558de078863df5152c6d.zip
sci-libs/gmsh Version bump
-rw-r--r--sci-libs/gmsh/files/gmsh-2.3.0.patch20
-rw-r--r--sci-libs/gmsh/files/gmsh-2.3.0_hdf5.patch23
-rw-r--r--sci-libs/gmsh/gmsh-2.3.0.ebuild74
3 files changed, 117 insertions, 0 deletions
diff --git a/sci-libs/gmsh/files/gmsh-2.3.0.patch b/sci-libs/gmsh/files/gmsh-2.3.0.patch
new file mode 100644
index 000000000..148c101bf
--- /dev/null
+++ b/sci-libs/gmsh/files/gmsh-2.3.0.patch
@@ -0,0 +1,20 @@
+--- gmsh-2.3.0/configure.orig 2009-02-22 15:06:28.000000000 +0100
++++ gmsh-2.3.0/configure 2009-02-22 15:08:41.000000000 +0100
+@@ -3714,7 +3714,7 @@
+
+ GMSH_DIRS="Common Geo Mesh Post Plugin Numeric Parser Graphics Fltk"
+ GMSH_LIBS="-Llib -lGmshFltk -lGmshCommon -lGmshMesh -lGmshGeo -lGmshPost -lGmshPlugin"
+- GMSH_LIBS="${GMSH_LIBS} -lGmshCommon -lGmshGraphics -lGmshParser -lGmshNumeric"
++ GMSH_LIBS="${GMSH_LIBS} -lGmshCommon -lGmshGraphics -lGmshParser -lGmshNumeric ${LDFLAGS}"
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_FLTK 1
+ _ACEOF
+@@ -4884,7 +4884,7 @@
+ GMSH_LIBS="${GMSH_LIBS} ${OCC_LIBS}"
+ else
+ GMSH_LIBS="${GMSH_LIBS} -L${OCC_PREFIX}/lib ${OCC_LIBS}"
+- FLAGS="${FLAGS} -I${OCC_PREFIX}/inc"
++ FLAGS="${FLAGS} -DHAVE_WOK_CONFIG_H -DFREEBSD -D${ARCH} -I${OCC_PREFIX}/../inc"
+ fi
+ fi
+ fi
diff --git a/sci-libs/gmsh/files/gmsh-2.3.0_hdf5.patch b/sci-libs/gmsh/files/gmsh-2.3.0_hdf5.patch
new file mode 100644
index 000000000..9e104efe8
--- /dev/null
+++ b/sci-libs/gmsh/files/gmsh-2.3.0_hdf5.patch
@@ -0,0 +1,23 @@
+--- gmsh-2.3.0/configure.orig 2009-02-22 15:11:19.000000000 +0100
++++ gmsh-2.3.0/configure 2009-02-22 15:11:55.000000000 +0100
+@@ -5012,7 +5012,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lcgns $LIBS"
++LIBS="-lcgns -lhdf5 $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -5072,9 +5072,9 @@
+
+ BO="${BO} Cgns"
+ if test "x${CGNS_PREFIX}" = "x"; then
+- GMSH_LIBS="${GMSH_LIBS} -lcgns"
++ GMSH_LIBS="${GMSH_LIBS} -lcgns -lhdf5"
+ else
+- GMSH_LIBS="${GMSH_LIBS} -L${CGNS_PREFIX}/lib -lcgns"
++ GMSH_LIBS="${GMSH_LIBS} -L${CGNS_PREFIX}/lib -lcgns -lhdf5 "
+ FLAGS="${FLAGS} -I${CGNS_PREFIX}/include"
+ fi
+ fi
diff --git a/sci-libs/gmsh/gmsh-2.3.0.ebuild b/sci-libs/gmsh/gmsh-2.3.0.ebuild
new file mode 100644
index 000000000..3bffefd7c
--- /dev/null
+++ b/sci-libs/gmsh/gmsh-2.3.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils multilib
+
+DESCRIPTION="A three-dimensional finite element mesh generator with built-in pre- and post-processing facilities."
+HOMEPAGE="http://www.geuz.org/gmsh/"
+SRC_URI="http://www.geuz.org/gmsh/src/${P}-source.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chaco cgns doc examples jpeg metis opencascade png zlib X"
+
+RDEPEND="sci-libs/gsl
+ x11-libs/fltk
+ cgns? ( sci-libs/cgnslib )
+ jpeg? ( media-libs/jpeg )
+ opencascade? ( sci-libs/opencascade )
+ png? ( media-libs/libpng )
+ zlib? ( sys-libs/zlib )"
+
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}.patch
+
+ if use cgns && built_with_use sci-libs/cgnslib hdf5; then
+ epatch "${FILESDIR}"/${P}_hdf5.patch
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ use opencascade && myconf="${myconf} --with-occ-prefix=$CASROOT/lin"
+
+ # As for now, the MED integration doesnot compile
+ myconf="${myconf} --disable-med"
+
+ econf ${myconf} \
+ $(use_enable X gui) \
+ $(use_enable cgns) \
+ $(use_enable jpeg) \
+ $(use_enable metis) \
+ $(use_enable opencascade occ) \
+ $(use_enable png) \
+ $(use_enable chaco) \
+ $(use_enable zlib)
+
+ emake -j1 || die "emake failed"
+
+ if use doc ; then
+ cd doc/texinfo
+ emake pdf || die "could not build documentation"
+ fi
+}
+
+src_install() {
+ einstall || die "could not install"
+ dodoc README doc/CREDITS.txt
+
+ if use doc ; then
+ dodoc doc/{FAQ.txt,README.*} doc/texinfo/*.pdf
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r demos tutorial || die "failed to install examples"
+ fi
+}