aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2013-09-04 07:13:06 +0200
committerKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2013-09-04 07:13:06 +0200
commit38ad37bb4760fa7b91bdc6a007c04ee8b920f45c (patch)
treeef56020c6b5421793c8ff500e23fdd1529965fa5
parentMerge branch 'master' of github.com:gentoo-science/sci (diff)
parentAdded, KEYWORDS, IUSE, deleted COMMONDEP variables (diff)
downloadsci-38ad37bb4760fa7b91bdc6a007c04ee8b920f45c.tar.gz
sci-38ad37bb4760fa7b91bdc6a007c04ee8b920f45c.tar.bz2
sci-38ad37bb4760fa7b91bdc6a007c04ee8b920f45c.zip
merging
-rw-r--r--sci-libs/nibabel/metadata.xml19
-rw-r--r--sci-libs/nibabel/nibabel-9999.ebuild40
-rw-r--r--sci-libs/nipy/Manifest1
-rw-r--r--sci-libs/nipy/metadata.xml12
-rw-r--r--sci-libs/nipy/nipy-0.3.0.ebuild38
-rw-r--r--sci-libs/nipy/nipy-9999.ebuild37
-rw-r--r--sci-libs/nipype/metadata.xml21
-rw-r--r--sci-libs/nipype/nipype-9999.ebuild33
8 files changed, 201 insertions, 0 deletions
diff --git a/sci-libs/nibabel/metadata.xml b/sci-libs/nibabel/metadata.xml
new file mode 100644
index 000000000..7ffd788e6
--- /dev/null
+++ b/sci-libs/nibabel/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>h.chr@mail.ru</email>
+ <name>Horea Christian</name>
+</maintainer>
+<longdescription lang="en">
+ The package provides read and write access to some common medical and
+ neuroimaging file formats, including: ANALYZE (plain, SPM99, SPM2), GIFTI,
+ NIfTI1, MINC, MGH and ECAT as well as PAR/REC. It can read and write Freesurfer
+ geometry, and read Freesurfer morphometry and annotation files. There is some
+ very limited support for DICOM. NiBabel is the successor of PyNIfTI.
+</longdescription>
+<use>
+ <flag name="dicom">Adds limited read support for the DICOM imaging format.</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-libs/nibabel/nibabel-9999.ebuild b/sci-libs/nibabel/nibabel-9999.ebuild
new file mode 100644
index 000000000..0070d0bfd
--- /dev/null
+++ b/sci-libs/nibabel/nibabel-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1 git-2
+
+DESCRIPTION="Access a cacophony of neuro-imaging file formats"
+HOMEPAGE="http://nipy.org/nibabel/"
+EGIT_REPO_URI="https://github.com/nipy/nibabel.git"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="dicom doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dicom? (
+ sci-libs/pydicom[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ )
+ "
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ distutils-r1_install_for_testing
+ cd "${BUILD_DIR}" || die
+ echo "backend: Agg" > matplotlibrc
+ MPLCONFIGDIR=. nosetests || die
+}
diff --git a/sci-libs/nipy/Manifest b/sci-libs/nipy/Manifest
new file mode 100644
index 000000000..e2730eee9
--- /dev/null
+++ b/sci-libs/nipy/Manifest
@@ -0,0 +1 @@
+DIST nipy-0.3.0.tar.gz 2143887 SHA256 74fef65c832795a35e1757d8bd852177fae190517a964afcb0812cfc1107d155 SHA512 3eaab4628bfa1706c99d516242387e1a27330bbf03b5b79da80d9a5e697b4e779f8f059e6f7bcc4253c5ad7af1bf6c600bcc5bd87db95d2e38f445d1f4416106 WHIRLPOOL 8a27c42abd8c7ae5ce66b8cfb0686b79e3208950107fcc5090d88fa2c23bf15d4ce4ae5b598f6f51c6e70122c40a343b9b7b2950ef09aefaeb22e24efd854af0
diff --git a/sci-libs/nipy/metadata.xml b/sci-libs/nipy/metadata.xml
new file mode 100644
index 000000000..ac599a834
--- /dev/null
+++ b/sci-libs/nipy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>h.chr@mail.ru</email>
+ <name>Horea Christian</name>
+</maintainer>
+<longdescription lang="en">
+ NIPY is a python project for analysis of structural and functional neuroimaging data.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/nipy/nipy-0.3.0.ebuild b/sci-libs/nipy/nipy-0.3.0.ebuild
new file mode 100644
index 000000000..8b8b3a9c2
--- /dev/null
+++ b/sci-libs/nipy/nipy-0.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+DISTUTILS_NO_PARALLEL_BUILD=true
+
+inherit distutils-r1 eutils multilib flag-o-matic
+
+
+DESCRIPTION="Neuroimaging tools for Python"
+HOMEPAGE="http://nipy.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/numpy-1.2[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sympy-0.6.6[${PYTHON_USEDEP}]
+ >=sci-libs/nibabel-1.2[${PYTHON_USEDEP}]"
+DEPEND="
+ "
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # bug #397605
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+
+ # nipy uses the horrible numpy.distutils automagic
+} \ No newline at end of file
diff --git a/sci-libs/nipy/nipy-9999.ebuild b/sci-libs/nipy/nipy-9999.ebuild
new file mode 100644
index 000000000..506b59a12
--- /dev/null
+++ b/sci-libs/nipy/nipy-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scikits_image/scikits_image-0.8.2.ebuild,v 1.3 2013/06/18 04:33:25 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+DISTUTILS_NO_PARALLEL_BUILD=true
+
+inherit distutils-r1 multilib git-2 flag-o-matic
+
+DESCRIPTION="Neuroimaging tools for Python"
+HOMEPAGE="http://nipy.org/"
+EGIT_REPO_URI="https://github.com/nipy/nipy"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+KEYWORDS=""
+
+RDEPEND="
+ >=dev-python/numpy-1.2[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sympy-0.6.6[${PYTHON_USEDEP}]
+ >=sci-libs/nibabel-1.2[${PYTHON_USEDEP}]"
+DEPEND="
+ "
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # bug #397605
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+
+ # nipy uses the horrible numpy.distutils automagic
+} \ No newline at end of file
diff --git a/sci-libs/nipype/metadata.xml b/sci-libs/nipype/metadata.xml
new file mode 100644
index 000000000..d41e11fc9
--- /dev/null
+++ b/sci-libs/nipype/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>h.chr@mail.ru</email>
+ <name>Horea Christian</name>
+</maintainer>
+<longdescription lang="en">
+ Nipype, an open-source, community-developed initiative under the
+ umbrella of NiPy, is a Python project that provides a uniform interface
+ to existing neuroimaging software and facilitates interaction between
+ these packages within a single workflow. Nipype provides an environment
+ that encourages interactive exploration of algorithms from different
+ packages (e.g., SPM, FSL, FreeSurfer, Camino, MRtrix, MNE, AFNI, Slicer),
+ eases the design of workflows within and between packages, and reduces
+ the learning curve necessary to use different packages. Nipype is
+ creating a collaborative platform for neuroimaging software development
+ in a high-level language and addressing limitations of existing pipeline systems.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/nipype/nipype-9999.ebuild b/sci-libs/nipype/nipype-9999.ebuild
new file mode 100644
index 000000000..c01af0a0d
--- /dev/null
+++ b/sci-libs/nipype/nipype-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scikits_image/scikits_image-0.8.2.ebuild,v 1.3 2013/06/18 04:33:25 patrick Exp $
+
+EAPI=5
+
+# pyamg missing py3 support
+# PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 git-2
+
+DESCRIPTION="Neuroimaging in Python: Pipelines and Interfaces"
+HOMEPAGE="http://nipy.sourceforge.net/nipype/"
+EGIT_REPO_URI="https://github.com/nipy/nipype"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ >=sci-libs/scipy-0.7.0[${PYTHON_USEDEP}]
+ >=sci-libs/nibabel-1.2[${PYTHON_USEDEP}]
+ >=dev-python/numpy-0.7[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]"
+DEPEND="
+ "
+
+python_test() {
+ nosetests -v || die
+}
+
+