aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin <jlec@j-schmitz.net>2013-01-16 06:21:44 -0800
committerJustin <jlec@j-schmitz.net>2013-01-16 06:21:44 -0800
commit3aec746fad73023066764bb3969113e7863d5f8a (patch)
tree2bdd5b52284784f7142eb1601c0af07be7ab454c
parentInitial upload of sci-libs/libmatheval (bug 181417) (diff)
parentRemoved CMAKE_VERBOSE=1 in pg2plplot-0.2.0.ebuild (diff)
downloadsci-3aec746fad73023066764bb3969113e7863d5f8a.tar.gz
sci-3aec746fad73023066764bb3969113e7863d5f8a.tar.bz2
sci-3aec746fad73023066764bb3969113e7863d5f8a.zip
Merge pull request #41 from AstroFloyd/master
Adding an initial ebuild for PG2PLplot
-rw-r--r--sci-libs/pg2plplot/ChangeLog10
-rw-r--r--sci-libs/pg2plplot/Manifest1
-rw-r--r--sci-libs/pg2plplot/metadata.xml9
-rw-r--r--sci-libs/pg2plplot/pg2plplot-0.2.0.ebuild34
4 files changed, 54 insertions, 0 deletions
diff --git a/sci-libs/pg2plplot/ChangeLog b/sci-libs/pg2plplot/ChangeLog
new file mode 100644
index 000000000..ebe27d178
--- /dev/null
+++ b/sci-libs/pg2plplot/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/pg2plplot
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*pg2plplot-0.2.0 (13 Jan 2013)
+
+ 13 Jan 2013; AstroFloyd <AstroFloyd@gmail.com> +pg2plplot-0.2.0.ebuild,
+ +metadata.xml:
+ Created initial ebuild for PG2PLplot-0.2.0
+
diff --git a/sci-libs/pg2plplot/Manifest b/sci-libs/pg2plplot/Manifest
new file mode 100644
index 000000000..8af865206
--- /dev/null
+++ b/sci-libs/pg2plplot/Manifest
@@ -0,0 +1 @@
+DIST pg2plplot-0.2.0.tar.gz 34232 SHA256 b4ee8a52619b49d1b1d6fc0b982a20f0c1dcb33a0c725526fd55180b9d5dff4e SHA512 04d79f5c730965450d2cebd3a28d9d7908ccda9dcb6d6c0ae6fd91dae4149f2b837006eb35cd7f9e4fdb7245a971eb575a40abb8a445904614815af164e3cc8d WHIRLPOOL b3444ca96cd62a3510dc4336e0aede821901f68eeacee949dffa80780921e83f91762ccfefd5996034d033639561e36a40b0c0f2b31a5ef7d047b7501c489e50
diff --git a/sci-libs/pg2plplot/metadata.xml b/sci-libs/pg2plplot/metadata.xml
new file mode 100644
index 000000000..e8ef06d2d
--- /dev/null
+++ b/sci-libs/pg2plplot/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>AstroFloyd@gmail.com</email>
+ <name>AstroFloyd</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-libs/pg2plplot/pg2plplot-0.2.0.ebuild b/sci-libs/pg2plplot/pg2plplot-0.2.0.ebuild
new file mode 100644
index 000000000..e37ce0e90
--- /dev/null
+++ b/sci-libs/pg2plplot/pg2plplot-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit cmake-utils fortran-2
+
+DESCRIPTION="Assist the transition from PGPlot to PLplot in Fortran programs"
+HOMEPAGE="http://pg2plplot.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X png postscript static-libs"
+
+DEPEND="virtual/fortran
+ sci-libs/plplot[fortran]"
+
+# If USE="png" or "postscript", ensure PLplot has USE="cairo":
+RDEPEND="${DEPEND}
+ sci-libs/plplot[fortran,X?]
+ png? ( sci-libs/plplot[cairo] )
+ postscript? ( sci-libs/plplot[cairo] )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use static-libs CREATE_STATICLIB)
+ )
+ cmake-utils_src_configure
+}
+
+DOCS="CHANGELOG README VERSION"