aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoroli <oli@32389bae-6d03-0410-99cf-db05cde120eb>2008-08-26 20:03:42 +0000
committeroli <oli@32389bae-6d03-0410-99cf-db05cde120eb>2008-08-26 20:03:42 +0000
commit3b26de98101131a4d7974d522f47901de49bfc18 (patch)
treef0c7014e1871fd268b2e0abf8dab32c6ed49c606
parentsci-libs/cgnslib: New Ebuild for bug 176455 (diff)
downloadsci-3b26de98101131a4d7974d522f47901de49bfc18.tar.gz
sci-3b26de98101131a4d7974d522f47901de49bfc18.tar.bz2
sci-3b26de98101131a4d7974d522f47901de49bfc18.zip
sci-libs/cgnstools: New Ebuild for bug 176455
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1246 32389bae-6d03-0410-99cf-db05cde120eb
-rw-r--r--sci-libs/cgnstools/ChangeLog8
-rw-r--r--sci-libs/cgnstools/Manifest5
-rw-r--r--sci-libs/cgnstools/cgnstools-2.5.2.ebuild84
-rw-r--r--sci-libs/cgnstools/metadata.xml5
4 files changed, 102 insertions, 0 deletions
diff --git a/sci-libs/cgnstools/ChangeLog b/sci-libs/cgnstools/ChangeLog
new file mode 100644
index 000000000..7e478bc16
--- /dev/null
+++ b/sci-libs/cgnstools/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sci-libs/cgnstools
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 26 Aug 2008; Oliver Borm (boroli) <oli.borm@web.de>
+ +cgnstools-2.5.2.ebuild, +metadata.xml:
+ Ebuild for cgnstools from bug 176455
+
diff --git a/sci-libs/cgnstools/Manifest b/sci-libs/cgnstools/Manifest
new file mode 100644
index 000000000..1ee8d6224
--- /dev/null
+++ b/sci-libs/cgnstools/Manifest
@@ -0,0 +1,5 @@
+DIST cgnslib_2.5-2.tar.gz 390011 RMD160 9ef07fd8ebcebb74ab9a3cc39303fe2e3b722b7e SHA1 b1b5a8e9f73f12c04e5ebda92f9d6e8a347ecf30 SHA256 5e12a8042f1564a0d16f5eebecc79508684de68e0ba192cf44217e075d41de2c
+DIST cgnstools-2-5-2.tar.gz 1385150 RMD160 93b100853f609191d034e6a5caf5ed5e8c374b7e SHA1 6b2eebd709002e1e2a6f6fe00e8375f0dc03b783 SHA256 88bd5c1d0cb1d62ca2f26bd3d3e89adf694c3277b1a0aac4591f1312cafcc7e4
+EBUILD cgnstools-2.5.2.ebuild 2528 RMD160 b085621e26f01c7121a61185dc69b76cc5961d2f SHA1 abd80d5a51f37bc0dd2fbf4a22cad9bcb17628d9 SHA256 310c1af561be392cce6d320518731bad0e42faaf2d110cd744e2e999958a0c13
+MISC ChangeLog 255 RMD160 3ca7ce68f017300905d391e1f21cd604925aa698 SHA1 e873fda2adf085fcfcdc5ced4e333dc6447957a7 SHA256 6662537656b836944d747a77ca265716c68b9ccf27396b8efd8e6c1543c71aca
+MISC metadata.xml 156 RMD160 dc078172bfebcb25d69bdf8731714f9cce9d3e36 SHA1 da2b240a255820145b7c83a5c48e45b96b7e9ee6 SHA256 5d22100902db7507a5b5493dd4a66cdb08025faf80a2c0b75e6392315c47f900
diff --git a/sci-libs/cgnstools/cgnstools-2.5.2.ebuild b/sci-libs/cgnstools/cgnstools-2.5.2.ebuild
new file mode 100644
index 000000000..e11ae7ade
--- /dev/null
+++ b/sci-libs/cgnstools/cgnstools-2.5.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator multilib
+
+MY_P="${PN}-$(replace_all_version_separators '-')"
+MY_LIB_PN="cgnslib_"
+MY_LIB_P="${MY_LIB_PN}$(replace_version_separator 2 '-')"
+MY_LIB_SHORT_P="${MY_LIB_PN}$(get_version_component_range 1-2 ${PV})"
+
+DESCRIPTION="The CFD General Notation System (CGNS) tools."
+HOMEPAGE="http://www.cgns.org/"
+SRC_URI="mirror://sourceforge/cgns/${MY_P}.tar.gz
+ mirror://sourceforge/cgns/${MY_LIB_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fortran tcl tk hdf5 szip zlib X"
+
+RDEPEND="sci-libs/cgnslib
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/"${PN}"
+
+src_compile() {
+ sed -i -e "s| g77 | gfortran |" \
+ -e 's|-Wl,-rpath,$cgnsdir/\\$(SYSTEM)|-Wl,-soname,libcgns.so|' \
+ -e 's|-Wl,-R,$cgnsdir/\\$(SYSTEM)|-Wl,-soname,libcgns.so|' "${WORKDIR}"/"${MY_LIB_SHORT_P}"/configure
+
+ local myconf
+ use amd64 && myconf="${myconf} --enable-64bit"
+ myconf="${myconf} --enable-gcc"
+ myconf_lib="${myconf} --enable-lfs --enable-shared"
+
+ cd "${WORKDIR}/${MY_LIB_SHORT_P}"
+ econf \
+ $(use_with fortran) \
+ $(use_with hdf5) \
+ $(use_with zlib) \
+ $(use_with szip) \
+ ${myconf_lib}
+
+ cd "${S}"
+
+ sed -i -e "s|@STRIP@|true|" \
+ -e "s|\\\$(EXE_INSTALL_DIR)/cgnswish|\\\$(EXE_INSTALL_DIR)|" "${S}"/make.defs.in
+
+ sed -i -e "s|CGNSLIB=\\\\\\$\\\(CGNSDIR\\\)/lib/\\\\\\$\\\(LIBCGNS\\\)|CGNSLIB=/usr/$(get_libdir)/libcgns.so|" \
+ -e "s|CGNSLIB=\\\\\\$\\\(CGNSDIR\\\)/\\\\\\$\\\(LIBCGNS\\\)|CGNSLIB=/usr/$(get_libdir)/libcgns.so|" \
+ -e "s|CGNSLIB=\\\$adfhdir/\\\\\\$\\\(SYSTEM\\\)/libcgns.\\\\\\$\\\(A\\\)|CGNSLIB=/usr/$(get_libdir)/libcgns.so|" \
+ -e "s|/unix/|/../|" \
+ -e "s|BIN_INSTALL_DIR/\\\$SYSTEM|BIN_INSTALL_DIR|" "${S}"/configure
+
+ myconf="${myconf} --with-cgns=${WORKDIR}/${MY_LIB_SHORT_P} --bindir=${D}/usr/bin --datadir=${D}/usr/share/${PN}"
+
+ if use tcl ; then
+ TCLVER="$(echo 'puts [info tclversion]' | $(type -P tclsh))"
+ myconf="${myconf} $(use_with tcl tcl /usr/$(get_libdir)/tcl${TCLVER})"
+ fi
+
+ if use tk ; then
+ # no, there's no tkversion, and type -P wish requires running X
+ TKVER="$(echo 'puts [info tclversion]' | $(type -P tclsh))"
+ myconf="${myconf} $(use_with tk tk /usr/$(get_libdir)/tk${TKVER})"
+ fi
+
+ econf \
+ $(use_with X x) \
+ ${myconf} \
+ || die "econf failed"
+
+ emake || die "emake tools failed"
+}
+
+src_install() {
+ sed -i -e "s|${D}||" "${S}"/cgconfig
+
+ emake DESTDIR="${D}" install || die "install failed"
+}
diff --git a/sci-libs/cgnstools/metadata.xml b/sci-libs/cgnstools/metadata.xml
new file mode 100644
index 000000000..b229aec85
--- /dev/null
+++ b/sci-libs/cgnstools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>