aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-16 17:15:37 +0200
committerJustin Lecher <jlec@gentoo.org>2013-06-16 17:15:37 +0200
commit3e1cb4dc9866f4cebd8eeedfac3ff142c872a7d2 (patch)
tree82ec2ceebae1c4ecc1fe78676d36f1fac8a194e6
parentsci-chemistry/pyquante: Bump to EAPI=5 and distutils-r1.eclass (diff)
downloadsci-3e1cb4dc9866f4cebd8eeedfac3ff142c872a7d2.tar.gz
sci-3e1cb4dc9866f4cebd8eeedfac3ff142c872a7d2.tar.bz2
sci-3e1cb4dc9866f4cebd8eeedfac3ff142c872a7d2.zip
sci-chemistry/specView: Bump to EAPI=5 and python-single-r1.eclass
Package-Manager: portage-2.2.0_alpha180
-rw-r--r--sci-chemistry/specView/ChangeLog3
-rw-r--r--sci-chemistry/specView/specView-1.0.2.ebuild52
2 files changed, 19 insertions, 36 deletions
diff --git a/sci-chemistry/specView/ChangeLog b/sci-chemistry/specView/ChangeLog
index 09193d635..b6fe2af69 100644
--- a/sci-chemistry/specView/ChangeLog
+++ b/sci-chemistry/specView/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 16 Jun 2013; Justin Lecher <jlec@gentoo.org> specView-1.0.2.ebuild:
+ Bump to EAPI=5 and python-single-r1.eclass
+
03 Mar 2013; Justin Lecher <jlec@gentoo.org> specView-1.0.2.ebuild,
metadata.xml:
Fix quoting
diff --git a/sci-chemistry/specView/specView-1.0.2.ebuild b/sci-chemistry/specView/specView-1.0.2.ebuild
index 89666a69d..a0a5bac38 100644
--- a/sci-chemistry/specView/specView-1.0.2.ebuild
+++ b/sci-chemistry/specView/specView-1.0.2.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
-PYTHON_DEPEND="2"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit python toolchain-funcs
+inherit multilib python-single-r1 toolchain-funcs
DESCRIPTION="Fast way to visualise NMR spectrum and peak data"
HOMEPAGE="http://www.ccpn.ac.uk/software/specview"
@@ -18,8 +18,8 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
RDEPEND="
- dev-python/pyopengl
- dev-python/pyside[webkit]"
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/pyside[webkit,${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
S="${WORKDIR}"/ccpnmr/ccpnmr3.0/
@@ -30,11 +30,6 @@ S="${WORKDIR}"/ccpnmr/ccpnmr3.0/
#unbundle inchi
#parallel build
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
src_prepare() {
sed \
-e "s|/usr|"${EPREFIX}"/usr|g" \
@@ -43,7 +38,7 @@ src_prepare() {
-e "/^OPT_FLAG/s:=.*$:= ${CFLAGS}:g" \
-e "/^LINK_FLAGS/s:$: ${LDFLAGS}:g" \
-e "/^PYTHON_DIR/s:=.*:= "${EPREFIX}"/usr:g" \
- -e "/^PYTHON_LIB/s:=.*:= $(python_get_library -l):g" \
+ -e "/^PYTHON_LIB/s:=.*:= $(python_get_LIBS):g" \
-e "/^PYTHON_INCLUDE_FLAGS/s:=.*:= -I"${EPREFIX}"$(python_get_includedir) -I"${EPREFIX}"$(python_get_sitedir)/numpy/core/include/numpy:g" \
-e "/^PYTHON_LIB_FLAGS/s:=.*:= -L"${EPREFIX}"/usr/$(get_libdir):g" \
-e "/^SHARED_FLAGS/s:=.*:= -shared:g" \
@@ -72,37 +67,22 @@ src_install() {
find . -name "*.pyc" -type f -delete
dodir /usr/bin
sed \
- -e "s|gentoo_sitedir|${EPREFIX}$(python_get_sitedir)|g" \
- -e "s|gentoolibdir|${EPREFIX}/usr/${libdir}|g" \
- -e "s|gentootk|${EPREFIX}/usr/${libdir}/tk${tkver}|g" \
- -e "s|gentootcl|${EPREFIX}/usr/${libdir}/tclk${tkver}|g" \
- -e "s|gentoopython|$(PYTHON -a)|g" \
- -e "s|gentoousr|${EPREFIX}/usr|g" \
- -e "s|//|/|g" \
+ -e "s|gentoo_sitedir|${EPREFIX}$(python_get_sitedir)|g" \
+ -e "s|gentoolibdir|${EPREFIX}/usr/${libdir}|g" \
+ -e "s|gentootk|${EPREFIX}/usr/${libdir}/tk${tkver}|g" \
+ -e "s|gentootcl|${EPREFIX}/usr/${libdir}/tclk${tkver}|g" \
+ -e "s|gentoopython|${PYTHON}|g" \
+ -e "s|gentoousr|${EPREFIX}/usr|g" \
+ -e "s|//|/|g" \
"${FILESDIR}"/${PN} > "${ED}"/usr/bin/${PN} || die
fperms 755 /usr/bin/${PN}
- insinto ${in_path}
-
dodir ${in_path}/cNg
rm -rf cNg || die
ebegin "Installing main files"
- doins -r *
- eend
-
- ebegin "Adjusting permissions"
-
- for _file in $(find "${ED}" -type f -name "*so"); do
- chmod 755 ${_file}
- done
+ python_moduleinto ${PN}
+ python_domodule *
eend
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
+ python_optimize
}