aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-11-18 18:15:13 +0000
committerJustin Lecher <jlec@gentoo.org>2017-11-18 19:49:15 +0000
commit3f172f3c7afc1a9d9f1e98b1dd6ad3bb822683bc (patch)
tree480fc01cf67bc4d40dcb1c5444d392e68bd217c3
parentsci-visualization/mantid: Dropped due to missing dependency (diff)
downloadsci-3f172f3c7afc1a9d9f1e98b1dd6ad3bb822683bc.tar.gz
sci-3f172f3c7afc1a9d9f1e98b1dd6ad3bb822683bc.tar.bz2
sci-3f172f3c7afc1a9d9f1e98b1dd6ad3bb822683bc.zip
dev-lang/pgi: Bump to EAPI 6
* Fix repoman warnings Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.14, Repoman-2.3.6 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-lang/pgi/metadata.xml6
-rw-r--r--dev-lang/pgi/pgi-13.5.ebuild18
2 files changed, 11 insertions, 13 deletions
diff --git a/dev-lang/pgi/metadata.xml b/dev-lang/pgi/metadata.xml
index e355aa225..93c720670 100644
--- a/dev-lang/pgi/metadata.xml
+++ b/dev-lang/pgi/metadata.xml
@@ -2,7 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<longdescription>
- PGI is the C/C++/Fortran compiler suite of the Portland Group.
+ PGI is the C/C++/Fortran compiler suite of the Portland Group.
</longdescription>
<maintainer type="person">
<email>gentryx@gmx.de</email>
@@ -12,7 +12,7 @@
<name>Gentoo Cluster Project</name>
</maintainer>
<use>
- <flag name="java">Install a PGI-tuned JRE.</flag>
- <flag name="cuda">Install PGI's CUDA components (e.g. for OpenACC)</flag>
+ <flag name="java">Install a PGI-tuned JRE.</flag>
+ <flag name="cuda">Install PGI's CUDA components (e.g. for OpenACC)</flag>
</use>
</pkgmetadata>
diff --git a/dev-lang/pgi/pgi-13.5.ebuild b/dev-lang/pgi/pgi-13.5.ebuild
index 0f747a78d..19c636132 100644
--- a/dev-lang/pgi/pgi-13.5.ebuild
+++ b/dev-lang/pgi/pgi-13.5.ebuild
@@ -1,9 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit eutils
+EAPI=6
DESCRIPTION="PGI compiler suite"
HOMEPAGE="http://www.pgroup.com/"
@@ -46,15 +44,13 @@ QA_PREBUILT="
S="${WORKDIR}"
+PATCHES=( "${FILESDIR}"/${P}-terminal.patch )
+
pkg_nofetch() {
einfo "PGI doesn't provide direct download links. Please download"
einfo "${ARCHIVE} from ${HOMEPAGE}"
}
-src_prepare() {
- epatch "${FILESDIR}/${P}-terminal.patch"
-}
-
src_install() {
dodir /opt/pgi
@@ -97,11 +93,13 @@ EOF
epatch "${FILESDIR}/${P}-glibc.patch"
# java symlink might be broken if useflag is disabled:
- use java || rm opt/pgi/linux86-64/13.5/jre
+ if ! use java; then
+ rm opt/pgi/linux86-64/13.5/jre || die
+ fi
# replace PGI's curl with the stock version:
dodir /opt/pgi/linux86-64/13.5/etc/pgi_license_tool
- dosym /usr/bin/curl /opt/pgi/linux86-64/13.5/etc/pgi_license_tool/curl
+ dosym ../../../../../../usr/bin/curl /opt/pgi/linux86-64/13.5/etc/pgi_license_tool/curl
dodir /opt/pgi/linux86/13.5/etc/pgi_license_tool
- dosym /usr/bin/curl /opt/pgi/linux86/13.5/etc/pgi_license_tool/curl
+ dosym ../../../../../../usr/bin/curl /opt/pgi/linux86/13.5/etc/pgi_license_tool/curl
}