aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <seb@localhost.(none)>2010-02-04 22:08:02 +0000
committerSebastien Fabbro <seb@localhost.(none)>2010-02-04 22:08:02 +0000
commit3f36b03a52c85c030190fcc97261410dd6bc285a (patch)
treeb267bb83cd9e86a605186febbeabe85b069497fe
parentadded mpi support for hdf-java (diff)
downloadsci-3f36b03a52c85c030190fcc97261410dd6bc285a.tar.gz
sci-3f36b03a52c85c030190fcc97261410dd6bc285a.tar.bz2
sci-3f36b03a52c85c030190fcc97261410dd6bc285a.zip
mpi and libc fixes
-rw-r--r--sci-mathematics/scilab/ChangeLog7
-rw-r--r--sci-mathematics/scilab/Manifest5
-rw-r--r--sci-mathematics/scilab/files/scilab-5.2.0-no-redef-exp10.patch13
-rw-r--r--sci-mathematics/scilab/scilab-5.2.0-r1.ebuild (renamed from sci-mathematics/scilab/scilab-5.2.0.ebuild)30
4 files changed, 42 insertions, 13 deletions
diff --git a/sci-mathematics/scilab/ChangeLog b/sci-mathematics/scilab/ChangeLog
index 89839c9e7..110b646fb 100644
--- a/sci-mathematics/scilab/ChangeLog
+++ b/sci-mathematics/scilab/ChangeLog
@@ -2,6 +2,13 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*scilab-5.2.0-r1 (04 Feb 2010)
+
+ 04 Feb 2010; Sébastien Fabbro <bicatali@gentoo.org> -scilab-5.2.0.ebuild,
+ +scilab-5.2.0-r1.ebuild, +files/scilab-5.2.0-no-redef-exp10.patch:
+ MPI goodness for the hdf5 option, and added a patch to avoid libc
+ redefinitions. A bit of cleanup
+
22 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org> +scilab-5.2.0.ebuild,
+metadata.xml:
Import of new scilab-5.2. Thanks Guillaume Horel for his work, bug #237572
diff --git a/sci-mathematics/scilab/Manifest b/sci-mathematics/scilab/Manifest
index a9341b374..0e6e8f326 100644
--- a/sci-mathematics/scilab/Manifest
+++ b/sci-mathematics/scilab/Manifest
@@ -1,4 +1,5 @@
+AUX scilab-5.2.0-no-redef-exp10.patch 480 RMD160 b3a6dff50b5be722f177d8d61aa41dcf721ede66 SHA1 fcfd8ea8e7b665bf6aa36ee3eb5c5e735a0b5b4a SHA256 7eb72fe6eb088d27392a0751e33791fdc2dce7937b27f296a6e54b0c3f245968
DIST scilab-5.2.0-src.tar.gz 54656677 RMD160 8a14582779d5b413c3c20cc13824e0773f7f4327 SHA1 ba919f9af86ac97b22e8be915302e1de104fbc01 SHA256 3412d4343cd3ca6ba0b03b28fec66a00f643d4d73f13dc28c0f6596ccb9f386a
-EBUILD scilab-5.2.0.ebuild 2963 RMD160 6bd3395a888fcb361027bb49d432c42014f91b8f SHA1 23f28dd125856eb83f2fc2c6482dfc247507f3f3 SHA256 7932c2a75ec56ceadd229260615a6fc4feed04da0ea3ed98705f5010712aaf96
-MISC ChangeLog 479 RMD160 85406fe8237d62064e14c4e6ee76223da177e25e SHA1 7d13cc979425498bb8ac5963076b03911a0789cb SHA256 310de9c10c5f66842e4861b19c9cf8ff0b0df0aabb5d3b3fc2a037d3ab421f45
+EBUILD scilab-5.2.0-r1.ebuild 3077 RMD160 857050b56875a43fe76c25f7f7161b4c41ed9fd1 SHA1 2bceb351fbdefbaa53649a0211b8de91b6dffc29 SHA256 555dfb9aee27b3732089ec17cab0c3be16199036c6738ed732d83bc7d483de27
+MISC ChangeLog 760 RMD160 ee0973de767e30b75393aae8d0ed02899ed338d2 SHA1 9cb194645fff6894923bf8a8c9f8fb8a1d1df105 SHA256 0c12d1a4f93dbb2ad4f21e91bfac487efb62b0388bc3f5faf1b33a7e4f485262
MISC metadata.xml 856 RMD160 a72e4dc9351faf4a7c9d4cb5b8547477389be701 SHA1 6eb020ce9bdae52a285bfe9aa179f79a70d2b918 SHA256 7966c4663ba898e8e26bb2b748041ac0043ba613bb0f9468139b1dd0b0694b1e
diff --git a/sci-mathematics/scilab/files/scilab-5.2.0-no-redef-exp10.patch b/sci-mathematics/scilab/files/scilab-5.2.0-no-redef-exp10.patch
new file mode 100644
index 000000000..4eabb4e09
--- /dev/null
+++ b/sci-mathematics/scilab/files/scilab-5.2.0-no-redef-exp10.patch
@@ -0,0 +1,13 @@
+--- configure.ac.orig 2010-02-04 20:07:14.000000000 +0000
++++ configure.ac 2010-02-04 20:07:53.000000000 +0000
+@@ -894,10 +894,6 @@
+
+ AC_CHECK_FUNCS([pow] [sqrt] [finite] [floor])
+
+-AC_CHECK_FUNC([exp10],,[
+- AC_DEFINE([log_10_],[2.3025850929940456840179914546844],[Provide a macro to do exp10])
+- AC_DEFINE([exp10(x)],[exp( (log_10_) * (x) )],[Provide a macro to do exp10])
+- ])
+
+ ### If isinf exists or not (used to not be the case under Solaris)
+ ### See bug #4164
diff --git a/sci-mathematics/scilab/scilab-5.2.0.ebuild b/sci-mathematics/scilab/scilab-5.2.0-r1.ebuild
index 980321ec9..340b7ef63 100644
--- a/sci-mathematics/scilab/scilab-5.2.0.ebuild
+++ b/sci-mathematics/scilab/scilab-5.2.0-r1.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-4.1.2-r1.ebuild,v 1.3 2008/11/15 18:41:11 dertobi123 Exp $
+# $Header: $
EAPI=2
inherit eutils autotools java-pkg-2
-DESCRIPTION="Scientific software package for numerical computations (Matlab lookalike)"
+DESCRIPTION="Scientific software package for numerical computations"
LICENSE="CeCILL-2"
SRC_URI="http://www.scilab.org/download/${PV}/${P}-src.tar.gz"
HOMEPAGE="http://www.scilab.org/"
SLOT="0"
-IUSE="tk scicos +umfpack +gui fftw +gui doc +matio hdf5"
+IUSE="doc fftw +gui hdf5 +matio mpi scicos tk +umfpack"
KEYWORDS="~amd64 ~x86"
RDEPEND="virtual/lapack
@@ -29,10 +29,11 @@ RDEPEND="virtual/lapack
dev-java/jgoodies-looks
dev-java/skinlf
dev-java/jrosetta
- dev-java/javahelp )
+ dev-java/javahelp
+ hdf5? ( dev-java/hdf-java[mpi=] ) )
fftw? ( sci-libs/fftw:3.0 )
matio? ( sci-libs/matio )
- hdf5? ( dev-java/hdf-java )"
+ hdf5? ( sci-libs/hdf5[mpi=] )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
@@ -43,6 +44,8 @@ DEPEND="${RDEPEND}
app-text/docbook-xsl-stylesheets )"
src_prepare() {
+ # avoid redefinition of exp10
+ epatch "${FILESDIR}"/${P}-no-redef-exp10.patch
#add the correct java directories to the config file
sed \
-i "/^.DEFAULT_JAR_DIR/{s|=.*|=\"$(echo $(ls -d /usr/share/*/lib))\"|}" \
@@ -51,24 +54,30 @@ src_prepare() {
sed -i "s|-L\$SCI_SRCDIR/bin/|-L\$SCI_SRCDIR/bin/ \
-L$(java-config -i gluegen) \
-L$(java-config -i hdf-java) \
- -L$(java-config -i jogl)|" configure.ac || die
- eautoreconf
+ -L$(java-config -i jogl)|" \
+ configure.ac || die
sed -i \
-e "/<\/librarypaths>/i\<path value=\"$(java-config -i gluegen)\"\/>" \
-e "/<\/librarypaths>/i\<path value=\"$(java-config -i jogl)\"\/>" \
-e "/<\/librarypaths>/i\<path value=\"$(java-config -i hdf-java)\"\/>" \
etc/librarypath.xml || die
+ eautoreconf
java-pkg-2_src_prepare
}
src_configure() {
local myopts
use doc && myopts="--with-docbook=/usr/share/sgml/docbook/xsl-stylesheets"
-
export JAVA_HOME=$(java-config -O)
export BLAS_LIBS="$(pkg-config --libs blas)"
export LAPACK_LIBS="$(pkg-config --libs lapack)"
-
+ # mpi is only used for hdf5 i/o
+ if use mpi && use hdf5; then
+ export CC=mpicc
+ export CXX=mpicxx
+ export FC=mpif90
+ export F77=mpif77
+ fi
econf \
--disable-rpath \
--without-pvm \
@@ -101,8 +110,7 @@ src_install() {
#install icon
newicon icons/scilab.xpm scilab.xpm
-
- make_desktop_entry ${PN} "Scilab" ${PN} "Education;Math"
+ make_desktop_entry ${PN} "Scilab" ${PN}
}
pkg_postinst() {