aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-03-15 15:08:29 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-03-15 15:08:29 +0000
commit3f6eea6d00790261c647aa05101d05bdbbef74b0 (patch)
tree2a4e6fcf8430100f4fcc4bf6bec5b7636db5d4bf
parentopenmpi-1.0.1.ebuild: added pic use flag and corrected fortran stuff (diff)
downloadsci-3f6eea6d00790261c647aa05101d05bdbbef74b0.tar.gz
sci-3f6eea6d00790261c647aa05101d05bdbbef74b0.tar.bz2
sci-3f6eea6d00790261c647aa05101d05bdbbef74b0.zip
scipy-0.4.6.ebuild: eselect corrections
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@121 32389bae-6d03-0410-99cf-db05cde120eb
-rw-r--r--sci-libs/scipy/Manifest4
-rw-r--r--sci-libs/scipy/files/digest-scipy-0.4.41
-rw-r--r--sci-libs/scipy/scipy-0.4.4.ebuild55
-rw-r--r--sci-libs/scipy/scipy-0.4.6.ebuild48
4 files changed, 29 insertions, 79 deletions
diff --git a/sci-libs/scipy/Manifest b/sci-libs/scipy/Manifest
index 2fb3d4628..646663cdf 100644
--- a/sci-libs/scipy/Manifest
+++ b/sci-libs/scipy/Manifest
@@ -1,6 +1,4 @@
MD5 e9fb7edfed65991c7026915252774a16 ChangeLog 563
-MD5 a949de96fef5b6758302142a51404cce files/digest-scipy-0.4.4 64
MD5 190361bc8c86c26f2509e2711bf3a82c files/digest-scipy-0.4.6 64
MD5 51dd57e78f009510e5b3a8384723e22d metadata.xml 686
-MD5 6ee78283245d2fa4de4a4065a6058e3e scipy-0.4.4.ebuild 1389
-MD5 d7e90b39b59ff8a425d80355e174d8aa scipy-0.4.6.ebuild 1396
+MD5 d4ca13b552349bbe204c3d55be56d36d scipy-0.4.6.ebuild 1367
diff --git a/sci-libs/scipy/files/digest-scipy-0.4.4 b/sci-libs/scipy/files/digest-scipy-0.4.4
deleted file mode 100644
index 72a88a608..000000000
--- a/sci-libs/scipy/files/digest-scipy-0.4.4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 b4e40265fc9d37fbaee809fff6c84469 scipy-0.4.4.tar.gz 2192200
diff --git a/sci-libs/scipy/scipy-0.4.4.ebuild b/sci-libs/scipy/scipy-0.4.4.ebuild
deleted file mode 100644
index dc4694ba9..000000000
--- a/sci-libs/scipy/scipy-0.4.4.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit distutils fortran
-
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-DESCRIPTION="Open source scientific tools for Python"
-HOMEPAGE="http://www.scipy.org/"
-LICENSE="BSD"
-
-SLOT="0"
-IUSE="fftw"
-KEYWORDS="~x86"
-#keyworded to x86 only because of numpy
-#could use any lapack, but it seems that lapack-atlas provides non-f2c clapack routines
-RDEPEND=">=dev-lang/python-2.3.3
- >=dev-python/numpy-0.9.2
- virtual/blas
- sci-libs/lapack-atlas
- fftw? ( =sci-libs/fftw-2.1* )"
-
-# install doc claims fftw-2 is faster for complex ffts.
-# install doc claims gcc-4 not fully tested
-# wxwindows seems to have disapeared.
-# f2py seems to be in numpy.
-#
-FORTRAN="g77"
-
-DEPEND="${RDEPEND}
- app-admin/eselect
- =sys-devel/gcc-3*"
-
-pkg_setup() {
- if [ -z "$(/usr/bin/eselect lapack show | grep ATLAS)" ]; then
- eerror "You need to set lapack-atlas to use this version of scipy"
- einfo "Please run:"
- einfo "\teselect lapack set ATLAS"
- einfo "or, if you have the threaded version:"
- einfo "\teselect lapack set threaded-ATLAS"
- einfo "And re-emerge scipy"
- die "setup failed"
- fi
-}
-
-src_test() {
- einfo "Testing installation ..."
- python -c "import scipy; scipy.test(level=1)" || \
- die "Unit tests failed!"
-}
-
-src_install() {
- distutils_src_install
- dodoc `ls *.txt`
-}
diff --git a/sci-libs/scipy/scipy-0.4.6.ebuild b/sci-libs/scipy/scipy-0.4.6.ebuild
index 0648ea3e3..28d6c6f0c 100644
--- a/sci-libs/scipy/scipy-0.4.6.ebuild
+++ b/sci-libs/scipy/scipy-0.4.6.ebuild
@@ -12,41 +12,49 @@ LICENSE="BSD"
SLOT="0"
IUSE="fftw"
KEYWORDS="~amd64 ~x86"
-#keyworded to x86 only because of numpy
-#could use any lapack, but it seems that lapack-atlas provides non-f2c clapack routines
+
+# did not use virtual/blas and virtual/lapack
+# because scipy needs to compile all libraries with the same compiler
+# needs more work
RDEPEND=">=dev-lang/python-2.3.3
>=dev-python/numpy-0.9.5
- virtual/blas
+ sci-libs/blas-atlas
sci-libs/lapack-atlas
fftw? ( =sci-libs/fftw-2.1* )"
+DEPEND="${RDEPEND}
+ app-admin/eselect
+ =sys-devel/gcc-3*"
+
# install doc claims fftw-2 is faster for complex ffts.
# install doc claims gcc-4 not fully tested
-# wxwindows seems to have disapeared.
+# wxwindows seems to have disapeared : ?
# f2py seems to be in numpy.
-#
-FORTRAN="g77"
+#
-DEPEND="${RDEPEND}
- app-admin/eselect
- =sys-devel/gcc-3*"
+FORTRAN="g77"
-pkg_setup() {
- if [ -z "$(/usr/bin/eselect lapack show | grep ATLAS)" ]; then
- eerror "You need to set lapack-atlas to use this version of scipy"
- einfo "Please run:"
- einfo "\teselect lapack set ATLAS"
- einfo "or, if you have the threaded version:"
- einfo "\teselect lapack set threaded-ATLAS"
- einfo "And re-emerge scipy"
- die "setup failed"
+pkg_setup() {
+ if [ -d "/usr/$(getlib_dir)/atlas/threaded-atlas" ]; then
+ eselect blas set threaded-ATLAS
+ else
+ eselect blas set ATLAS
fi
+ eselect lapack set ATLAS
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ einfo ""
+ echo "[atlas]" > site.cfg
+ echo "atlas_libs = lapack, blas, cblas, atlas" >> site.cfg
+ # let discover fftw by itself if installed
}
src_test() {
- einfo "Testing installation ..."
python -c "import scipy; scipy.test(level=1)" || \
- die "Unit tests failed!"
+ die "tests failed"
}
src_install() {