aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-03-27 01:50:09 -0400
committerHorea Christian <chr@chymera.eu>2020-03-27 01:50:09 -0400
commit40c090269df19d22445fd840215c4445f98296e6 (patch)
tree9687ac735ce08daa342c401f96a50bd0ee615dc6
parentmedia-libs/DualContouringSample: depend on media-libs/glm (diff)
downloadsci-40c090269df19d22445fd840215c4445f98296e6.tar.gz
sci-40c090269df19d22445fd840215c4445f98296e6.tar.bz2
sci-40c090269df19d22445fd840215c4445f98296e6.zip
dev-python/json_tricks: new package
dependency of upcoming sci-biology/psychopy version 2020.1.3 Package-Manager: Portage-2.3.95, Repoman-2.3.21 Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--dev-python/json_tricks/Manifest1
-rw-r--r--dev-python/json_tricks/json_tricks-3.14.0.ebuild25
-rw-r--r--dev-python/json_tricks/metadata.xml26
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/json_tricks/Manifest b/dev-python/json_tricks/Manifest
new file mode 100644
index 000000000..004c95997
--- /dev/null
+++ b/dev-python/json_tricks/Manifest
@@ -0,0 +1 @@
+DIST json_tricks-3.14.0.tar.gz 21572 BLAKE2B d69bd4fdeff4436a6a18ef9ab898bce3e3a78e09b9374b7a0876236fe61e5e038f634f0a58cdee6e99b79ae17a25515a778efa80d2ce72188c44da1a7f5048b3 SHA512 95182c0b23c50f4b84df9e2b876459d7221fee5f8fb28be5d3454c097e154aaf1de19ece1138667ffd7fb9fea3419033a0e6e2fea91d8e461813de72d653fc8e
diff --git a/dev-python/json_tricks/json_tricks-3.14.0.ebuild b/dev-python/json_tricks/json_tricks-3.14.0.ebuild
new file mode 100644
index 000000000..750faed73
--- /dev/null
+++ b/dev-python/json_tricks/json_tricks-3.14.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+MY_HASH="895ef50d8d9882e8030005103a205b2b5f169721ac5b3f265847da07729f"
+
+DESCRIPTION="Extra features for Python's JSON"
+HOMEPAGE="https://github.com/mverleg/pyjson_tricks"
+SRC_URI="mirror://pypi/../be/05/${MY_HASH}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND=""
+
+DEPEND=""
+
+distutils_enable_tests pytest
diff --git a/dev-python/json_tricks/metadata.xml b/dev-python/json_tricks/metadata.xml
new file mode 100644
index 000000000..f833d4463
--- /dev/null
+++ b/dev-python/json_tricks/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ The json-tricks package brings several pieces of functionality to
+ Python handling of json files: (1) Store and load numpy arrays in
+ human-readable format; (2) Store and load class instances both
+ generic and customized; (3) Store and load date/times as a
+ dictionary (including timezone); (4) Preserve map order {} using
+ OrderedDict; (5) Allow for comments in json files by starting lines
+ with #; (6) Sets, complex numbers, Decimal, Fraction, enums,
+ compression, duplicate keys, pathlib Paths ...
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">json-tricks</remote-id>
+ </upstream>
+</pkgmetadata>
+