aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-03-26 08:39:09 +0100
committerJustin Lecher <jlec@gentoo.org>2014-03-26 08:59:26 +0100
commit449645d3a0cf19fb66d1cfeaea85b301adc2b11a (patch)
treec29fe645ab45bd01cd561579a61128444c5a206d
parentsci-biology/ncbi-tools++: add deps on jpeg-turbo (diff)
downloadsci-449645d3a0cf19fb66d1cfeaea85b301adc2b11a.tar.gz
sci-449645d3a0cf19fb66d1cfeaea85b301adc2b11a.tar.bz2
sci-449645d3a0cf19fb66d1cfeaea85b301adc2b11a.zip
sci-chemistry/specView: Version BUmp
Package-Manager: portage-2.2.9-r1
-rw-r--r--sci-chemistry/specView/ChangeLog5
-rw-r--r--sci-chemistry/specView/Manifest1
-rw-r--r--sci-chemistry/specView/specView-1.0.3_p2.ebuild88
3 files changed, 94 insertions, 0 deletions
diff --git a/sci-chemistry/specView/ChangeLog b/sci-chemistry/specView/ChangeLog
index 6fcf527be..e7854b8de 100644
--- a/sci-chemistry/specView/ChangeLog
+++ b/sci-chemistry/specView/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*specView-1.0.3_p2 (26 Mar 2014)
+
+ 26 Mar 2014; Justin Lecher <jlec@gentoo.org> +specView-1.0.3_p2.ebuild:
+ Version BUmp
+
08 Jan 2014; Justin Lecher <jlec@gentoo.org> specView-1.0.3.ebuild:
Fix double prefix
diff --git a/sci-chemistry/specView/Manifest b/sci-chemistry/specView/Manifest
index f35353b9a..50c8ebc9f 100644
--- a/sci-chemistry/specView/Manifest
+++ b/sci-chemistry/specView/Manifest
@@ -1,2 +1,3 @@
DIST specView1.0.2.tar.gz 15811413 SHA256 3a8d8b9e0f15e6481d8d6ea9a1f51d06a3cd2a4295acc3dfaf9e4ee0e3b1509f SHA512 f3194148f90d9dbe706c33fefda9cb6db71e0812f83bbf94bb170170bd9d4fcd4eae6295ccc78c6544b093dfbf09512555405dfab5b0516152dce2cb25b18965 WHIRLPOOL d35dd8753565f29b36c55014b8b34f0a5c60fad9f4353d4a094b6a7d2010a9936e9e3e42d27c4d5e6076a861fe7eb424acf86c7847e0218e8877ffb4a9865411
DIST specView1.0.3.tar.gz 15675662 SHA256 24e88651b1c544db7967d2d650d03f5cf88092a5da7c333ea16d563a32ff57f8 SHA512 2d29121b0dfff6158e9d7a6e9f666eccae655f258720a2d595a21e81241a44c0cf5347acbbca420f70464a21eabd22041a8402fb26a814dacaed9ed90b10e25c WHIRLPOOL ccba371740a8d45a26072c02dfc98d7c0de00071665f745fa19d65c6470eb4edb10fac827519bf6b12c8ff6cb7e39c541f9b7f9aff20cfb83325ca8c8dc93f20
+DIST specView1.0.3r2.tar.gz 15739439 SHA256 0c843fc690cefd347f9845c64c60289965b906d68a9181e944b5ad0831544ba1 SHA512 8795eb643837475bccb611bb3067ee9675a668079fc6c12e3470d6d0c463932afa0499836a5d4728c2c7f582a18ea4c4f7713291fa429758ccbadb432e0671a9 WHIRLPOOL 4b73f2589fb4e7cfc4cc7f4b579355abc301c9def1e644aec621ab45741aceddc1e96bb34066aeb4a7f900b026073bc488f4b015fbfcbb3d38faf3f84ef05e44
diff --git a/sci-chemistry/specView/specView-1.0.3_p2.ebuild b/sci-chemistry/specView/specView-1.0.3_p2.ebuild
new file mode 100644
index 000000000..279a8fc60
--- /dev/null
+++ b/sci-chemistry/specView/specView-1.0.3_p2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="Fast way to visualise NMR spectrum and peak data"
+HOMEPAGE="http://www.ccpn.ac.uk/software/specview"
+SRC_URI="http://www2.ccpn.ac.uk/download/ccpnmr/${PN}${PV/_p/r}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( CCPN LGPL-2.1 )"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/pyside[webkit,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/ccpnmr/ccpnmr3.0/
+
+#TODO:
+#install in sane place
+#unbundle data model
+#unbundle inchi
+#parallel build
+
+src_prepare() {
+ sed \
+ -e "s|/usr|\"${EPREFIX}/usr\"|g" \
+ -e "s|^\(CC =\).*|\1 $(tc-getCC)|g" \
+ -e '/^MALLOC_FLAG/s:^:#:g' \
+ -e "/^OPT_FLAG/s:=.*$:= ${CFLAGS}:g" \
+ -e "/^LINK_FLAGS/s:$: ${LDFLAGS}:g" \
+ -e "/^PYTHON_DIR/s:=.*:= \"${EPREFIX}/usr\":g" \
+ -e "/^PYTHON_LIB/s:=.*:= $(python_get_LIBS):g" \
+ -e "/^PYTHON_INCLUDE_FLAGS/s:=.*:= -I\"$(python_get_includedir)\" -I\"$(python_get_sitedir)/numpy/core/include/numpy\":g" \
+ -e "/^PYTHON_LIB_FLAGS/s:=.*:= -L\"${EPREFIX}/usr/$(get_libdir)\":g" \
+ -e "/^SHARED_FLAGS/s:=.*:= -shared:g" \
+ -e "/^GL_DIR/s:=.*:= \"${EPREFIX}/usr/$(get_libdir)\":g" \
+ -e "/^GL_INCLUDE_FLAGS/s:=.*:= -I\"${EPREFIX}/usr/include\":g" \
+ -e "/^GL_LIB_FLAGS/s:=.*:= -L\"${EPREFIX}/usr/$(get_libdir)\":g" \
+ cNg/environment_default.txt > cNg/environment.txt || die
+ echo "SHARED_LINK_PARM = ${LDFLAGS}" >> cNg/environment.txt || die
+
+ rm -rf license || die
+
+ sed \
+ -e 's:ln -s:cp -f:g' \
+ -i $(find python -name linkSharedObjs) || die
+}
+
+src_compile() {
+ emake -C cNg all
+ emake -j1 -C cNg links
+}
+
+src_install() {
+ local in_path=$(python_get_sitedir)/${PN}
+ local _file
+
+ find . -name "*.pyc" -type f -delete
+ dodir /usr/bin
+ sed \
+ -e "s|gentoo_sitedir|$(python_get_sitedir)|g" \
+ -e "s|gentoolibdir|${EPREFIX}/usr/${libdir}|g" \
+ -e "s|gentootk|${EPREFIX}/usr/${libdir}/tk${tkver}|g" \
+ -e "s|gentootcl|${EPREFIX}/usr/${libdir}/tclk${tkver}|g" \
+ -e "s|gentoopython|${PYTHON}|g" \
+ -e "s|gentoousr|\"${EPREFIX}/usr\"|g" \
+ -e "s|//|/|g" \
+ "${FILESDIR}"/${PN} > "${ED}"/usr/bin/${PN} || die
+ fperms 755 /usr/bin/${PN}
+
+ dodir "${in_path#${EPREFIX}}/cNg"
+ rm -rf cNg || die
+
+ ebegin "Installing main files"
+ python_moduleinto ${PN}
+ python_domodule *
+ eend
+ python_optimize
+}