aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-06 19:33:08 +0100
committerJustin Lecher <jlec@gentoo.org>2014-01-06 19:33:08 +0100
commit471b5e3ed3a735d5cada410af66e6cb063fa8eae (patch)
tree305df1e99056c5caf19a75867cafbf24e708283b
parentsci-chemistry/openbabel: Switch from git-2 to git-r3 (diff)
downloadsci-471b5e3ed3a735d5cada410af66e6cb063fa8eae.tar.gz
sci-471b5e3ed3a735d5cada410af66e6cb063fa8eae.tar.bz2
sci-471b5e3ed3a735d5cada410af66e6cb063fa8eae.zip
sci-chemistry/openbabel-java: Switch from git-2 to git-r3
Package-Manager: portage-2.2.8
-rw-r--r--sci-chemistry/openbabel-java/ChangeLog5
-rw-r--r--sci-chemistry/openbabel-java/openbabel-java-9999.ebuild15
2 files changed, 12 insertions, 8 deletions
diff --git a/sci-chemistry/openbabel-java/ChangeLog b/sci-chemistry/openbabel-java/ChangeLog
index 36777b53b..c09c3eb00 100644
--- a/sci-chemistry/openbabel-java/ChangeLog
+++ b/sci-chemistry/openbabel-java/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sci-chemistry/openbabel-java
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 06 Jan 2014; Justin Lecher <jlec@gentoo.org> openbabel-java-9999.ebuild:
+ Switch from git-2 to git-r3
+
*openbabel-java-9999 (24 Sep 2013)
24 Sep 2013; Reinis Danne <rei4dan@gmail.com> +openbabel-java-9999.ebuild,
diff --git a/sci-chemistry/openbabel-java/openbabel-java-9999.ebuild b/sci-chemistry/openbabel-java/openbabel-java-9999.ebuild
index fc7ca33e3..601653cca 100644
--- a/sci-chemistry/openbabel-java/openbabel-java-9999.ebuild
+++ b/sci-chemistry/openbabel-java/openbabel-java-9999.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-inherit cmake-utils eutils java-pkg-2 git-2
+inherit cmake-utils eutils java-pkg-2 git-r3
DESCRIPTION="Java bindings for OpenBabel"
HOMEPAGE="http://openbabel.sourceforge.net/"
+SRC_URI=""
EGIT_REPO_URI="https://github.com/openbabel/openbabel.git"
LICENSE="GPL-2"
@@ -33,11 +34,11 @@ src_configure() {
-DOB_MODULE_PATH=${EPREFIX}/usr/$(get_libdir)/openbabel/${PV}
-DLIB_INSTALL_DIR=${S}/$(get_libdir)
-DJAVA_BINDINGS=ON
- -DJAVA_INCLUDE_PATH=${EPREFIX}$(java-config-2 -o)/include
- -DJAVA_INCLUDE_PATH2=${EPREFIX}$(java-config-2 -o)/include/linux
- -DJAVA_AWT_INCLUDE_PATH=${EPREFIX}$(java-config-2 -o)/include
- -DJAVA_AWT_LIBRARY=${EPREFIX}$(java-config-2 -o)/jre/lib/${ABI}/libjawt.so
- -DJAVA_JVM_LIBRARY=${EPREFIX}$(java-config-2 -o)/jre/lib/${ABI}/server/libjvm.so
+ -DJAVA_INCLUDE_PATH=${EPREFIX}/etc/java-config-2/current-system-vm/include
+ -DJAVA_INCLUDE_PATH2=${EPREFIX}/etc/java-config-2/current-system-vm/include/linux
+ -DJAVA_AWT_INCLUDE_PATH=${EPREFIX}/etc/java-config-2/current-system-vm/include
+ -DJAVA_AWT_LIBRARY=${EPREFIX}/etc/java-config-2/current-system-vm/jre/lib/${ABI}/libjawt.so
+ -DJAVA_JVM_LIBRARY=${EPREFIX}/etc/java-config-2/current-system-vm/jre/lib/${ABI}/server/libjvm.so
-DRUN_SWIG=ON"
cmake-utils_src_configure