aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jbronder@gentoo.org>2013-07-08 21:11:30 -0400
committerJustin Bronder <jbronder@gentoo.org>2013-07-08 21:11:30 -0400
commit4ba599724202bcbfbf55d0d8b9de472939b2b41e (patch)
tree8d1e27f9b3b88e55e858a7b2358e35356af4ecb4
parentdev-java/xmlgraphics-commons package removal (diff)
downloadsci-4ba599724202bcbfbf55d0d8b9de472939b2b41e.tar.gz
sci-4ba599724202bcbfbf55d0d8b9de472939b2b41e.tar.bz2
sci-4ba599724202bcbfbf55d0d8b9de472939b2b41e.zip
Initial commit, upstream package move from sys-cluster/mpich2 and bump
Package-Manager: portage-2.1.12.2
-rw-r--r--sys-cluster/mpich/ChangeLog10
-rw-r--r--sys-cluster/mpich/Manifest1
-rw-r--r--sys-cluster/mpich/files/eselect.mpi.mpich8
-rw-r--r--sys-cluster/mpich/metadata.xml18
-rw-r--r--sys-cluster/mpich/mpich-3.0.4.ebuild122
5 files changed, 159 insertions, 0 deletions
diff --git a/sys-cluster/mpich/ChangeLog b/sys-cluster/mpich/ChangeLog
new file mode 100644
index 000000000..deb211c97
--- /dev/null
+++ b/sys-cluster/mpich/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-cluster/mpich
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*mpich-3.0.4 (09 Jul 2013)
+
+ 09 Jul 2013; Justin Bronder <jsbronder@gentoo.org> +mpich-3.0.4.ebuild,
+ +.mpich-3.0.4.ebuild.swp, +files/eselect.mpi.mpich, +metadata.xml:
+ Initial commit, upstream package move from sys-cluster/mpich2 and bump
+
diff --git a/sys-cluster/mpich/Manifest b/sys-cluster/mpich/Manifest
new file mode 100644
index 000000000..5c00dbd1d
--- /dev/null
+++ b/sys-cluster/mpich/Manifest
@@ -0,0 +1 @@
+DIST mpich-3.0.4.tar.gz 10921075 SHA256 cf638c85660300af48b6f776e5ecd35b5378d5905ec5d34c3da7a27da0acf0b3 SHA512 f9d8b2cf561fe5f85c12512ef4dd7b0cf5ec8b53ddb07bfa0d1db2e3c8ae0382c77e0661f46b82ec96b05d18ea2d25328bb84e9528ac06e5925f30ec8ef030d0 WHIRLPOOL 52c811d1adcba26424bb3f05b7b97faff16ab3762782474fcde5f49e9ca77155fb91d80967120d9277eed2adb116443afe444671eb6315a610587d55ac4ec9ed
diff --git a/sys-cluster/mpich/files/eselect.mpi.mpich b/sys-cluster/mpich/files/eselect.mpi.mpich
new file mode 100644
index 000000000..703d71176
--- /dev/null
+++ b/sys-cluster/mpich/files/eselect.mpi.mpich
@@ -0,0 +1,8 @@
+MPI_CC=@ROOT@usr/bin/mpicc
+MPI_CXX=@ROOT@usr/bin/mpicxx
+MPI_F77=@ROOT@usr/bin/mpif77
+MPI_FC=@ROOT@usr/bin/mpif90
+CLASS_BASE_MPI_IMP=@BASE_IMP@
+PATH=@ROOT@usr/bin
+MANPATH=@ROOT@usr/share/man
+LD_LIBRARY_PATH=@ROOT@usr/@LIBDIR@
diff --git a/sys-cluster/mpich/metadata.xml b/sys-cluster/mpich/metadata.xml
new file mode 100644
index 000000000..1738cc60e
--- /dev/null
+++ b/sys-cluster/mpich/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cluster</herd>
+ <maintainer>
+ <email>jsbronder@gentoo.org</email>
+ <name>Justin Bronder</name>
+ </maintainer>
+ <maintainer>
+ <email>balaji@mcs.anl.gov</email>
+ <name>Pavan Balaji</name>
+ <description>Upstream Contact</description>
+ </maintainer>
+ <use>
+ <flag name="mpi-threads">Enable MPI_THREAD_MULTIPLE</flag>
+ <flag name="romio">Build the ROMIO MPI-IO component</flag>
+ </use>
+</pkgmetadata>
diff --git a/sys-cluster/mpich/mpich-3.0.4.ebuild b/sys-cluster/mpich/mpich-3.0.4.ebuild
new file mode 100644
index 000000000..4c5ce942d
--- /dev/null
+++ b/sys-cluster/mpich/mpich-3.0.4.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+
+inherit fortran-2 mpi
+
+MY_PV=${PV/_/}
+DESCRIPTION="A high performance and portable MPI implementation"
+HOMEPAGE="http://www.mpich.org/"
+SRC_URI="http://www.mpich.org/static/downloads/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="mpich"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="+cxx doc fortran mpi-threads romio threads"
+
+COMMON_DEPEND="
+ dev-libs/libaio
+ sys-apps/hwloc
+ romio? ( net-fs/nfs-utils )
+ $(mpi_imp_deplist)"
+
+DEPEND="${COMMON_DEPEND}
+ dev-lang/perl
+ sys-devel/libtool"
+
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+pkg_setup() {
+ FORTRAN_STANDARD="77 90"
+ fortran-2_pkg_setup
+ MPI_ESELECT_FILE="eselect.mpi.mpich"
+
+ if use mpi-threads && ! use threads; then
+ ewarn "mpi-threads requires threads, assuming that's what you want"
+ fi
+}
+
+src_prepare() {
+ # Using MPICHLIB_LDFLAGS doesn't seem to fully work.
+ sed -i 's| *@WRAPPER_LDFLAGS@ *||' \
+ src/packaging/pkgconfig/mpich.pc.in \
+ src/env/*.in \
+ || die
+}
+
+src_configure() {
+ local c="--enable-shared"
+
+ # The configure statements can be somewhat confusing, as they
+ # don't all show up in the top level configure, however, they
+ # are picked up in the children directories.
+
+ if use mpi-threads; then
+ # MPI-THREAD requries threading.
+ c="${c} --with-thread-package=pthreads"
+ c="${c} --enable-threads=runtime"
+ else
+ if use threads ; then
+ c="${c} --with-thread-package=pthreads"
+ else
+ c="${c} --with-thread-package=none"
+ fi
+ c="${c} --enable-threads=single"
+ fi
+
+ if ! mpi_classed; then
+ c="${c} --sysconfdir=${EPREFIX}/etc/${PN}"
+ c="${c} --docdir=${EPREFIX}/usr/share/doc/${PF}"
+ else
+ c="${c} --docdir=$(mpi_root)/usr/share/doc/${PF}"
+ fi
+
+ export MPICHLIB_CFLAGS=${CFLAGS}
+ export MPICHLIB_CPPFLAGS=${CPPFLAGS}
+ export MPICHLIB_CXXFLAGS=${CXXFLAGS}
+ export MPICHLIB_FFLAGS=${FFLAGS}
+ export MPICHLIB_FCFLAGS=${FCFLAGS}
+ export MPICHLIB_LDFLAGS=${LDFLAGS}
+ unset CFLAGS CPPFLAGS CXXFLAGS FFLAGS FCFLAGS LDFLAGS
+
+ econf $(mpi_econf_args) ${c} \
+ --with-pm=hydra \
+ --disable-mpe \
+ --disable-fast \
+ --enable-smpcoll \
+ --enable-versioning \
+ --with-hwloc-prefix=/usr \
+ $(use_enable romio) \
+ $(use_enable cxx) \
+ $(use_enable fortran f77) \
+ $(use_enable fortran fc)
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ local d=$(echo ${ED}/$(mpi_root)/ | sed 's,///*,/,g')
+
+ default
+
+ mpi_dodir /usr/share/doc/${PF}
+ mpi_dodoc COPYRIGHT README{,.envvar} CHANGES RELEASE_NOTES
+ mpi_newdoc src/pm/hydra/README README.hydra
+ if use romio; then
+ mpi_newdoc src/mpi/romio/README README.romio
+ fi
+
+ if ! use doc; then
+ rm -rf "${d}"usr/share/doc/${PF}/www*
+ fi
+
+ mpi_imp_add_eselect
+}