aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2019-12-01 11:57:31 +0800
committerBenda Xu <heroxbd@gentoo.org>2019-12-01 12:35:26 +0800
commit4be0e2ffbed7ec50f59a29b1fb0c17626a59a497 (patch)
treea8605d048673bcb4896aa2e96f27348dea6c4efc
parentdev-libs/optix: initial commit of 6.0.0. (diff)
downloadsci-4be0e2ffbed7ec50f59a29b1fb0c17626a59a497.tar.gz
sci-4be0e2ffbed7ec50f59a29b1fb0c17626a59a497.tar.bz2
sci-4be0e2ffbed7ec50f59a29b1fb0c17626a59a497.zip
media-libs/DualContouringSample: initial commit of 0_p20191111
This is included as a dependency of sci-physics/opticks. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--media-libs/DualContouringSample/DualContouringSample-0_p20191111.ebuild28
-rw-r--r--media-libs/DualContouringSample/files/DualContouringSample-0_glm.patch33
-rw-r--r--media-libs/DualContouringSample/metadata.xml7
3 files changed, 68 insertions, 0 deletions
diff --git a/media-libs/DualContouringSample/DualContouringSample-0_p20191111.ebuild b/media-libs/DualContouringSample/DualContouringSample-0_p20191111.ebuild
new file mode 100644
index 000000000..4caa506bb
--- /dev/null
+++ b/media-libs/DualContouringSample/DualContouringSample-0_p20191111.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="A sample Dual Contouring implementation"
+HOMEPAGE="https://github.com/simoncblyth/DualContouringSample"
+
+EGIT_REPO_URI="https://github.com/simoncblyth/${PN}.git"
+EGIT_COMMIT="d5ed08c21228575f948292422cd8542cbdce255c"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-util/bcm"
+
+PATCHES=( "${FILESDIR}"/DualContouringSample-0_glm.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_INCLUDEDIR=include/${PN}
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/media-libs/DualContouringSample/files/DualContouringSample-0_glm.patch b/media-libs/DualContouringSample/files/DualContouringSample-0_glm.patch
new file mode 100644
index 000000000..efa40b66e
--- /dev/null
+++ b/media-libs/DualContouringSample/files/DualContouringSample-0_glm.patch
@@ -0,0 +1,33 @@
+Index: DualContouringSample-0_p20191111/CMakeLists.txt
+===================================================================
+--- DualContouringSample-0_p20191111.orig/CMakeLists.txt
++++ DualContouringSample-0_p20191111/CMakeLists.txt
+@@ -3,18 +3,11 @@ set(name DualContouringSample)
+ project(${name} VERSION 0.1.0)
+
+ include(CTest)
+-include(OpticksBuildOptions)
+-
+-include(GNUInstallDirs)
+-set(CMAKE_INSTALL_INCLUDEDIR "externals/include/${name}")
+-set(CMAKE_INSTALL_LIBDIR "externals/lib")
+-set(CMAKE_INSTALL_BINDIR "lib")
+-#set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_FULL_LIBDIR}")
+
+ find_package(BCM REQUIRED)
+ include(BCMDeploy)
+
+-find_package(GLM REQUIRED)
++find_package(glm REQUIRED)
+
+
+ set(SOURCES
+@@ -37,7 +30,7 @@ set(HEADERS
+ )
+
+ add_library(${name} SHARED ${SOURCES})
+-target_link_libraries(${name} PUBLIC Opticks::GLM)
++target_link_libraries(${name} PUBLIC glm)
+
+ # needed for tests that use non-installed headers
+ target_include_directories(${name} PUBLIC
diff --git a/media-libs/DualContouringSample/metadata.xml b/media-libs/DualContouringSample/metadata.xml
new file mode 100644
index 000000000..7203fb853
--- /dev/null
+++ b/media-libs/DualContouringSample/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>heroxbd@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>