aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2012-03-23 09:01:38 +0100
committerHonza Macháček <Hloupy.Honza@centrum.cz>2012-03-23 09:01:38 +0100
commit4d9e279ca65ca4c7b9cef50b676329e5d5e0a5a9 (patch)
treefffa2deb34e3cef9c42729f509bfb72389dd9fbe
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci; github.c... (diff)
downloadsci-4d9e279ca65ca4c7b9cef50b676329e5d5e0a5a9.tar.gz
sci-4d9e279ca65ca4c7b9cef50b676329e5d5e0a5a9.tar.bz2
sci-4d9e279ca65ca4c7b9cef50b676329e5d5e0a5a9.zip
sci-physics/abinit metadata updated (libabinit USE flag), sci-physics/abinit-6.12.1 fortran setup improved
-rw-r--r--sci-physics/abinit/ChangeLog4
-rw-r--r--sci-physics/abinit/abinit-6.12.1.ebuild20
-rw-r--r--sci-physics/abinit/metadata.xml6
3 files changed, 22 insertions, 8 deletions
diff --git a/sci-physics/abinit/ChangeLog b/sci-physics/abinit/ChangeLog
index 2a5c1ee69..7255b062d 100644
--- a/sci-physics/abinit/ChangeLog
+++ b/sci-physics/abinit/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 23 Mar 2012; Honza Macháček <Hloupy.Honza@centrum.cz> abinit-6.12.1.ebuild,
+ metadata.xml:
+ Metadata updated, fortran setup in 6.12.1 ebuild improved.
+
*abinit-6.12.1 (22 Mar 2012)
22 Mar 2012; Honza Macháček <Hloupy.Honza@centrum.cz>
diff --git a/sci-physics/abinit/abinit-6.12.1.ebuild b/sci-physics/abinit/abinit-6.12.1.ebuild
index 00e1fa2fb..653a6ec03 100644
--- a/sci-physics/abinit/abinit-6.12.1.ebuild
+++ b/sci-physics/abinit/abinit-6.12.1.ebuild
@@ -56,6 +56,14 @@ DOCS=( AUTHORS ChangeLog COPYING INSTALL KNOWN_PROBLEMS NEWS PACKAGING
FORTRAN_STANDARD=90
pkg_setup() {
+ # Doesn't compile with gcc-4.0, only >=4.1
+ if [[ $(tc-getFC) == *gfortran ]]; then
+ if [[ $(gcc-major-version) -eq 4 ]] \
+ && [[ $(gcc-minor-version) -lt 1 ]]; then
+ die "Requires gcc-4.1 or newer"
+ fi
+ fi
+
# fortran-2.eclass does not handle mpi wrappers
if use mpi; then
export FC="mpif90"
@@ -65,15 +73,11 @@ pkg_setup() {
else
tc-export FC F77 CC CXX
fi
- fortran-2_pkg_setup
- # Doesn't compile with gcc-4.0, only >=4.1
- if [[ $(tc-getFC) == *gfortran ]]; then
- if [[ $(gcc-major-version) -eq 4 ]] \
- && [[ $(gcc-minor-version) -lt 1 ]]; then
- die "Requires gcc-4.1 or newer"
- fi
- fi
+ # Preprocesor macross can make some lines really long
+ append-fflags -ffree-line-length-none
+
+ fortran-2_pkg_setup
# Sort out some USE options
if use fftw-threads && ! use fftw; then
diff --git a/sci-physics/abinit/metadata.xml b/sci-physics/abinit/metadata.xml
index 0a34647b9..7ff0b568e 100644
--- a/sci-physics/abinit/metadata.xml
+++ b/sci-physics/abinit/metadata.xml
@@ -31,6 +31,12 @@ ABINIT is a package whose main program allows one to find the total energy, char
</flag>
</use>
<use>
+ <flag name="libabinit">
+ Build the libabinit used by sci-libs/bigdft
+ (usage not tested yet, circular dependency not resolved)
+ </flag>
+</use>
+<use>
<flag name="vdwxc">
Activate van der Waals exchange-correlation
</flag>