aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-04 12:17:30 +0100
committerHorea Christian <chr@chymera.eu>2021-01-05 02:38:31 -0500
commit4de1a2e8ea2a0891b199ee4a7ae3368b37cb9ac8 (patch)
treeeffdbfb9d744bf85293487148ce562624b216585
parentReadme.md: typo (diff)
downloadsci-4de1a2e8ea2a0891b199ee4a7ae3368b37cb9ac8.tar.gz
sci-4de1a2e8ea2a0891b199ee4a7ae3368b37cb9ac8.tar.bz2
sci-4de1a2e8ea2a0891b199ee4a7ae3368b37cb9ac8.zip
dev-python/pytest-doctestplus: new dep
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--dev-python/pytest-doctestplus/Manifest1
-rw-r--r--dev-python/pytest-doctestplus/metadata.xml8
-rw-r--r--dev-python/pytest-doctestplus/pytest-doctestplus-0.8.0.ebuild23
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-doctestplus/Manifest b/dev-python/pytest-doctestplus/Manifest
new file mode 100644
index 000000000..4f66e9882
--- /dev/null
+++ b/dev-python/pytest-doctestplus/Manifest
@@ -0,0 +1 @@
+DIST pytest-doctestplus-0.8.0.tar.gz 27489 BLAKE2B 1377eeadc1c0558c0f0f497aec775f04fc111b7815468c87a48e1abedbb66f648128b10ba050a798232cc63cba1c79e794c4653e51f8ee5a27029a6ed10fb5a6 SHA512 108f6bf2d5d663bfc9c6c50e63633814baf248062b6e2d83ca6e83d1d8db9940251ebbb60cd57b04e8ede20b9511f4c86e4ac618618cb42ccaa68c6c38989f2e
diff --git a/dev-python/pytest-doctestplus/metadata.xml b/dev-python/pytest-doctestplus/metadata.xml
new file mode 100644
index 000000000..4f4367037
--- /dev/null
+++ b/dev-python/pytest-doctestplus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pytest-doctestplus/pytest-doctestplus-0.8.0.ebuild b/dev-python/pytest-doctestplus/pytest-doctestplus-0.8.0.ebuild
new file mode 100644
index 000000000..05b962262
--- /dev/null
+++ b/dev-python/pytest-doctestplus/pytest-doctestplus-0.8.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin with advanced doctest features"
+HOMEPAGE="https://astropy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# TODO: fix this
+RESTRICT="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest