aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Horel <guillaume.horel@gmail.com>2013-04-01 21:34:56 -0400
committerGuillaume Horel <guillaume.horel@gmail.com>2013-04-01 21:34:56 -0400
commit500c722f1fd50cea00f491d23346744131ff7a06 (patch)
treef9f2f93a273bbb84eeb2286b8a5c0c991347c150
parentdev-libs/double-conversion version bump (diff)
downloadsci-500c722f1fd50cea00f491d23346744131ff7a06.tar.gz
sci-500c722f1fd50cea00f491d23346744131ff7a06.tar.bz2
sci-500c722f1fd50cea00f491d23346744131ff7a06.zip
dev-lang/julia update dependency and remove useflag
-rw-r--r--dev-lang/julia/files/julia-nopatchelf.patch14
-rw-r--r--dev-lang/julia/julia-9999.ebuild28
-rw-r--r--dev-lang/julia/metadata.xml8
3 files changed, 25 insertions, 25 deletions
diff --git a/dev-lang/julia/files/julia-nopatchelf.patch b/dev-lang/julia/files/julia-nopatchelf.patch
new file mode 100644
index 000000000..2ac5a80d4
--- /dev/null
+++ b/dev-lang/julia/files/julia-nopatchelf.patch
@@ -0,0 +1,14 @@
+diff -urN julia-9999-orig/deps/Makefile julia-9999/deps/Makefile
+--- julia-9999-orig/deps/Makefile 2013-04-01 19:43:13.868529747 -0400
++++ julia-9999/deps/Makefile 2013-04-01 19:45:35.261543816 -0400
+@@ -37,10 +37,6 @@
+ endif
+ endif
+
+-ifeq ($(OS), Linux)
+-STAGE1_DEPS += patchelf
+-endif
+-
+ WGET = $(abspath .)/jldownload
+ WGET_DASH_O = $(WGET)
+
diff --git a/dev-lang/julia/julia-9999.ebuild b/dev-lang/julia/julia-9999.ebuild
index c6f774e60..c0668705b 100644
--- a/dev-lang/julia/julia-9999.ebuild
+++ b/dev-lang/julia/julia-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
EGIT_REPO_URI="git://github.com/JuliaLang/julia.git"
@@ -15,7 +15,7 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc emacs notebook"
+IUSE="doc emacs"
RDEPEND=">=sys-devel/llvm-3.0
sys-libs/readline
@@ -24,18 +24,19 @@ RDEPEND=">=sys-devel/llvm-3.0
sci-libs/arpack
sci-libs/fftw
dev-libs/gmp
+ >=dev-libs/double-conversion-1.1.1
>=sys-libs/libunwind-1.1
dev-libs/libpcre
sci-mathematics/glpk
sys-libs/zlib
virtual/blas
- virtual/lapack
- notebook? ( www-servers/lighttpd )"
+ virtual/lapack"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
+ epatch "${FILESDIR}/julia-nopatchelf.patch"
# Folder /usr/include/suitesparse does not exists, everything should be in /usr/include
sed -e "s|SUITESPARSE_INC = -I /usr/include/suitesparse|SUITESPARSE_INC = |g" \
-i deps/Makefile
@@ -57,32 +58,23 @@ src_prepare() {
}
src_compile() {
- emake -j1
+ emake
use doc && emake -C doc html
- if use notebook; then
- emake -C ui/webserver
- sed -e "s|etc|/share/julia/etc|" \
- -i usr/bin/launch-julia-webserver ||die
- fi
use emacs && elisp-compile contrib/julia-mode.el
}
src_install() {
- emake -j1 install PREFIX="${D}/usr"
+ emake install PREFIX="${D}/usr"
cat > 99julia <<-EOF
LDPATH=/usr/$(get_libdir)/julia
EOF
doenvd 99julia
- if use notebook; then
- cp -R ui/website "${D}/usr/share/julia"
- insinto /usr/share/julia/etc
- doins deps/lighttpd.conf
- fi
+
if use emacs; then
elisp-install "${PN}" contrib/julia-mode.el
elisp-site-file-install "${FILESDIR}"/63julia-gentoo.el
fi
- use doc && dodoc -r doc/_build/html
+ use doc && dohtml -r doc/_build/html/
dodoc README.md
}
diff --git a/dev-lang/julia/metadata.xml b/dev-lang/julia/metadata.xml
index 03a860095..afa3d5374 100644
--- a/dev-lang/julia/metadata.xml
+++ b/dev-lang/julia/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>guillaume.horel@gmail.com</email>
- <name>Guillaume Horel</name>
- </maintainer>
+ <herd>python</herd>
<longdescription>
Julia is a high-level, high-performance dynamic programming language for
technical computing, with syntax that is familiar to users of other
@@ -17,7 +14,4 @@
around defining functions, and overloading them for different combinations
of argument types (which can also be user-defined).
</longdescription>
-<use>
- <flag name="notebook">Install requirements for the web notebook based on <pkg>www-servers/lighttpd</pkg></flag>
-</use>
</pkgmetadata>