aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-10 16:31:20 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-10 16:31:20 +0100
commit543568f48aaecad938c119b47aef062a61422a6b (patch)
treea5b43f1ed93aaf26c4dd4d51f2719e9a653b43c9
parentMerge pull request #563 from apieum/fix-dgs-texinfo (diff)
parentSave the downloaded tarball as ${P}.tar.gz (diff)
downloadsci-543568f48aaecad938c119b47aef062a61422a6b.tar.gz
sci-543568f48aaecad938c119b47aef062a61422a6b.tar.bz2
sci-543568f48aaecad938c119b47aef062a61422a6b.zip
Merge pull request #558 from chatcannon/nexus-4.4.1
Nexus 4.4.1
-rw-r--r--sci-libs/nexus/Manifest2
-rw-r--r--sci-libs/nexus/metadata.xml12
-rw-r--r--sci-libs/nexus/nexus-4.3.1.ebuild57
-rw-r--r--sci-libs/nexus/nexus-4.4.1.ebuild57
4 files changed, 63 insertions, 65 deletions
diff --git a/sci-libs/nexus/Manifest b/sci-libs/nexus/Manifest
index 47ec4c670..ae75bd58b 100644
--- a/sci-libs/nexus/Manifest
+++ b/sci-libs/nexus/Manifest
@@ -1 +1 @@
-DIST nexus-4.3.1.tar.gz 16734478 SHA256 da186e0978321e793800cd45611fc767d46cf5d7d2c8f60277b3f48b4a84cb0b SHA512 f470d4bc1e7f3d714b4849798a9d509b8d23da486a25d4998d023fea1f148030ab86b88ac088ad71847db6692479e1ca2fad48d2c4dad016f9652e19c08f5a0b WHIRLPOOL effa806f7372ef974412aa974bdf4b84cfc7632ecb3153638bc9e948b80eb87130c0a4df9b6d010d36b3c0d7d8bdbde17e58d17de8ec298a161ebcfa2dc4b045
+DIST nexus-4.4.1.tar.gz 4820168 SHA256 5674ff3ac5573e80a33963804975ae1dadf55a95bcee818f23f485569d72bf1b SHA512 f561e5dcb48d6bb5d8acbfecae0e447fe7ca5c82ef85d03d3a9874a2f31e47769ac4229579a31321e2462160f39f6a1f1af28e7d05d5ff9985b1c4281cf053d1 WHIRLPOOL e86d2407eac3ca65274e9e622d3859321550966077b378f918eaafd9a37f68e0958f2b25329f07b8a93fd535613cbe2a9b5ef0d4a7a003acbc199ae9acf99915
diff --git a/sci-libs/nexus/metadata.xml b/sci-libs/nexus/metadata.xml
index 2c83b9196..bbec0bdc3 100644
--- a/sci-libs/nexus/metadata.xml
+++ b/sci-libs/nexus/metadata.xml
@@ -3,9 +3,9 @@
<pkgmetadata>
<herd>sci</herd>
<maintainer>
- <email>cjk34@cam.ac.uk</email>
+ <email>c.kerr@embl-hamburg.de</email>
<name>Chris Kerr</name>
- <description>I don't develop this software, I'm just a Gentoo user who wanted to install it</description>
+ <description>I occasionally submit patches to NeXus</description>
</maintainer>
<longdescription>Libraries and tools for the NeXus data format, developed
collaboratively by scientists from major scientific facilities to facilitate
@@ -13,13 +13,11 @@
NeXus is based on HDF5.</longdescription>
<use>
<flag name="xml">Allow using the verbose XML representation of NeXus data</flag>
+ <flag name="hdf4">Support the old HDF4 representation</flag>
+ <flag name="hdf5">Support the standard representation (HDF5)</flag>
<flag name="doc">Generate library documentation with <pkg>app-doc/doxygen</pkg></flag>
- <flag name="swig">Generate bindings with <pkg>dev-lang/swig</pkg></flag>
- <flag name="cbf">Support for Crystallographic Binary Format files with sci-libs/cbflib</flag>
<flag name="fortran">Build the Fortran bindings</flag>
- <flag name="guile">Build the Scheme bindings</flag>
- <flag name="tcl">Build the TCL bindings</flag>
<flag name="java">Build the Java bindings</flag>
- <flag name="python">Build the Python bindings</flag>
+ <flag name="utils">Build optional utility applications</flag>
</use>
</pkgmetadata>
diff --git a/sci-libs/nexus/nexus-4.3.1.ebuild b/sci-libs/nexus/nexus-4.3.1.ebuild
deleted file mode 100644
index 6111a06d6..000000000
--- a/sci-libs/nexus/nexus-4.3.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-FORTRAN_NEEDED=fortran
-FORTRAN_STANDARD=90
-PYTHON_COMPAT=( python2_7 )
-inherit fortran-2 flag-o-matic python-single-r1
-
-DESCRIPTION="Data format for neutron and x-ray scattering data"
-HOMEPAGE="http://nexusformat.org/"
-SRC_URI="http://download.nexusformat.org/kits/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="cbf doc fortran guile java python swig tcl xml"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- sci-libs/hdf5
- python? ( ${PYTHON_DEPS} )
- xml? ( dev-libs/mxml )
- cbf? ( sci-libs/cbflib )
- guile? ( dev-scheme/guile:12 )
-" # N.B. the website says it depends on HDF4 too, but I find it builds fine without it
-
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen dev-tex/xcolor )
- swig? ( dev-lang/swig:0 )
-"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- # Handling of dependencies between Fortran module files doesn't play well with parallel make
- use fortran && export MAKEOPTS="${MAKEOPTS} -j1 "
- use fortran && fortran-2_pkg_setup
-}
-
-src_configure() {
- # Linking between Fortran libraries gives a relocation error, using workaround suggested at:
- # http://www.gentoo.org/proj/en/base/amd64/howtos/?part=1&chap=3
- use fortran && append-fflags -fPIC
-
- econf \
- $(use_with doc doxygen) \
- $(use_with fortran f90) \
- $(use_with swig) \
- $(use_with xml) \
- $(use_with cbf cbflib) \
- $(use_with guile) \
- $(use_with java) \
- $(use_with python)
-}
diff --git a/sci-libs/nexus/nexus-4.4.1.ebuild b/sci-libs/nexus/nexus-4.4.1.ebuild
new file mode 100644
index 000000000..b113f9e82
--- /dev/null
+++ b/sci-libs/nexus/nexus-4.4.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD="77 90"
+inherit cmake-utils fortran-2 java-pkg-opt-2
+
+DESCRIPTION="Data format for neutron and x-ray scattering data"
+HOMEPAGE="http://nexusformat.org/"
+SRC_URI="https://github.com/nexusformat/code/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc cxx fortran -hdf4 +hdf5 java utils xml"
+
+REQUIRED_USE=" || ( hdf4 hdf5 xml ) "
+
+RDEPEND="
+ xml? ( dev-libs/mxml )
+ hdf4? ( sci-libs/hdf )
+ hdf5? ( sci-libs/hdf5[zlib] )
+ utils? ( sys-libs/readline:0 sys-libs/libtermcap-compat dev-libs/libxml2 )
+"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen dev-tex/xcolor )
+"
+
+S="${WORKDIR}/code-${PV}"
+
+pkg_setup() {
+ # Handling of dependencies between Fortran module files doesn't play well with parallel make
+ use fortran && export MAKEOPTS="${MAKEOPTS} -j1 "
+ use fortran && fortran-2_pkg_setup
+ java-pkg-opt-2_pkg_setup
+}
+
+src_configure() {
+ # Linking between Fortran libraries gives a relocation error, using workaround suggested at:
+ # http://www.gentoo.org/proj/en/base/amd64/howtos/?part=1&chap=3
+ use fortran && append-fflags -fPIC
+
+ cmake-utils_src_configure \
+ $(cmake-utils_use_enable hdf4) \
+ $(cmake-utils_use_enable hdf5) \
+ $(cmake-utils_use_enable xml MXML) \
+ $(cmake-utils_use_enable cxx) \
+ $(cmake-utils_use_enable fortran FORTRAN90) \
+ $(cmake-utils_use_enable fortran FORTRAN77) \
+ $(cmake-utils_use_enable java) \
+ $(cmake-utils_use_enable utils APPS) \
+ $(cmake-utils_use_enable utils CONTRIB)
+}