aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyang Wu <xgreenlandforwyy@gmail.com>2023-03-20 15:39:16 +0800
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-03-28 18:40:48 +0200
commit551b3d503ecacb6620b987019cfd7bb0718d5067 (patch)
treee8d1847468884dff5f0aaa0c31a1efbaa7554229
parentsci-libs/vtk: new package, 9.1.0-r6 (diff)
downloadsci-551b3d503ecacb6620b987019cfd7bb0718d5067.tar.gz
sci-551b3d503ecacb6620b987019cfd7bb0718d5067.tar.bz2
sci-551b3d503ecacb6620b987019cfd7bb0718d5067.zip
dev-cpp/xsimd: new package, add 10.0.0
Tests passed on amd64 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-cpp/xsimd/Manifest1
-rw-r--r--dev-cpp/xsimd/files/remove-libdir-in-pc.patch12
-rw-r--r--dev-cpp/xsimd/metadata.xml11
-rw-r--r--dev-cpp/xsimd/xsimd-10.0.0.ebuild27
4 files changed, 51 insertions, 0 deletions
diff --git a/dev-cpp/xsimd/Manifest b/dev-cpp/xsimd/Manifest
new file mode 100644
index 000000000..1411b4acf
--- /dev/null
+++ b/dev-cpp/xsimd/Manifest
@@ -0,0 +1 @@
+DIST xsimd-10.0.0.tar.gz 212082 BLAKE2B 2a3c6dd711f9e7ffd32ce3fd9a6056a56768a0f5b6ff412d2c5cd5f82682cac87ed0a68109a449ab6337f89a4719e9ab25f94060d3f675783ce00c79e3378512 SHA512 bd7a363bbebc9196954c8c87271f14f05ca177569fcf080dac91be06ad2801c43fccbb385afd700b80d58c83d77f26ba199a7105672e4a1e55c517d15dd6e8e3
diff --git a/dev-cpp/xsimd/files/remove-libdir-in-pc.patch b/dev-cpp/xsimd/files/remove-libdir-in-pc.patch
new file mode 100644
index 000000000..4548f0ab4
--- /dev/null
+++ b/dev-cpp/xsimd/files/remove-libdir-in-pc.patch
@@ -0,0 +1,12 @@
+libdir is not used in this header-only package
+And this line cause QA notice:
+key=libdir does not respect EPREFIX libdir=/lib64
+===================================================================
+--- xsimd-10.0.0.orig/xsimd.pc.in
++++ xsimd-10.0.0/xsimd.pc.in
+@@ -1,5 +1,4 @@
+ prefix=@CMAKE_INSTALL_PREFIX@
+-libdir=@libdir_for_pc_file@
+ includedir=@includedir_for_pc_file@
+
+ Name: xsimd
diff --git a/dev-cpp/xsimd/metadata.xml b/dev-cpp/xsimd/metadata.xml
new file mode 100644
index 000000000..7e8334e1b
--- /dev/null
+++ b/dev-cpp/xsimd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgreenlandforwyy@gmail.com</email>
+ <name>Yiyang Wu</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">xtensor-stack/xsimd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/xsimd/xsimd-10.0.0.ebuild b/dev-cpp/xsimd/xsimd-10.0.0.ebuild
new file mode 100644
index 000000000..1a34b725b
--- /dev/null
+++ b/dev-cpp/xsimd/xsimd-10.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ wrappers for SIMD intrinsics and math implementations"
+HOMEPAGE="https://github.com/xtensor-stack/xsimd"
+SRC_URI="https://github.com/xtensor-stack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/doctest )"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=( "${FILESDIR}"/remove-libdir-in-pc.patch )
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_TESTS="$(usex test ON OFF)" )
+ cmake_src_configure
+}