aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-08-29 18:47:45 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-08-29 18:49:02 +0800
commit567964848893e5eff970c5c319c4de183c534d9a (patch)
treee1ba6388240156fecd6fbab28dcad234c233bfb4
parentsci-libs/awkward-array: bump to 0.13.0. (diff)
downloadsci-567964848893e5eff970c5c319c4de183c534d9a.tar.gz
sci-567964848893e5eff970c5c319c4de183c534d9a.tar.bz2
sci-567964848893e5eff970c5c319c4de183c534d9a.zip
sci-physics/uproot-methods: bump to 0.7.4.
Add python 3.7 and 3.8 targets. Package-Manager: Portage-2.3.88, Repoman-2.3.18 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--sci-physics/uproot-methods/Manifest1
-rw-r--r--sci-physics/uproot-methods/uproot-methods-0.7.4.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/sci-physics/uproot-methods/Manifest b/sci-physics/uproot-methods/Manifest
index e9946ccd0..b261c1ced 100644
--- a/sci-physics/uproot-methods/Manifest
+++ b/sci-physics/uproot-methods/Manifest
@@ -1 +1,2 @@
DIST uproot-methods-0.7.2.tar.gz 25121 BLAKE2B 3e7af6001769e0b72ba8e29db169e7a62d54c64b737dd6bccdbb52747acef753af0398846056b5858557f506242786194bcfe442fb01e07e485b42cf6f3f434b SHA512 ce1662890ac5795ad090543c11e5525f2b94f7551cdaf5de25bdb085992c0b330d60d0e77c11f4b7f823a79784f4fad7f843e3bf665ee8376dc0362dd4314000
+DIST uproot-methods-0.7.4.tar.gz 25560 BLAKE2B 89754a482e523a70b0ce9563afa8b057271ea0a3adca93205ae313c94abfb2676cdd61e9b011c96e7663be6ee1303341a18e7ce0295718ee6b58edc9bc69cb57 SHA512 d7c494170cf8dd3d0da293b5e7bd97047b9465e9d3589c5de94ad22561663ca0199b219b8087d06fbf1675de7cd3f8e3fe9aa89f27deef096e3bd02d7c3ccd77
diff --git a/sci-physics/uproot-methods/uproot-methods-0.7.4.ebuild b/sci-physics/uproot-methods/uproot-methods-0.7.4.ebuild
new file mode 100644
index 000000000..f1e393642
--- /dev/null
+++ b/sci-physics/uproot-methods/uproot-methods-0.7.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Manipulate arrays of complex data structures as easily as Numpy."
+HOMEPAGE="https://github.com/scikit-hep/${PN}"
+SRC_URI="https://github.com/scikit-hep/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/awkward-array[${PYTHON_USEDEP}]"
+DEPEND=""