aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-13 08:32:58 +0200
committerJustin Lecher <jlec@gentoo.org>2013-06-13 08:32:58 +0200
commit574ac2e9dffc4cbcac9a478d5034c14151a5bd8c (patch)
treeae207476de7f3faf56b97dc9aaa54e1fb9366437
parentsci-libs/blastdb: Add missing build dep; fix license (diff)
downloadsci-574ac2e9dffc4cbcac9a478d5034c14151a5bd8c.tar.gz
sci-574ac2e9dffc4cbcac9a478d5034c14151a5bd8c.tar.bz2
sci-574ac2e9dffc4cbcac9a478d5034c14151a5bd8c.zip
dev-python/inference: Bump to EAPI=5 and distutils-r1.eclass; make license more restrictive as we cannot check it right now
Package-Manager: portage-2.2.0_alpha179
-rw-r--r--dev-python/inference/ChangeLog7
-rw-r--r--dev-python/inference/inference-0.4.ebuild31
-rw-r--r--dev-python/inference/metadata.xml4
3 files changed, 24 insertions, 18 deletions
diff --git a/dev-python/inference/ChangeLog b/dev-python/inference/ChangeLog
index e8bfcafec..bf5440d46 100644
--- a/dev-python/inference/ChangeLog
+++ b/dev-python/inference/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for dev-python/inference
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 13 Jun 2013; Justin Lecher <jlec@gentoo.org> inference-0.4.ebuild,
+ metadata.xml:
+ Bump to EAPI=5 and distutils-r1.eclass; make license more restrictive as we
+ cannot check it right now
+
25 Oct 2012; Justin Lecher <jlec@gentoo.org> inference-0.4.ebuild,
metadata.xml:
Move to EAPI=5; correct usage of fortran-2.eclass
diff --git a/dev-python/inference/inference-0.4.ebuild b/dev-python/inference/inference-0.4.ebuild
index bb508aa2e..4b41fa3cb 100644
--- a/dev-python/inference/inference-0.4.ebuild
+++ b/dev-python/inference/inference-0.4.ebuild
@@ -1,28 +1,25 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="nosetests"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit distutils flag-o-matic fortran-2 toolchain-funcs
+inherit distutils-r1 flag-o-matic fortran-2
DESCRIPTION="Collection of Python modules for statistical inference"
HOMEPAGE="http://inference.astro.cornell.edu/"
SRC_URI="${HOMEPAGE}/${P}.tar.gz"
SLOT="0"
-LICENSE="as-is"
+LICENSE="all-rights-reserved"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="sci-libs/scipy"
+DEPEND="sci-libs/scipy[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
- dev-python/matplotlib"
+ dev-python/matplotlib[${PYTHON_USEDEP}]"
# buggy tests
RESTRICT="test"
@@ -31,18 +28,22 @@ pkg_setup() {
fortran-2_pkg_setup
}
-src_prepare() {
+python_prepare_all() {
# The usual numpy.distutils hacks when fortran is used
append-ldflags -shared
append-fflags -fPIC
export NUMPY_FCONFIG="config_fc --noopt --noarch"
- distutils_src_prepare
+ distutils-r1_python_prepare_all
}
-src_compile() {
- distutils_src_compile ${NUMPY_CONFIG}
+python_compile() {
+ distutils-r1_python_compile ${NUMPY_CONFIG}
}
-src_install() {
- distutils_src_install ${NUMPY_FCONFIG}
+python_test() {
+ nosetests --verbose --verbosity=3
+}
+
+python_install() {
+ distutils-r1_python_install ${NUMPY_FCONFIG}
}
diff --git a/dev-python/inference/metadata.xml b/dev-python/inference/metadata.xml
index b6797a704..2c89b5d1e 100644
--- a/dev-python/inference/metadata.xml
+++ b/dev-python/inference/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
The inference package is a collection of Python modules implementing
a variety of methods targeting the statistical inference
problems—and the statistical modeling style—of the physical