aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-15 15:23:53 +0200
committerJustin Lecher <jlec@gentoo.org>2013-10-15 19:17:08 +0200
commit5acd8437fd8fe9a6e01d4c8b1cb1434d04c4790d (patch)
tree7fa9eb1b6c46cde4cda16420d0db56042a97739a
parentsci-geosciences/qgis: Import tree changes (diff)
downloadsci-5acd8437fd8fe9a6e01d4c8b1cb1434d04c4790d.tar.gz
sci-5acd8437fd8fe9a6e01d4c8b1cb1434d04c4790d.tar.bz2
sci-5acd8437fd8fe9a6e01d4c8b1cb1434d04c4790d.zip
dev-python/omniorbpy: Add missing PYTHON_DEPS and PYTHON_REQUIRED_USE
Package-Manager: portage-2.2.7
-rw-r--r--dev-python/omniorbpy/ChangeLog3
-rw-r--r--dev-python/omniorbpy/omniorbpy-3.4.ebuild6
2 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/omniorbpy/ChangeLog b/dev-python/omniorbpy/ChangeLog
index 1b9bddbae..1961eecc3 100644
--- a/dev-python/omniorbpy/ChangeLog
+++ b/dev-python/omniorbpy/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 15 Oct 2013; Justin Lecher <jlec@gentoo.org> omniorbpy-3.4.ebuild:
+ Add missing PYTHON_DEPS and PYTHON_REQUIRED_USE
+
14 Jun 2013; Justin Lecher <jlec@gentoo.org> omniorbpy-3.4.ebuild,
metadata.xml:
Bump to EAPI=5 and distutils-r1.eclass
diff --git a/dev-python/omniorbpy/omniorbpy-3.4.ebuild b/dev-python/omniorbpy/omniorbpy-3.4.ebuild
index c265e39cb..53f58297a 100644
--- a/dev-python/omniorbpy/omniorbpy-3.4.ebuild
+++ b/dev-python/omniorbpy/omniorbpy-3.4.ebuild
@@ -19,7 +19,9 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="ssl"
-DEPEND="
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
>=net-misc/omniORB-4.1.3
ssl? ( dev-libs/openssl )"
RDEPEND=${DEPEND}
@@ -61,5 +63,5 @@ src_install() {
dodoc doc/tex/*
insinto /usr/share/doc/${PF}/
- doins -r examples || die
+ doins -r examples
}