aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-22 13:30:44 -0400
committerAisha Tammy <gentoo@aisha.cc>2020-09-22 13:30:44 -0400
commit5d89187b8279ff9ab7849aab2a84661be8eb6269 (patch)
tree37176eb5a93950ba4da5ced77f9d3dfe477d8420
parentdev-python/pynomo: drop dead package (diff)
downloadsci-5d89187b8279ff9ab7849aab2a84661be8eb6269.tar.gz
sci-5d89187b8279ff9ab7849aab2a84661be8eb6269.tar.bz2
sci-5d89187b8279ff9ab7849aab2a84661be8eb6269.zip
dev-python/python-gantt: drop python2
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--dev-python/python-gantt/python-gantt-0.6.0.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/dev-python/python-gantt/python-gantt-0.6.0.ebuild b/dev-python/python-gantt/python-gantt-0.6.0.ebuild
index 47b93c751..2c8347c49 100644
--- a/dev-python/python-gantt/python-gantt-0.6.0.ebuild
+++ b/dev-python/python-gantt/python-gantt-0.6.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+PYTHON_COMPAT=( python3_{6..8} )
inherit distutils-r1
@@ -13,17 +13,14 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- "
RDEPEND="
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/svgwrite[${PYTHON_USEDEP}]
- "
+"
+
+distutils_enable_tests nose
python_test() {
- nosetests -v || die "Tests fail with ${EPYTHON}"
+ nosetests -v || die "nose tests fail with ${EPYTHON}"
}