aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-04 06:23:24 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-04 06:23:24 +0100
commit67b756ceafdc4378861efdbf82f83844a31ccf20 (patch)
treec87ccbb0b42eae601b23a56e004995126b45e17b
parentsci-biology/sailfish: fix configure phase (diff)
downloadsci-67b756ceafdc4378861efdbf82f83844a31ccf20.tar.gz
sci-67b756ceafdc4378861efdbf82f83844a31ccf20.tar.bz2
sci-67b756ceafdc4378861efdbf82f83844a31ccf20.zip
sci-biology/sambamba: version bump, EAPI bump
does not compile, seems to require some other compiler that is not packaged in ::gentoo at the moment Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-biology/sambamba/Manifest3
-rw-r--r--sci-biology/sambamba/sambamba-0.6.5.ebuild27
-rw-r--r--sci-biology/sambamba/sambamba-0.8.0.ebuild36
-rw-r--r--sci-biology/sambamba/sambamba-9999.ebuild10
4 files changed, 43 insertions, 33 deletions
diff --git a/sci-biology/sambamba/Manifest b/sci-biology/sambamba/Manifest
index c8fbec14b..3e3052479 100644
--- a/sci-biology/sambamba/Manifest
+++ b/sci-biology/sambamba/Manifest
@@ -1 +1,2 @@
-DIST sambamba-0.6.5.tar.gz 249275 BLAKE2B a01b2863053838c1fe7151e7baf3041c1396ad547ec962d495b8c486cc6f0cdfcbd1cc5c6963795017dfd77e27a605462aa11fb7043dcf2f6ad666e64ad8bbef SHA512 a0353523bb921a32e4f7601d9c5552b2103567cfa23fb622b213170028122f49cb6929942e9a630890ddd93b7ebf00f048344edb75d5f2d10b1c86bae018497c
+DIST b3692db46d2b23a7c0af2d5e69988c94f126e10a.tar.gz 320972 BLAKE2B e9af776d3a867f551e20c2a3c234f2c9a27e729b972a0b40e25eee830f1c2a2975fe939de68459fda6d56a1b3a63e26937cfbf77fcbb2b711ecdbc9385069d91 SHA512 f51c5332fdc5a74bcd4f9597b187721cc2f33bc535c374c0ff47f438f79f6bec382e20462bb90d8be5f6bdf02ff5d7b4f5bf358bba55e03211ee566035ef3fbd
+DIST sambamba-0.8.0.tar.gz 630637 BLAKE2B ea51a86bb546de3792e6d8bc0494aa2afe525d3914d1cc15ad8d52ca1acd2d109f726154273e98ef0e6144266fc34048f8c5008fe5c50be093b4082fb3fac1b5 SHA512 2d74c5ca3188fe0628b4873891eebecb1f514474bb1a2a8aca4ca3f40275acfb0fda0de5e11097754d317cac39b982b6ae45c5dde457cd83d6f684596ca5a5ac
diff --git a/sci-biology/sambamba/sambamba-0.6.5.ebuild b/sci-biology/sambamba/sambamba-0.6.5.ebuild
deleted file mode 100644
index ab2fb990e..000000000
--- a/sci-biology/sambamba/sambamba-0.6.5.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Parallell process SAM/BAM/CRAM files faster than samtools"
-HOMEPAGE="http://lomereiter.github.io/sambamba"
-SRC_URI="https://github.com/lomereiter/sambamba/archive/v0.6.5.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS=""
-IUSE="debug"
-
-# https://github.com/ldc-developers/gentoo-overlay/tree/master/dev-lang/ldc2
-#
-# contains bundled htslib
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-src_compile(){
- if use debug ; then
- emake sambamba-ldmd2-debug
- else
- emake sambamba-ldmd2-64
- fi
-}
diff --git a/sci-biology/sambamba/sambamba-0.8.0.ebuild b/sci-biology/sambamba/sambamba-0.8.0.ebuild
new file mode 100644
index 000000000..d6da97806
--- /dev/null
+++ b/sci-biology/sambamba/sambamba-0.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LZ4_COMMIT="b3692db46d2b23a7c0af2d5e69988c94f126e10a"
+
+DESCRIPTION="Parallell process SAM/BAM/CRAM files faster than samtools"
+HOMEPAGE="https://lomereiter.github.io/sambamba/"
+SRC_URI="https://github.com/lomereiter/sambamba/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/lz4/lz4/archive/${LZ4_COMMIT}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+
+# https://github.com/ldc-developers/gentoo-overlay/tree/master/dev-lang/ldc2
+#
+# contains bundled htslib
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ rm -r "${S}/lz4" || die
+ mv "${WORKDIR}/lz4-${LZ4_COMMIT}" "${S}/lz4" || die
+}
+
+src_compile(){
+ if use debug ; then
+ emake debug all
+ else
+ emake all
+ fi
+}
diff --git a/sci-biology/sambamba/sambamba-9999.ebuild b/sci-biology/sambamba/sambamba-9999.ebuild
index 8cd4c3ba2..e655b10b0 100644
--- a/sci-biology/sambamba/sambamba-9999.ebuild
+++ b/sci-biology/sambamba/sambamba-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3
DESCRIPTION="Parallell process SAM/BAM/CRAM files faster than samtools"
-HOMEPAGE="http://lomereiter.github.io/sambamba"
+HOMEPAGE="https://lomereiter.github.io/sambamba/"
EGIT_REPO_URI="https://github.com/lomereiter/sambamba.git"
LICENSE="GPL-2+"
@@ -21,8 +21,8 @@ RDEPEND="${DEPEND}"
src_compile(){
if use debug ; then
- emake sambamba-ldmd2-debug
+ emake debug all
else
- emake sambamba-ldmd2-64
+ emake all
fi
}