aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-03 16:39:18 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-03 16:39:18 +0100
commit6a99019c4da6610a402d95e133d556895e5d2ad7 (patch)
tree917df64a392b981d5ee0e718dd08614d0f58aadb
parentsci-biology/ABI-expression-data: remove RedundantLongDescription (diff)
downloadsci-6a99019c4da6610a402d95e133d556895e5d2ad7.tar.gz
sci-6a99019c4da6610a402d95e133d556895e5d2ad7.tar.bz2
sci-6a99019c4da6610a402d95e133d556895e5d2ad7.zip
sci-physics/mc-tester: EAPI bump, add pythia flag
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-physics/mc-tester/files/mc-tester-1.25.0-compare.sh.patch4
-rw-r--r--sci-physics/mc-tester/mc-tester-1.25.0.ebuild40
-rw-r--r--sci-physics/mc-tester/metadata.xml4
3 files changed, 23 insertions, 25 deletions
diff --git a/sci-physics/mc-tester/files/mc-tester-1.25.0-compare.sh.patch b/sci-physics/mc-tester/files/mc-tester-1.25.0-compare.sh.patch
index 180dcb029..bb8695fca 100644
--- a/sci-physics/mc-tester/files/mc-tester-1.25.0-compare.sh.patch
+++ b/sci-physics/mc-tester/files/mc-tester-1.25.0-compare.sh.patch
@@ -1,5 +1,5 @@
---- analyze/compare.sh
-+++ analyze/compare.sh
+--- a/analyze/compare.sh
++++ b/analyze/compare.sh
@@ -6,13 +6,14 @@
#----------------------------------
# Change these variables
diff --git a/sci-physics/mc-tester/mc-tester-1.25.0.ebuild b/sci-physics/mc-tester/mc-tester-1.25.0.ebuild
index d651961b9..5a08d1b3e 100644
--- a/sci-physics/mc-tester/mc-tester-1.25.0.ebuild
+++ b/sci-physics/mc-tester/mc-tester-1.25.0.ebuild
@@ -1,48 +1,53 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils
+MYPN="MC-TESTER"
-MYPN=MC-TESTER
+DOCS_BUILDER="doxygen"
+DOCS_DIR="doc"
+DOCS_DEPEND="media-gfx/graphviz"
+
+inherit docs
DESCRIPTION="Comparisons of Monte Carlo predictions in High Energy Physics"
HOMEPAGE="http://mc-tester.web.cern.ch/MC-TESTER/"
SRC_URI="http://mc-tester.web.cern.ch/MC-TESTER/${MYPN}-${PV}.tar.gz"
-LICENSE="CPC GPL-2+"
-#HepMC interface is licensed under GPL, other code under CPC
+#HepMC interface is licensed under GPL, other code under CPC
+LICENSE="CPC GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc examples hepmc"
+
+IUSE="examples hepmc pythia"
RDEPEND="sci-physics/root:=
hepmc? ( sci-physics/hepmc )
+ pythia? ( sci-physics/pythia:8 )
"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${MYPN}"
-src_prepare() {
- epatch "${FILESDIR}/${P}-compare.sh.patch"
-}
+PATCHES=(
+ "${FILESDIR}/${P}-compare.sh.patch"
+)
src_configure() {
econf \
--with-root="${EPREFIX}/usr" \
- --without-Pythia8 \
+ $(use_with pythia Pythia8 "${EPREFIX}/usr") \
$(use_with hepmc HepMC "${EPREFIX}/usr")
}
src_compile() {
+ docs_compile
default
- use doc && cd doc && default
}
src_install() {
- emake PREFIX="${D}/usr" install
+ default
newbin analyze/compare.sh mc-tester-compare
insinto /usr/libexec/${PN}/analyze
@@ -50,11 +55,6 @@ src_install() {
insinto /usr/share/${PN}
doins analyze/*.tex
- if use doc; then
- dohtml doc/doxygenDocs/html/*
- dodoc doc/{README*,USER-TESTS,tester.ps.gz}
- fi
-
use examples && dodoc -r examples-*
}
diff --git a/sci-physics/mc-tester/metadata.xml b/sci-physics/mc-tester/metadata.xml
index 53b89a9c9..521dff098 100644
--- a/sci-physics/mc-tester/metadata.xml
+++ b/sci-physics/mc-tester/metadata.xml
@@ -8,10 +8,8 @@
<email>sci-physics@gentoo.org</email>
<name>Gentoo Physics Project</name>
</maintainer>
- <longdescription>
-A universal tool for comparisons of Monte Carlo predictions in High Energy Physics
-</longdescription>
<use>
<flag name="hepmc">Compile <pkg>sci-physics/hepmc</pkg> interface</flag>
+ <flag name="pythia">Compile <pkg>sci-physics/pythiac</pkg> interface</flag>
</use>
</pkgmetadata>