aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-10-04 08:29:30 -0600
committerChristoph Junghans <ottxor@gentoo.org>2012-10-04 08:29:30 -0600
commit6bb45ca97b5bf1b6f258f73c59986c13966843b5 (patch)
tree6f205baec693ac0506644d35f36e95be8fed4a87
parentupdated package.mask (diff)
downloadsci-6bb45ca97b5bf1b6f258f73c59986c13966843b5.tar.gz
sci-6bb45ca97b5bf1b6f258f73c59986c13966843b5.tar.bz2
sci-6bb45ca97b5bf1b6f258f73c59986c13966843b5.zip
live ebuild update
(Portage version: 2.2.0_alpha135/git/Linux i686, unsigned Manifest commit)
-rw-r--r--app-doc/gromacs-manual/ChangeLog9
-rw-r--r--app-doc/gromacs-manual/gromacs-manual-4.6.9999.ebuild49
-rw-r--r--app-doc/gromacs-manual/gromacs-manual-9999.ebuild17
3 files changed, 67 insertions, 8 deletions
diff --git a/app-doc/gromacs-manual/ChangeLog b/app-doc/gromacs-manual/ChangeLog
index b9f148f17..338a2e38c 100644
--- a/app-doc/gromacs-manual/ChangeLog
+++ b/app-doc/gromacs-manual/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for app-doc/gromacs-manual
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*gromacs-manual-4.6.9999 (04 Oct 2012)
+
+ 04 Oct 2012; Christoph Junghans <ottxor@gentoo.org>
+ +gromacs-manual-4.6.9999.ebuild, gromacs-manual-9999.ebuild:
+ live ebuild update
+
25 Jun 2011; Justin Lecher <jlec@gentoo.org> gromacs-manual-9999.ebuild:
Merged
@@ -17,4 +23,3 @@
26 Aug 2010; Christoph Junghans <kleiner_otti@gmx.de>
+gromacs-manual-9999.ebuild, +metadata.xml:
initial commit
-
diff --git a/app-doc/gromacs-manual/gromacs-manual-4.6.9999.ebuild b/app-doc/gromacs-manual/gromacs-manual-4.6.9999.ebuild
new file mode 100644
index 000000000..43597e9ab
--- /dev/null
+++ b/app-doc/gromacs-manual/gromacs-manual-4.6.9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+EGIT_REPO_URI="git://git.gromacs.org/manual"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_BRANCH="master"
+else
+ EGIT_BRANCH="release-4-6"
+fi
+
+inherit cmake-utils git-2
+
+DESCRIPTION="Manual for gromacs"
+HOMEPAGE="http://www.gromacs.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ ~sci-chemistry/gromacs-${PV}
+ dev-texlive/texlive-latex
+ sys-apps/coreutils"
+RDEPEND=""
+
+src_prepare() {
+ local progs
+ progs=$(tr '\n' ' ' <${EROOT}usr/share/gromacs/programs.list) || die
+ sed \
+ -e "s/^\(PROGRAMS\).*/\1='${progs}'/" \
+ -e "/^INSTALLED_OPTIONS_PROGRAM_NAME/s!=.*!=${EROOT}usr/bin/g_options!" \
+ -i mkman || die "sed of mkman failed"
+ sed \
+ -e "s!\${GMXSRC}/admin/\(programs.txt\)!${EROOT}usr/share/gromacs/\1!" \
+ -e "s!\${GMXSRC}/share/html!${EROOT}usr/share/doc/gromacs-${PV}/html!" \
+ -e "s!\${GMXBIN}!${EROOT}usr/bin!" \
+ -e '/FATAL_ERROR.*GMX\(SRC\|BIN\)/s/^/#/' \
+ -i CMakeLists.txt || die "sed of CMakeLists.txt failed"
+}
+
+src_install() {
+ insinto /usr/share/doc/gromacs-${PV}
+ newins ${CMAKE_BUILD_DIR}/gromacs.pdf manual-${PV}.pdf
+}
diff --git a/app-doc/gromacs-manual/gromacs-manual-9999.ebuild b/app-doc/gromacs-manual/gromacs-manual-9999.ebuild
index c9f988336..43597e9ab 100644
--- a/app-doc/gromacs-manual/gromacs-manual-9999.ebuild
+++ b/app-doc/gromacs-manual/gromacs-manual-9999.ebuild
@@ -1,11 +1,15 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=4
EGIT_REPO_URI="git://git.gromacs.org/manual"
-EGIT_BRANCH="master"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_BRANCH="master"
+else
+ EGIT_BRANCH="release-4-6"
+fi
inherit cmake-utils git-2
@@ -21,15 +25,16 @@ IUSE=""
DEPEND="
~sci-chemistry/gromacs-${PV}
dev-texlive/texlive-latex
- sys-apps/coreutils
- app-shells/tcsh"
+ sys-apps/coreutils"
RDEPEND=""
src_prepare() {
local progs
progs=$(tr '\n' ' ' <${EROOT}usr/share/gromacs/programs.list) || die
- sed -i "s/^\(PROGRAMS\).*/\1='${progs}'/" mkman || die
- sed -i "s@^\(INSTALLED.*=\).*@\1${EROOT}usr/bin/g_options@" mkoptions || die
+ sed \
+ -e "s/^\(PROGRAMS\).*/\1='${progs}'/" \
+ -e "/^INSTALLED_OPTIONS_PROGRAM_NAME/s!=.*!=${EROOT}usr/bin/g_options!" \
+ -i mkman || die "sed of mkman failed"
sed \
-e "s!\${GMXSRC}/admin/\(programs.txt\)!${EROOT}usr/share/gromacs/\1!" \
-e "s!\${GMXSRC}/share/html!${EROOT}usr/share/doc/gromacs-${PV}/html!" \