aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-05-25 17:43:56 -0400
committerHorea Christian <chr@chymera.eu>2023-05-25 17:43:56 -0400
commit6cfe31e2407efdc5e61625117a16f46c8387cbb7 (patch)
treeb91b5b49e4398f3e3ffe26f3b5866fc08b411bfe
parentdev-vcs/dandi-cli: drop 0.50.0-r1 (diff)
downloadsci-6cfe31e2407efdc5e61625117a16f46c8387cbb7.tar.gz
sci-6cfe31e2407efdc5e61625117a16f46c8387cbb7.tar.bz2
sci-6cfe31e2407efdc5e61625117a16f46c8387cbb7.zip
app-office/visidata: add 2.11_p20230217
Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--app-office/visidata/Manifest1
-rw-r--r--app-office/visidata/visidata-2.11_p20230217.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/app-office/visidata/Manifest b/app-office/visidata/Manifest
index c4d7940c7..76f9256b2 100644
--- a/app-office/visidata/Manifest
+++ b/app-office/visidata/Manifest
@@ -1,2 +1,3 @@
DIST visidata-2.11.gh.tar.gz 1927455 BLAKE2B 95f868028fabb488f550b2ba15b60104a2d54dff972946ac38996d2906464e306e396adbf8dee32107aaf19a48d0e5d087aeeec82909e1d09b1d84b1e61138b7 SHA512 01512d47da329ba95aa7ceb5678a652fba5e06f6ff7ef0216b6271bf5b63a10712d425a2a1668ef6399b74f9fa9cb8d2d0f7bfa9316488ef5d64285ddcdde31a
+DIST visidata-2.11_p20230217.gh.tar.gz 2062327 BLAKE2B c7cd07ac816a31c2294d431c6426fc44f8a2cf015e7994d8b918c9e60cce2e7700ac77919c5a9e5c3ad5ccf41cb5b04e34fc84016a0c6faa8bd4e8e470275d0a SHA512 eaf2060c6fe6d1fed713cb0318d12233f279151a1a97b11ae3a7ccf07a065d716cf81872b76aa71a15dda3bfd85c09e7e03f9be2fae857f8edbded86e06b597f
DIST visidata-2.8.gh.tar.gz 1791958 BLAKE2B f7a7dec514bcca37b4ee6ee9c16eb07a625b83e601a5bcf1ca5589a462e50086cbd9997238230ac464b4dc77e9deb421d3ff0bcf0fa39b32f1c1ce0308d2cb7b SHA512 da9bce4e59054ea518024639a1f60d6f19886cd061a52aa49189d7478ea27950e6e97e0d1730456b65815f9298d0225bfcebe4bba5452e1a9a87f5f56aa11dc3
diff --git a/app-office/visidata/visidata-2.11_p20230217.ebuild b/app-office/visidata/visidata-2.11_p20230217.ebuild
new file mode 100644
index 000000000..a0993fff7
--- /dev/null
+++ b/app-office/visidata/visidata-2.11_p20230217.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..11} )
+
+inherit distutils-r1 optfeature
+
+MY_HASH="5ff7883563eeac32fe192c5b2d4290a4e1e91cc2"
+DESCRIPTION="Terminal spreadsheet multitool for discovering and arranging data"
+HOMEPAGE="http://visidata.org"
+SRC_URI="https://github.com/saulpw/visidata/archive/${MY_HASH}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/odfpy[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ $(python_gen_impl_dep sqlite)
+ )
+"
+
+S="${WORKDIR}/${PN}-${MY_HASH}"
+
+#distutils_enable_sphinx docs \
+# dev-python/recommonmark \
+# dev-python/sphinx-argparse
+# dev-python/sphinx-markdown-tables
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ rm tests/load-http.vd || die "Could not remove network-dependent test."
+ rm tests/graph-cursor-nosave.vd || die "Could not remove network-dependent test."
+ rm tests/messenger-nosave.vd || die "Could not remove network-dependent test."
+ rm tests/save-benchmarks.vd || die "Could not benchmarks test"
+ rm tests/graphpr-nosave.vd || die "Could not benchmarks test"
+ rm tests/describe-error.vd || die "Could not remove network-dependent test"
+ rm tests/describe.vd || die "Could not remove network-dependent test"
+ rm tests/edit-type.vd || die "Could not remove network-dependent test"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ git init || die "Git init failed."
+ git add tests/golden/ || die "Git add failed."
+ # this test script eventually calls pytest under the hood
+ dev/test.sh || die "Tests failed."
+ rm .git -rf || die "Could not clean up git test directory."
+}
+
+pkg_postinst() {
+ optfeature "integration with yaml" >=dev-python/pyyaml-5.1
+ optfeature "integration with pcap" dev-python/dnslib #dpkt pypcapkit
+ optfeature "integration with png" dev-python/pypng
+ optfeature "integration with http" dev-python/requests
+ optfeature "integration with postgres" dev-python/psycopg-binary
+ optfeature "integration with xlsx" dev-python/openpyxl
+ optfeature "integration with xls" dev-python/xlrd
+ optfeature "integration with hdf5" dev-python/h5py
+ optfeature "integration with ttf/otf" dev-python/fonttools
+ optfeature "integration with xml/htm/html" dev-python/lxml
+ optfeature "integration with dta (Stata)" dev-python/pandas
+ optfeature "integration with shapefiles" sci-libs/pyshp
+ optfeature "integration with namestand" dev-python/graphviz
+ optfeature "integration with pdfminer.six" dev-python/pdfminer-six # in guru
+ optfeature "integration with vobject" dev-python/vobject
+ optfeature "integration with tabulate" dev-python/tabulate
+ optfeature "integration with tabulate (with unicode)" dev-python/wcwidth
+ # optfeature "pdf tables" tabula # no package presently
+ #optfeature "integration with mbtiles" mapbox-vector-tile
+ #optfeature "integration with xpt (SAS)" xport
+ #optfeature "integration with sas7bdat (SAS)" sas7bdat
+ #optfeature "integration with sav (SPSS)" savReaderWriter
+}