aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-10-03 08:54:24 -0600
committerChristoph Junghans <ottxor@gentoo.org>2012-10-03 08:54:41 -0600
commit6d54a8c0ae0936c3108a4c1d5ee96f2e93caba0e (patch)
treea518900085af90f00fbc7e80e56e2147b9b584fb
parent[sci-mathematics/scilab] fix errors in previous commit (diff)
downloadsci-6d54a8c0ae0936c3108a4c1d5ee96f2e93caba0e.tar.gz
sci-6d54a8c0ae0936c3108a4c1d5ee96f2e93caba0e.tar.bz2
sci-6d54a8c0ae0936c3108a4c1d5ee96f2e93caba0e.zip
hybrid stuff got merged
(Portage version: 2.2.0_alpha134/git/Linux i686, unsigned Manifest commit)
-rw-r--r--sci-chemistry/gromacs/ChangeLog4
-rw-r--r--sci-chemistry/gromacs/gromacs-4.6.9999.ebuild12
-rw-r--r--sci-chemistry/gromacs/metadata.xml1
3 files changed, 7 insertions, 10 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index e597ab8bd..47636de82 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 03 Oct 2012; Christoph Junghans <ottxor@gentoo.org> gromacs-4.6.9999.ebuild,
+ metadata.xml:
+ hybrid stuff got merged
+
09 Aug 2012; Christoph Junghans <ottxor@gentoo.org> gromacs-4.6.9999.ebuild:
use ninja if available
diff --git a/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild b/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
index f54af37be..bbf4161d1 100644
--- a/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
@@ -23,7 +23,6 @@ if [[ $PV = *9999* ]]; then
git://github.com/gromacs/gromacs.git
http://repo.or.cz/r/gromacs.git"
EGIT_BRANCH="release-4-6"
- use hybrid && EGIT_BRANCH="nbnxn_hybrid_acc"
inherit git-2
else
SRC_URI="${SRC_URI} ftp://ftp.gromacs.org/pub/${PN}/${P}.tar.gz"
@@ -37,7 +36,7 @@ HOMEPAGE="http://www.gromacs.org/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="X blas cuda doc -double-precision +fftw gsl hybrid lapack
+IUSE="X blas cuda doc -double-precision +fftw gsl lapack
mpi openmp +single-precision test +threads xml zsh-completion ${ACCE_IUSE}"
CDEPEND="
@@ -61,7 +60,7 @@ RDEPEND="${CDEPEND}
RESTRICT="test"
-REQUIRED_USE="cuda? ( !double-precision hybrid )"
+REQUIRED_USE="cuda? ( !double-precision )"
pkg_pretend() {
[[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
@@ -122,7 +121,7 @@ src_configure() {
use avx256 && acce="AVX_256"
#workaround for now
- use sse2 && use hybrid && CFLAGS+=" -msse2"
+ use sse2 && CFLAGS+=" -msse2"
#to create man pages, build tree binaries are executed (bug #398437)
[[ ${CHOST} = *-darwin* ]] && \
@@ -225,9 +224,4 @@ pkg_postinst() {
einfo "For more Gromacs cool quotes (gcq) add g_luck to your .bashrc"
einfo
elog "Gromacs can use sci-chemistry/vmd to read additional file formats"
- if use hybrid; then
- elog "Cuda and hybrid acceleration is still experimental,"
- elog "use 'cutoff-scheme = Verlet' in your mdp file and"
- elog "report bugs: http://redmine.gromacs.org/issues"
- fi
}
diff --git a/sci-chemistry/gromacs/metadata.xml b/sci-chemistry/gromacs/metadata.xml
index dd3f082b0..acbcd53ae 100644
--- a/sci-chemistry/gromacs/metadata.xml
+++ b/sci-chemistry/gromacs/metadata.xml
@@ -9,7 +9,6 @@
<use>
<flag name="cuda">Enable cuda non-bonded kernels</flag>
<flag name="double-precision">More precise calculations at the expense of speed</flag>
- <flag name="hybrid">Enable hybrid acceleration kernels</flag>
<flag name="single-precision">Single precision version of gromacs (default)</flag>
<!-- acceleration optimization flags -->
<flag name="fkernels">Enable building of Fortran Kernels for platforms that dont have assembly loops</flag>