aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-02-08 14:17:11 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2016-02-08 14:17:11 +0100
commit6db8c7e7872771122bbacd7512f35685fc8c62e2 (patch)
tree50b3b0a81ef12cf7772d217455492b439399a5ac
parentMerge pull request #582 from TheChymera/nipy-extra (diff)
downloadsci-6db8c7e7872771122bbacd7512f35685fc8c62e2.tar.gz
sci-6db8c7e7872771122bbacd7512f35685fc8c62e2.tar.bz2
sci-6db8c7e7872771122bbacd7512f35685fc8c62e2.zip
dev-python/hdf5storage: Add new package, ebuild written by me
Package-Manager: portage-2.2.26
-rw-r--r--dev-python/hdf5storage/Manifest1
-rw-r--r--dev-python/hdf5storage/hdf5storage-0.1.11.ebuild22
-rw-r--r--dev-python/hdf5storage/hdf5storage-9999.ebuild21
-rw-r--r--dev-python/hdf5storage/metadata.xml23
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/hdf5storage/Manifest b/dev-python/hdf5storage/Manifest
new file mode 100644
index 000000000..5b5f79bad
--- /dev/null
+++ b/dev-python/hdf5storage/Manifest
@@ -0,0 +1 @@
+DIST hdf5storage-0.1.11.zip 112352 SHA256 1eb56cba56a057b4bb27e8547789376d130c1c589f5677d0a7b576524ff0de49 SHA512 c0d57223d7480c72685e158140b0f60b4832bbcc18cfecd7ea1dc5f1a59ae82286d5dedcccbac5834d7f455749df6be9ba9c6bcf58e69ecb874be5a84b87221b WHIRLPOOL de193d20784263d886be9452e55534fb4d98336b00b64df73610eb9be46a85129dd144f3431418406629656d81a0f402b17bafca4b0c25a62a21e846b0cb6e44
diff --git a/dev-python/hdf5storage/hdf5storage-0.1.11.ebuild b/dev-python/hdf5storage/hdf5storage-0.1.11.ebuild
new file mode 100644
index 000000000..9efada42e
--- /dev/null
+++ b/dev-python/hdf5storage/hdf5storage-0.1.11.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read/write Python types to/from HDF5 files, including MATLAB v7.3 MAT files"
+HOMEPAGE="https://github.com/frejanordsiek/hdf5storage"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}" \ No newline at end of file
diff --git a/dev-python/hdf5storage/hdf5storage-9999.ebuild b/dev-python/hdf5storage/hdf5storage-9999.ebuild
new file mode 100644
index 000000000..6d3215567
--- /dev/null
+++ b/dev-python/hdf5storage/hdf5storage-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Read/write Python types to/from HDF5 files, including MATLAB v7.3 MAT files"
+HOMEPAGE="https://github.com/frejanordsiek/hdf5storage"
+EGIT_REPO_URI="https://github.com/frejanordsiek/${PN}.git git://github.com/frejanordsiek/${PN}.git"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}" \ No newline at end of file
diff --git a/dev-python/hdf5storage/metadata.xml b/dev-python/hdf5storage/metadata.xml
new file mode 100644
index 000000000..320a9f946
--- /dev/null
+++ b/dev-python/hdf5storage/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ This Python package provides high level utilities to read/write a
+ variety of Python types to/from HDF5 (Heirarchal Data Format)
+ formatted files. This package also provides support for MATLAB MAT
+ v7.3 formatted files, which are just HDF5 files with a different
+ extension and some extra meta-data.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">hdf5storage</remote-id>
+ <remote-id type="github">frejanordsiek/hdf5storage</remote-id>
+ </upstream>
+</pkgmetadata>