aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-25 02:30:31 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-09-25 02:30:31 +0000
commit6fc3bed056f805686eb7bfaa4461373d178dfa33 (patch)
tree8bb6efa13ce86ac5c334f10d085043a2ab430a92
parentsci-libs/arrayfire: drop old version (diff)
downloadsci-6fc3bed056f805686eb7bfaa4461373d178dfa33.tar.gz
sci-6fc3bed056f805686eb7bfaa4461373d178dfa33.tar.bz2
sci-6fc3bed056f805686eb7bfaa4461373d178dfa33.zip
sci-libs/arrayfire: drop live version
Package-Manager: Portage-3.0.8, Repoman-3.0.1 RepoMan-Options: --force Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--sci-libs/arrayfire/Manifest1
-rw-r--r--sci-libs/arrayfire/arrayfire-9999.ebuild110
2 files changed, 0 insertions, 111 deletions
diff --git a/sci-libs/arrayfire/Manifest b/sci-libs/arrayfire/Manifest
index 6ed3ca518..574ad0051 100644
--- a/sci-libs/arrayfire/Manifest
+++ b/sci-libs/arrayfire/Manifest
@@ -1,2 +1 @@
DIST arrayfire-3.7.2.tar.bz2 53973398 BLAKE2B 33323516c4b708affb0d5457a55e4defae363b913b30d1c74a7b7d8956c9e85397a030c4c9e1b6e2605dd1703763b261beca9a5cfb69ff8a183cc95e51670748 SHA512 733f5931cca9397dd45945fde05d887207d11891fcc5ff0d2b5f30ac6bd4881240c595bd24d1d7b8f89c74e249b3fe16a15c2640586940bf101cd0fbaec998a6
-DIST gtest-1.7.0.zip 1164254 BLAKE2B ba8cf5dc336e3a6889b58922b62497cdac94d9f77bc5cbac3d72e4a88f33cbe572b6f61b5323acb7ea6dfc67f92c0ba231bedc5251c276831ea7a9e77ab6d570 SHA512 8859369f2dd32cbc2ac01aba029aa3ff20a321f40658b9643aff442d34c33468221866b801b28c66a28af47dbcd362d26941fc98db92b6efb7e41ea5b7be1a07
diff --git a/sci-libs/arrayfire/arrayfire-9999.ebuild b/sci-libs/arrayfire/arrayfire-9999.ebuild
deleted file mode 100644
index 356bccb0c..000000000
--- a/sci-libs/arrayfire/arrayfire-9999.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils git-r3 multilib
-
-GTEST_PV="1.7.0"
-
-DESCRIPTION="A general purpose GPU library"
-HOMEPAGE="http://www.arrayfire.com/"
-SRC_URI="test? ( https://github.com/google/googletest/archive/release-${GTEST_PV}.zip -> gtest-${GTEST_PV}.zip )"
-EGIT_REPO_URI="https://github.com/${PN}/${PN}.git git://github.com/${PN}/${PN}.git"
-
-LICENSE="
- BSD
- nonfree? ( OpenSIFT )"
-SLOT="0"
-IUSE="+examples +cpu cuda nonfree opencl test unified graphics"
-KEYWORDS=""
-
-RDEPEND="
- >=sys-devel/gcc-4.7:*
- media-libs/freeimage
- cuda? (
- >=dev-util/nvidia-cuda-toolkit-7.5.18-r1
- dev-libs/boost
- )
- cpu? (
- virtual/blas
- virtual/cblas
- virtual/lapacke
- sci-libs/fftw:3.0
- )
- opencl? (
- virtual/blas
- virtual/cblas
- virtual/lapacke
- >=sci-libs/clblas-2.4
- >=sci-libs/clfft-2.6.1
- dev-libs/boost
- || ( dev-libs/boost-compute >=dev-libs/boost-1.61.0 )
- )
- graphics? (
- media-libs/glew:=
- >=media-libs/glfw-3.1.1
- ~sci-visualization/forge-3.2.2
- )"
-DEPEND="${RDEPEND}"
-
-BUILD_DIR="${S}/build"
-CMAKE_BUILD_TYPE=Release
-
-# We need write acccess /dev/nvidiactl, /dev/nvidia0 and /dev/nvidia-uvm and the portage
-# user is (usually) not in the video group
-RESTRICT="userpriv"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ]] ) ; then
- die "Compilation with gcc older than 4.7 is not supported."
- fi
- fi
-}
-
-src_unpack() {
- git-r3_src_unpack
-
- if ! use nonfree; then
- find "${WORKDIR}" -name "*_nonfree*" -delete || die
- fi
-
- if use test; then
- mkdir -p "${BUILD_DIR}"/third_party/src/ || die
- cd "${BUILD_DIR}"/third_party/src/ || die
- unpack ${A}
- mv "${BUILD_DIR}"/third_party/src/gtest-"${GTEST_PV}" "${BUILD_DIR}"/third_party/src/googletest || die
- fi
-}
-
-src_configure() {
- if use cuda; then
- addwrite /dev/nvidiactl
- addwrite /dev/nvidia0
- addwrite /dev/nvidia-uvm
- fi
-
- local mycmakeargs=(
- -DBUILD_CPU="$(usex cpu)"
- -DBUILD_CUDA="$(usex cuda)"
- -DBUILD_OPENCL="$(usex opencl)"
- -DBUILD_EXAMPLES="$(usex examples)"
- -DBUILD_TEST="$(usex test)"
- -DBUILD_GRAPHICS="$(usex graphics)"
- -DBUILD_NONFREE="$(usex nonfree)"
- -DBUILD_UNIFIED="$(usex unified)"
- -DUSE_SYSTEM_BOOST_COMPUTE=ON
- -DUSE_SYSTEM_CLBLAS=ON
- -DUSE_SYSTEM_CLFFT=ON
- -DUSE_SYSTEM_FORGE=ON
- -DAF_INSTALL_CMAKE_DIR=/usr/$(get_libdir)/cmake/ArrayFire
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- dobin "${BUILD_DIR}/bin2cpp"
-}