aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-16 19:22:08 +0200
committerJustin Lecher <jlec@gentoo.org>2013-06-16 19:22:08 +0200
commit70c6bdd6914374ca8b505c4c843955e8289394d2 (patch)
tree86ebfe87cc17fd9cae836f0e22754aa0efc83852
parentMerge pull request #82 from ercpe/ercpe (diff)
downloadsci-70c6bdd6914374ca8b505c4c843955e8289394d2.tar.gz
sci-70c6bdd6914374ca8b505c4c843955e8289394d2.tar.bz2
sci-70c6bdd6914374ca8b505c4c843955e8289394d2.zip
sci-chemistry/shiftx2: Respect FLAGS
Package-Manager: portage-2.2.0_alpha180
-rw-r--r--sci-chemistry/shiftx2/ChangeLog8
-rw-r--r--sci-chemistry/shiftx2/metadata.xml10
-rw-r--r--sci-chemistry/shiftx2/shiftx2-1.07_p20120106.ebuild22
3 files changed, 28 insertions, 12 deletions
diff --git a/sci-chemistry/shiftx2/ChangeLog b/sci-chemistry/shiftx2/ChangeLog
new file mode 100644
index 000000000..5aafaf3ca
--- /dev/null
+++ b/sci-chemistry/shiftx2/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sci-chemistry/shiftx2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 16 Jun 2013; Justin Lecher <jlec@gentoo.org> shiftx2-1.07_p20120106.ebuild,
+ metadata.xml:
+ Respect FLAGS
+
diff --git a/sci-chemistry/shiftx2/metadata.xml b/sci-chemistry/shiftx2/metadata.xml
index 947e3461e..80444f44b 100644
--- a/sci-chemistry/shiftx2/metadata.xml
+++ b/sci-chemistry/shiftx2/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription>
+ <herd>sci</herd>
+ <longdescription>
SHIFTX2 predicts both the backbone and side chain 1H, 13C and 15N chemical
shifts for proteins using their structural (PDB) coordinates as input.
SHIFTX2 combines ensemble machine learning methods with sequence
@@ -33,7 +33,7 @@
prediction. Journal of Biomolecular NMR, Volume 50, Number 1, 43-57.
doi: 10.1007/s10858-011-9478-4.
</longdescription>
- <use>
- <flag name='debug'>Enables debug output in the shiftx2 java part</flag>
- </use>
+ <use>
+ <flag name="debug">Enables debug output in the shiftx2 java part</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-chemistry/shiftx2/shiftx2-1.07_p20120106.ebuild b/sci-chemistry/shiftx2/shiftx2-1.07_p20120106.ebuild
index e9cb4c73a..5a19e4b0b 100644
--- a/sci-chemistry/shiftx2/shiftx2-1.07_p20120106.ebuild
+++ b/sci-chemistry/shiftx2/shiftx2-1.07_p20120106.ebuild
@@ -25,12 +25,15 @@ CDEPEND="dev-util/weka"
RDEPEND="${CDEPEND}
dev-lang/R
+ sci-chemistry/reduce
>=virtual/jre-1.5"
DEPEND="${CDEPEND}
>=virtual/jdk-1.5"
S="${WORKDIR}"/${MY_P}
+QA_PREBUILT="/opt/.*"
+
src_prepare() {
epatch "${FILESDIR}/gentoo-fixes.patch"
rm "${S}"/src/FeatureRanges.java || die
@@ -43,7 +46,12 @@ src_prepare() {
fi
# hack alert!
- sed '/-o/s:$: -lm:g' -i "${S}/modules/resmf/Makefile" || die
+ sed \
+ -e '/-o/s:$(GCC):$(GCC) $(LDFLAGS):g' \
+ -e '/-o/s:$(CC):$(CC) $(LDFLAGS):g' \
+ -i modules/*/Makefile || die
+
+ sed -e '/-o/s:$: -lm:g' -i "${S}/modules/resmf/Makefile" || die
}
src_compile() {
@@ -65,7 +73,7 @@ src_compile() {
einfo "Building module effects"
cd "${S}"/modules/effects || die
emake clean
- emake CFLAGS="${CFLAGS}" GCC=$(tc-getCC) LINK="${LDFLAGS}" all
+ emake CFLAGS="${CFLAGS}" CC=$(tc-getCC) LINK="${LDFLAGS}" all
}
src_install() {
@@ -83,12 +91,11 @@ src_install() {
dodoc README 1UBQ.pdb
python_parallel_foreach_impl python_doscript "${S}"/*py
- # modules/angles
- cd "${S}"/modules/angles || die
- dobin get_angles phipsi
-
# other modules
- dobin "${S}"/modules/resmf/resmf "${S}"/modules/effects/caleffect
+ dobin \
+ "${S}"/modules/angles/{get_angles,phipsi} \
+ "${S}"/modules/resmf/resmf \
+ "${S}"/modules/effects/caleffect
# script
python_scriptinto ${instdir}/script
@@ -101,4 +108,5 @@ src_install() {
python_parallel_foreach_impl python_doscript "${S}"/shifty3/*py
exeinto ${instdir}/shifty3
doexe "${S}"/shifty3/xalign_x
+ dosym ../${PN}/shifty3/xalign_x /opt/bin/xalign_x
}