aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2014-07-06 22:28:45 +0200
committerOliver Freyermuth <o.freyermuth@googlemail.com>2014-07-06 22:28:45 +0200
commit713b71262098ac50a7be419cf485718858e77174 (patch)
tree77f3a2bfd18737f3a1ff3a061bc2fe899866f1fe
parentNnot available anymore (diff)
downloadsci-713b71262098ac50a7be419cf485718858e77174.tar.gz
sci-713b71262098ac50a7be419cf485718858e77174.tar.bz2
sci-713b71262098ac50a7be419cf485718858e77174.zip
New live ebuild, using cmake-buildsystem (upstream switches to cmake for next release), add flags for g4root and mtroot. Adapt to upstream's fixes concerning install paths, we don't need to do manually installation anymore.
I will skip geant-vmc-3.00b01 from packaging, it does not include those fixes yet.
-rw-r--r--sci-physics/geant-vmc/ChangeLog8
-rw-r--r--sci-physics/geant-vmc/geant-vmc-9999.ebuild79
-rw-r--r--sci-physics/geant-vmc/metadata.xml3
3 files changed, 90 insertions, 0 deletions
diff --git a/sci-physics/geant-vmc/ChangeLog b/sci-physics/geant-vmc/ChangeLog
index 353b8417e..807b464c9 100644
--- a/sci-physics/geant-vmc/ChangeLog
+++ b/sci-physics/geant-vmc/ChangeLog
@@ -2,6 +2,14 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*geant-vmc-9999 (06 Jul 2014)
+
+ 06 Jul 2014; Oliver Freyermuth <o.freyermuth@googlemail.com>
+ +geant-vmc-9999.ebuild, metadata.xml:
+ New live ebuild, using cmake-buildsystem (upstream switches to cmake for next
+ release), add flags for g4root and mtroot. Adapt to upstream's fixes
+ concerning install paths, we don't need to do manually installation anymore.
+
31 Mar 2014; Oliver Freyermuth <o.freyermuth@googlemail.com>
geant-vmc-3.1.15a.ebuild:
Fix syntax bug in dependency atom
diff --git a/sci-physics/geant-vmc/geant-vmc-9999.ebuild b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
new file mode 100644
index 000000000..fa8fa5592
--- /dev/null
+++ b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils versionator git-r3
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI=" http://root.cern.ch/git/geant4_vmc.git"
+ KEYWORDS=""
+else
+ MPV=$(get_version_component_range 2-)
+ SRC_URI="ftp://root.cern.ch/root/vmc/geant4_vmc.${MPV}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Virtual Monte Carlo Geant4 implementation"
+HOMEPAGE="http://root.cern.ch/root/vmc/VirtualMC.html"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="doc examples geant3 +g4root +mtroot vgm"
+
+RDEPEND="
+ sci-physics/root:=
+ >=sci-physics/geant-4.9.6[opengl,geant3?]
+ vgm? ( >=sci-physics/vgm-4.00 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use vgm Geant4VMC_USE_VGM)
+ $(cmake-utils_use geant3 Geant4VMC_USE_GEANT4_G3TOG4)
+ $(cmake-utils_use g4root Geant4VMC_USE_G4Root)
+ $(cmake-utils_use mtroot Geant4VMC_USE_MTRoot)
+ $(cmake-utils_use examples Geant4VMC_INSTALL_EXAMPLES)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ local dirs="g4root mtroot source"
+ use g4root && dirs+=" g4root "
+ use mtroot && dirs+=" mtroot "
+ use examples && dirs+=" examples "
+ local d
+ for d in ${dirs}; do
+ pushd ${d} > /dev/null || die
+ if use doc; then
+ doxygen || die
+ fi
+ popd > /dev/null
+ done
+}
+
+src_test() {
+ cd examples || die
+ local origDir=${CMAKE_USE_DIR}
+ CMAKE_USE_DIR=${CMAKE_USE_DIR}/examples
+ CMAKE_IN_SOURCE_BUILD=1
+ CMAKE_MODULE_PATH=../cmake
+ local mycmakeargs=(
+ -DCMAKE_MODULE_PATH=${origDir}/cmake
+ )
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ ./run_suite.sh || die
+ CMAKE_IN_SOURCE_BUILD=0
+ CMAKE_USE_DIR=$origDir
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README history version_number
+ use doc && dohtml -r Geant4VMC.html doc/*
+}
diff --git a/sci-physics/geant-vmc/metadata.xml b/sci-physics/geant-vmc/metadata.xml
index 1bbc127a3..828e0454c 100644
--- a/sci-physics/geant-vmc/metadata.xml
+++ b/sci-physics/geant-vmc/metadata.xml
@@ -15,5 +15,8 @@
</longdescription>
<use>
<flag name="vgm">Enable the Virtual Geometry Model (<pkg>sci-physics/vgm</pkg>)</flag>
+ <flag name="g4root">Build G4Root (interface for GEANT4 simulation with a ROOT geometry)</flag>
+ <flag name="geant3">Build with Geant4 G3toG4 library</flag>
+ <flag name="mtroot">Build MTRoot (provides ROOT IO manager classes with multi-threading support)</flag>
</use>
</pkgmetadata>