aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-01-07 21:39:33 +0100
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2015-01-07 21:39:33 +0100
commit7286213decca43e6185a611dc357a71557fd84c9 (patch)
treed4be0161876fd8898fb3a754cb8204eed7acee3c
parentadded live version (diff)
downloadsci-7286213decca43e6185a611dc357a71557fd84c9.tar.gz
sci-7286213decca43e6185a611dc357a71557fd84c9.tar.bz2
sci-7286213decca43e6185a611dc357a71557fd84c9.zip
sci-biology/ICC: initial ebuild, perl installation steps need to be fixed
-rw-r--r--sci-biology/ICC/ChangeLog9
-rw-r--r--sci-biology/ICC/ICC-2.0.1.ebuild61
-rw-r--r--sci-biology/ICC/Manifest1
-rw-r--r--sci-biology/ICC/metadata.xml9
4 files changed, 80 insertions, 0 deletions
diff --git a/sci-biology/ICC/ChangeLog b/sci-biology/ICC/ChangeLog
new file mode 100644
index 000000000..cd415fd43
--- /dev/null
+++ b/sci-biology/ICC/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-biology/ICC
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*ICC-2.0.1 (07 Jan 2015)
+
+ 07 Jan 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> +ICC-2.0.1.ebuild:
+ initial ebuild, perl installation steps need to be fixed
+
diff --git a/sci-biology/ICC/ICC-2.0.1.ebuild b/sci-biology/ICC/ICC-2.0.1.ebuild
new file mode 100644
index 000000000..5e5fb5cbd
--- /dev/null
+++ b/sci-biology/ICC/ICC-2.0.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Error corrector for Roche/454 and IonTorrent data with indel and carryforward, SNP and haplotype calling"
+HOMEPAGE="http://indra.mullins.microbiol.washington.edu/ICC"
+SRC_URI="http://indra.mullins.microbiol.washington.edu/cgi-bin/ICC/info.cgi?ID=ICC_v2.0.1.zip -> ICC_v2.0.1.zip"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-lang/perl
+ sci-biology/ncbi-tools++"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_install(){
+ dobin Scripts/*.pl
+ dodoc README.txt
+
+ # BUG: does not work
+ cd Scripts/lib || die
+ perl-module_src_install DESTDIR="${D}" *.pm Parallel/ForkManager.pm # install into @INC path
+
+}
+
+# testing: Blast/Linux/LICENSE OK
+# testing: Example/exampleReads.fas OK
+# testing: Example/exampleReads.qual OK
+# testing: Example/exampleReference.fas OK
+# testing: README.md OK
+# testing: README.txt OK
+# testing: Scripts/ OK
+# testing: Scripts/CC.pl OK
+# testing: Scripts/HIC.pl OK
+# testing: Scripts/IC.pl OK
+# testing: Scripts/alignRegion.pl OK
+# testing: Scripts/config.pl OK
+# testing: Scripts/lib/ OK
+# testing: Scripts/lib/.DS_Store OK
+# testing: Scripts/lib/Parallel/ OK
+# testing: Scripts/lib/Parallel/ForkManager.pm OK
+# testing: Scripts/lib/paths.pm OK
+# testing: Scripts/lib/seqAlign.pm OK
+# testing: Scripts/lib/utils.pm OK
+# testing: Scripts/ntFreq.pl OK
+# testing: Scripts/readQualFilter.pl OK
+# testing: Scripts/retrieveRegion.pl OK
+# testing: Scripts/retrieveWindows.pl OK
+# testing: Scripts/runBLAST.pl OK
+# testing: Scripts/runICC.pl OK
+# testing: Scripts/uniqueReads.pl OK
+# testing: VersionHistory.txt OK
+
diff --git a/sci-biology/ICC/Manifest b/sci-biology/ICC/Manifest
new file mode 100644
index 000000000..375391637
--- /dev/null
+++ b/sci-biology/ICC/Manifest
@@ -0,0 +1 @@
+DIST ICC_v2.0.1.zip 63756669 SHA256 475eb33c8a9c49babc746823a988494f645f2d437ddb46c6988fbd14df39b833 SHA512 2952c5489e81f0702d3854a5a6f9591c4674b559a58be647bcd24c9837e8208ed1187721063a95abc120dffd860e13bd996a4f89f5e90de2d56ccd3750cce42e WHIRLPOOL 23bad2bf3daef731a5ffe967fe99e2dac698131f6b5e7becc2e9f4eaf3e9aa791f34b346382c84247f08e6717c07977c2e0104b1adb6877db6f29129ea4b4b43
diff --git a/sci-biology/ICC/metadata.xml b/sci-biology/ICC/metadata.xml
new file mode 100644
index 000000000..2bc893037
--- /dev/null
+++ b/sci-biology/ICC/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <maintainer>
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+</pkgmetadata>