aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-05 19:58:20 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-05 19:58:20 +0100
commit74bee558a76964dd78bcd11e37b42d97382183b0 (patch)
tree9dcc3705a8a86ca05e08df7de1767643064a20d6
parentsci-biology/conrad: works just fine with jdk-1.8 (diff)
downloadsci-74bee558a76964dd78bcd11e37b42d97382183b0.tar.gz
sci-74bee558a76964dd78bcd11e37b42d97382183b0.tar.bz2
sci-74bee558a76964dd78bcd11e37b42d97382183b0.zip
sci-chemistry/cs-rossetta: dep was removed
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-chemistry/cs-rosetta/Manifest3
-rw-r--r--sci-chemistry/cs-rosetta/cs-rosetta-1.01.2009.1109.11.ebuild103
-rw-r--r--sci-chemistry/cs-rosetta/metadata.xml8
3 files changed, 0 insertions, 114 deletions
diff --git a/sci-chemistry/cs-rosetta/Manifest b/sci-chemistry/cs-rosetta/Manifest
deleted file mode 100644
index 69a3f17b1..000000000
--- a/sci-chemistry/cs-rosetta/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST cs-rosetta-1.01.2009.1109.11-changelog 953 BLAKE2B ea99d07f24ce2bc4f9607ed3cff0f56a1eafad1611d02e8faf9a556077c81b84d66e10ce929221215072864477d845ec52114e6b0d1b0b1179027b507e65cc34 SHA512 dee6ffdb448dbd35f26f9fc1d1db4095fe445c833bd7c5d7a6aa37edc1ae526d6ba6e851aa83ee8204e5aa262b01c88684161f507f5db5eff6ac8d008dd09012
-DIST cs-rosetta-1.01.2009.1109.11-install.com 12420 BLAKE2B 46695218b5ac1a5cc5602c88de5097a80dfb3dc11fd50784e879771b4e386a13076ac51f2ae47489261228126f37abf607f6b68c6dd402c2fd8b4e7e90d71c79 SHA512 dc7ae15bef5fe591a5a11418c5eb203a39fba961da0a130ea6960e16a5c678af1b3a94cb7aef2c5ca3faa600fe9d1b8e31440b35b68b1f090597e261f8de76c9
-DIST cs-rosetta-1.01.2009.1109.11.tar.Z 15461998 BLAKE2B 1b81e2d8ca2298b174a4b5811f8cc2d7b110f4f15e4417be3fd6c82205095ab303a99b197fe063bc000b68d3d1abbb9f8508abcd9f32c7e81eb1d522530a9c57 SHA512 6c4872ca7e7fffa1de99b6c8447953bceaf226f24e02ceb4a2e6019aaaa52d6ae0393c55a8276b060e317980b051da19943879e5341020ec1ab2b42175e42aa1
diff --git a/sci-chemistry/cs-rosetta/cs-rosetta-1.01.2009.1109.11.ebuild b/sci-chemistry/cs-rosetta/cs-rosetta-1.01.2009.1109.11.ebuild
deleted file mode 100644
index 74cf932d8..000000000
--- a/sci-chemistry/cs-rosetta/cs-rosetta-1.01.2009.1109.11.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit flag-o-matic fortran-2 toolchain-funcs
-
-DESCRIPTION="System for chemical shifts based protein structure prediction using ROSETTA"
-HOMEPAGE="http://spin.niddk.nih.gov/bax/software/CSROSETTA/"
-SRC_URI="
- http://spin.niddk.nih.gov/bax/software/CSROSETTA/install.com -> ${P}-install.com
- http://spin.niddk.nih.gov/bax/software/CSROSETTA/CSRosetta.tar.Z -> ${P}.tar.Z
- http://spin.niddk.nih.gov/bax/software/CSROSETTA/changeLog -> ${P}-changelog"
-
-SLOT="0"
-LICENSE="all-rights-reserved"
-KEYWORDS=""
-IUSE="custom-cflags"
-
-RDEPEND="
- dev-lang/perl
- || ( sci-biology/update-blastdb sci-biology/ncbi-tools++ )
- sci-biology/profphd
- sci-biology/psipred
- sci-biology/samtools
- ~sci-libs/cs-rosetta-db-${PV}
- sci-chemistry/nmrpipe
- sci-chemistry/rosetta"
-DEPEND=""
-
-S="${WORKDIR}"
-
-src_unpack() {
- unpack ${P}.tar.Z
-}
-
-src_prepare() {
- cat >> "${T}"/39${PN} <<- EOF
- rosetta3="${EPREFIX}/usr/bin/AbinitioRelax"
- rosetta3_extpdbs="${EPREFIX}/usr/bin/extract_pdbs"
- rosetta3DB="${EPREFIX}/usr/share/rosetta-db"
- csrosettaDir="${EPREFIX}/opt/${PN}"
- csrosettaCom="${EPREFIX}/opt/${PN}/com"
- PATH="${EPREFIX}/opt/${PN}/com"
- MFR="${EPREFIX}/opt/${PN}/com/mfr.tcl"
- EOF
-
- # needs more love
- sed \
- -e "s:CSROSETTA_DIR/src/nnmake/pNNMAKE.gnu:${EPREFIX}/opt/${PN}/src/nnmake/pNNMAKE:g" \
- -i com/make_fragments_2000.pl || die
-
- append-fflags -ffixed-line-length-132
-}
-
-src_compile() {
- use custom-cflags || CXXFLAGS="-pipe -ffor-scope -fno-exceptions -O3 -ffast-math -funroll-loops -finline-functions -finline-limit=20000"
-
- compilation() {
- if [[ -f dipolar_nn.f ]]; then
- sed \
- -e '/write/s:(i,6f6.3):(i3,6(1x,f6.3)):g' \
- -i dipolar_nn.f || die
- fi
-
- sed \
- -e '/LDFLAGS/s: = : ?= :g' \
- -e '/CCFLAGS/s: = : += :g' \
- -e 's:$(OBJECT) $(LDFLAGS):$(LDFLAGS) $(OBJECT) -lm -o:g' \
- -e 's:$(FFLAGS) -o:$(FFLAGS) $(LDFLAGS) -o:g' \
- -e '/make.system/d' \
- -i *akefile || die
- emake \
- CC=$(tc-getCXX) \
- CCFLAGS="${CXXFLAGS}"
-
- if [[ -f pNNMAKE. ]]; then
- mv pNNMAKE{.,} || die
- emake almostsuperclean
- else
- emake clean
- fi
- }
-
- for i in src/{mfr2rosetta,SPARTA/src,pdbrms,TALOS,rosettaFrag2csFrag,nnmake}; do
- pushd ${i} > /dev/null
- compilation
- popd > /dev/null
- done
-}
-
-src_install() {
- insinto /opt/${PN}/
- doins -r *
- chmod 755 \
- "${ED}"/opt/${PN}/com/* \
- "${ED}"/opt/${PN}/src/{mfr2rosetta/mfr2rosetta,SPARTA/src/SPARTA,pdbrms/pdbrms,TALOS/TALOS,rosettaFrag2csFrag/rosettaFrag2csFrag,nnmake/pNNMAKE} \
- || die
-
- dosym make_fragments_2000.pl /opt/${PN}/com/make_fragment_2000.pl
-
- doenvd "${T}"/39${PN}
-}
diff --git a/sci-chemistry/cs-rosetta/metadata.xml b/sci-chemistry/cs-rosetta/metadata.xml
deleted file mode 100644
index da36ecbfc..000000000
--- a/sci-chemistry/cs-rosetta/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-chemistry@gentoo.org</email>
- <name>Gentoo Chemistry Project</name>
- </maintainer>
-</pkgmetadata>