aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-11-14 12:41:04 +0100
committerJustin Lecher <jlec@gentoo.org>2014-11-14 12:41:04 +0100
commit74f1bc3d01d6297542c6a28bd87c05bbab8abb45 (patch)
treed25857f392323751be405be2129f3a57e71c6d02
parentsci-chemistry/phenix-bin: Fix dep SLOT of sys-libs/db (diff)
parentsync with gx86 (diff)
downloadsci-74f1bc3d01d6297542c6a28bd87c05bbab8abb45.tar.gz
sci-74f1bc3d01d6297542c6a28bd87c05bbab8abb45.tar.bz2
sci-74f1bc3d01d6297542c6a28bd87c05bbab8abb45.zip
Merge remote-tracking branch 'github/master'
* github/master: sync with gx86 deps on boost:= deps on boost:=
-rw-r--r--sci-libs/votca-tools/ChangeLog3
-rw-r--r--sci-libs/votca-tools/votca-tools-9999.ebuild2
-rw-r--r--sci-physics/espresso++/ChangeLog6
-rw-r--r--sci-physics/espresso++/espresso++-9999.ebuild10
4 files changed, 13 insertions, 8 deletions
diff --git a/sci-libs/votca-tools/ChangeLog b/sci-libs/votca-tools/ChangeLog
index fb3e7d8f4..aa842b429 100644
--- a/sci-libs/votca-tools/ChangeLog
+++ b/sci-libs/votca-tools/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 13 Nov 2014; Christoph Junghans <ottxor@gentoo.org> votca-tools-9999.ebuild:
+ deps on boost:=
+
31 Aug 2014; Christoph Junghans <ottxor@gentoo.org> votca-tools-9999.ebuild:
sync with gx86
diff --git a/sci-libs/votca-tools/votca-tools-9999.ebuild b/sci-libs/votca-tools/votca-tools-9999.ebuild
index 9d964a023..781687917 100644
--- a/sci-libs/votca-tools/votca-tools-9999.ebuild
+++ b/sci-libs/votca-tools/votca-tools-9999.ebuild
@@ -28,7 +28,7 @@ IUSE="doc +fftw +gsl sqlite"
RDEPEND="fftw? ( sci-libs/fftw:3.0 )
dev-libs/expat
gsl? ( sci-libs/gsl )
- dev-libs/boost
+ dev-libs/boost:=
sqlite? ( dev-db/sqlite:3 )"
DEPEND="${RDEPEND}
diff --git a/sci-physics/espresso++/ChangeLog b/sci-physics/espresso++/ChangeLog
index 6e1cd3da7..dd0c03d0f 100644
--- a/sci-physics/espresso++/ChangeLog
+++ b/sci-physics/espresso++/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 13 Nov 2014; Christoph Junghans <ottxor@gentoo.org> espresso++-9999.ebuild:
+ sync with gx86
+
+ 13 Nov 2014; Christoph Junghans <ottxor@gentoo.org> espresso++-9999.ebuild:
+ deps on boost:=
+
25 Aug 2014; Christoph Junghans <ottxor@gentoo.org> espresso++-9999.ebuild:
sync with gx86
diff --git a/sci-physics/espresso++/espresso++-9999.ebuild b/sci-physics/espresso++/espresso++-9999.ebuild
index 2c2e73926..d21c13398 100644
--- a/sci-physics/espresso++/espresso++-9999.ebuild
+++ b/sci-physics/espresso++/espresso++-9999.ebuild
@@ -7,14 +7,13 @@ EAPI=5
PYTHON_COMPAT=( python2_7 )
CMAKE_MAKEFILE_GENERATOR="ninja"
-inherit cmake-utils multilib python-single-r1
+inherit cmake-utils python-single-r1
DESCRIPTION="extensible, flexible, fast and parallel simulation software for soft matter research"
HOMEPAGE="https://www.espresso-pp.de"
if [[ ${PV} = 9999 ]]; then
EHG_REPO_URI="https://bitbucket.org/${PN//+/p}/${PN//+/p}"
- EHG_REVISION="default"
inherit mercurial
KEYWORDS=
else
@@ -32,18 +31,15 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
virtual/mpi
- dev-libs/boost[python,mpi,${PYTHON_USEDEP}]
+ dev-libs/boost:=[python,mpi,${PYTHON_USEDEP}]
sci-libs/fftw:3.0
dev-python/mpi4py"
DEPEND="${RDEPEND}"
-DOCS=( AUTHORS NEWS README )
-
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DEXTERNAL_BOOST=ON
-DEXTERNAL_MPI4PY=ON
- -DLIB="$(get_libdir)"
-DWITH_RC_FILES=OFF
)
cmake-utils_src_configure